summaryrefslogtreecommitdiff
path: root/gnu/packages/selinux.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/selinux.scm')
-rw-r--r--gnu/packages/selinux.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/selinux.scm b/gnu/packages/selinux.scm
index d898b55129..c45570744a 100644
--- a/gnu/packages/selinux.scm
+++ b/gnu/packages/selinux.scm
@@ -162,7 +162,11 @@ module into a binary representation.")
;; Python bindings. Instruct it to use the correct output.
(substitute* "src/Makefile"
(("--prefix=\\$\\(PREFIX\\)")
- (string-append "--prefix=" #$output:python)))
+ (string-append "--prefix=" #$output:python
+ ;; Python 3.10 refuses to execute the install
+ ;; command unless these flags are present.
+ " --single-version-externally-managed"
+ " --root=/")))
(apply invoke "make" "install-pywrap" make-flags)))))))
;; These libraries are in "Requires.private" in libselinux.pc.