summaryrefslogtreecommitdiff
path: root/gnu/packages/selinux.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/selinux.scm')
-rw-r--r--gnu/packages/selinux.scm9
1 files changed, 7 insertions, 2 deletions
diff --git a/gnu/packages/selinux.scm b/gnu/packages/selinux.scm
index 5c0cbfa639..1502d167c4 100644
--- a/gnu/packages/selinux.scm
+++ b/gnu/packages/selinux.scm
@@ -106,12 +106,17 @@ boolean settings).")
(arguments
`(#:tests? #f ; there is no check target
#:make-flags
- (let ((out (assoc-ref %outputs "out")))
+ (let ((out (assoc-ref %outputs "out"))
+ (target ,(%current-target-system)))
(list (string-append "PREFIX=" out)
(string-append "LIBSEPOLA="
(assoc-ref %build-inputs "libsepol")
"/lib/libsepol.a")
- "CC=gcc"))
+ (string-append "CC="
+ (if target
+ (string-append (assoc-ref %build-inputs "cross-gcc")
+ "/bin/" target "-gcc")
+ "gcc"))))
#:phases
(modify-phases %standard-phases
(delete 'configure)