summaryrefslogtreecommitdiff
path: root/gnu/packages/serialization.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/serialization.scm')
-rw-r--r--gnu/packages/serialization.scm88
1 files changed, 83 insertions, 5 deletions
diff --git a/gnu/packages/serialization.scm b/gnu/packages/serialization.scm
index 8df4841eae..f721165751 100644
--- a/gnu/packages/serialization.scm
+++ b/gnu/packages/serialization.scm
@@ -8,7 +8,8 @@
;;; Copyright © 2017 Gregor Giesen <giesen@zaehlwerk.net>
;;; Copyright © 2017 Frederick M. Muriithi <fredmanglis@gmail.com>
;;; Copyright © 2017 ng0 <ng0@infotropique.org>
-;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2018 Joshua Sierles, Nextjournal <joshua@nextjournal.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -32,17 +33,21 @@
#:use-module (guix utils)
#:use-module (guix build-system cmake)
#:use-module (guix build-system gnu)
+ #:use-module (guix build-system python)
+ #:use-module (guix build-system r)
#:use-module (gnu packages)
#:use-module (gnu packages autotools)
#:use-module (gnu packages boost)
#:use-module (gnu packages check)
#:use-module (gnu packages compression)
+ #:use-module (gnu packages cran)
+ #:use-module (gnu packages databases)
#:use-module (gnu packages documentation)
#:use-module (gnu packages lua)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
#:use-module (gnu packages perl)
- #:use-module (guix build-system python))
+ #:use-module (gnu packages statistics))
(define-public cereal
(package
@@ -70,7 +75,8 @@
(lambda _
(substitute* "doc/doxygen.in"
(("@CMAKE_CURRENT_SOURCE_DIR@") "."))
- (zero? (system* "doxygen" "doc/doxygen.in"))))
+ (invoke "doxygen" "doc/doxygen.in")
+ #t))
;; There is no "install" target, so we have to provide our own
;; "install" phase.
(replace 'install
@@ -131,8 +137,9 @@ such as compact binary encodings, XML, or JSON.")
(modify-phases %standard-phases
(add-after 'unpack 'autoconf
(lambda _
- (system* "autoreconf" "-vfi"))))))
- (home-page "http://www.msgpack.org")
+ (invoke "autoreconf" "-vfi")
+ #t)))))
+ (home-page "https://www.msgpack.org")
(synopsis "Binary serialization library")
(description "Msgpack is a library for C/C++ that implements binary
serialization.")
@@ -409,3 +416,74 @@ JSON's ability, but serializes to a binary format which is smaller and faster
to generate and parse. The two primary functions are @code{cbor.loads} and
@code{cbor.dumps}.")
(license license:asl2.0)))
+
+(define-public flatbuffers
+ (package
+ (name "flatbuffers")
+ (version "1.8.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/google/flatbuffers/archive/v"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0blc978wc5h91662vai24xj92c3bx56y6hzid90qva7il302jl64"))))
+ (build-system cmake-build-system)
+ (arguments
+ '(#:build-type "Release"
+ #:configure-flags
+ (list (string-append "-DCMAKE_INSTALL_LIBDIR="
+ (assoc-ref %outputs "out") "/lib"))))
+ (home-page "https://google.github.io/flatbuffers/")
+ (synopsis "Memory-efficient serialization library")
+ (description "FlatBuffers is a cross platform serialization library for C++,
+C#, C, Go, Java, JavaScript, PHP, and Python. It was originally created for
+game development and other performance-critical applications.")
+ (license license:asl2.0)))
+
+(define-public r-feather
+ (package
+ (name "r-feather")
+ (version "0.3.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "feather" version))
+ (sha256
+ (base32
+ "1q6dbkfnkpnabq8lb6bm9ma44cfcghx2lm23pyk3vg7943wrn1pi"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-hms" ,r-hms)
+ ("r-rcpp" ,r-rcpp)
+ ("r-tibble" ,r-tibble)))
+ (home-page "https://github.com/wesm/feather")
+ (synopsis "R Bindings to the Feather API")
+ (description "Read and write feather files, a lightweight binary columnar
+daa store designed for maximum speed.")
+ (license license:asl2.0)))
+
+(define-public python-feather-format
+ (package
+ (name "python-feather-format")
+ (version "0.4.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "feather-format" version))
+ (sha256
+ (base32
+ "1adivm5w5ji4qv7hq7942vqlk8l2wgw87bdlsia771z14z3zp857"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-pandas" ,python-pandas)
+ ("python-pyarrow" ,python-pyarrow)))
+ (home-page "https://github.com/wesm/feather")
+ (synopsis "Python wrapper to the Feather file format")
+ (description "This package provides a Python wrapper library to the
+Apache Arrow-based Feather binary columnar serialization data frame format.")
+ (license license:asl2.0)))
+
+(define-public python2-feather-format
+ (package-with-python2 python-feather-format))