summaryrefslogtreecommitdiff
path: root/gnu/packages/shells.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/shells.scm')
-rw-r--r--gnu/packages/shells.scm18
1 files changed, 13 insertions, 5 deletions
diff --git a/gnu/packages/shells.scm b/gnu/packages/shells.scm
index 8042fab12f..8d2aadc0aa 100644
--- a/gnu/packages/shells.scm
+++ b/gnu/packages/shells.scm
@@ -543,14 +543,14 @@ ksh, and tcsh.")
(define-public xonsh
(package
(name "xonsh")
- (version "0.14.0")
+ (version "0.14.2")
(source
(origin
(method url-fetch)
(uri (pypi-uri "xonsh" version))
(sha256
(base32
- "1wcv1sk8igs5kb9fqb8njbxwiqbwzpn0kdx9xkaddq3wn6msma25"))
+ "0fddxzd45zvfr687mvd90f5s376yz0a8ln7qbpl94q89z7l0y77k"))
(modules '((guix build utils)))
(snippet
#~(begin
@@ -789,7 +789,7 @@ The OpenBSD Korn Shell is a cleaned up and enhanced ksh.")
(define-public loksh
(package
(name "loksh")
- (version "7.3")
+ (version "7.4")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -801,7 +801,7 @@ The OpenBSD Korn Shell is a cleaned up and enhanced ksh.")
(file-name (git-file-name name version))
(sha256
(base32
- "1miydvb79wagckchinp189l8i81f08lqajg5jngn77m4x4gwjf3n"))))
+ "0arbncmgs3wzkwlqzp5za8rwh9px2r5mn3i979rabc4cms1bs0l1"))))
(build-system meson-build-system)
(inputs (list ncurses))
(native-inputs (list pkg-config))
@@ -938,8 +938,16 @@ as part of the Guix bootstrap process.")
(base32
"18ylb54l9lmaynapbncc1zhbsirhihznrxihhxgqrpqgyjkfbap6"))))
(build-system gnu-build-system)
+ (arguments
+ (list
+ #:phases #~(modify-phases %standard-phases
+ (add-after 'unpack 'skip-failing-tests
+ (lambda _
+ (substitute* "Makefile.am"
+ (("tests/sort\\.org") ""))
+ (for-each delete-file '("configure" "Makefile.in")))))))
(native-inputs
- (list pkg-config))
+ (list autoconf automake pkg-config))
(inputs
(list guile-3.0 gash))
(home-page "https://savannah.nongnu.org/projects/gash/")