summaryrefslogtreecommitdiff
path: root/gnu/packages/shells.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/shells.scm')
-rw-r--r--gnu/packages/shells.scm7
1 files changed, 3 insertions, 4 deletions
diff --git a/gnu/packages/shells.scm b/gnu/packages/shells.scm
index 7868dc40f0..affc98a6e6 100644
--- a/gnu/packages/shells.scm
+++ b/gnu/packages/shells.scm
@@ -813,15 +813,14 @@ Shell (pdksh).")
(define-public oil
(package
(name "oil")
- ;; https://www.oilshell.org/blog/2020/04/release-0.8.pre4.html#comment-on-version-numbering
- (version "0.8.pre6")
+ (version "0.8.0")
(source
(origin
(method url-fetch)
(uri (string-append "https://www.oilshell.org/download/oil-"
version ".tar.gz"))
(sha256
- (base32 "11nfwn5b1w74hv78065jg2zm45mqzi59381b0f649j7n3g7yp3iq"))))
+ (base32 "1455hy61prznzp05vigh96ypyz9zarhvvzmmxvf8cnpa39s39a8c"))))
(build-system gnu-build-system)
(arguments
`(#:strip-binaries? #f ; strip breaks the binary
@@ -838,7 +837,7 @@ Shell (pdksh).")
(replace 'check
;; The tests are not distributed in the tarballs but upstream
;; recommends running this smoke test.
- ;; https://github.com/oilshell/oil/blob/release/0.8.pre6/INSTALL.txt#L38-L48
+ ;; https://github.com/oilshell/oil/blob/release/0.8.0/INSTALL.txt#L38-L48
(lambda _
(let* ((oil "_bin/oil.ovm"))
(invoke/quiet oil "osh" "-c" "echo hi")