summaryrefslogtreecommitdiff
path: root/gnu/packages/shells.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/shells.scm')
-rw-r--r--gnu/packages/shells.scm67
1 files changed, 22 insertions, 45 deletions
diff --git a/gnu/packages/shells.scm b/gnu/packages/shells.scm
index 2caefd3dd0..3d5e545536 100644
--- a/gnu/packages/shells.scm
+++ b/gnu/packages/shells.scm
@@ -396,17 +396,17 @@ written by Paul Haahr and Byron Rakitzis.")
(define-public tcsh
(package
(name "tcsh")
- (version "6.22.03")
+ (version "6.24.01")
(source (origin
(method url-fetch)
;; Old tarballs are moved to old/.
- (uri (list (string-append "ftp://ftp.astron.com/pub/tcsh/"
+ (uri (list (string-append "https://astron.com/pub/tcsh/"
"tcsh-" version ".tar.gz")
- (string-append "ftp://ftp.astron.com/pub/tcsh/"
+ (string-append "https://astron.com/pub/tcsh/"
"old/tcsh-" version ".tar.gz")))
(sha256
(base32
- "1dv24bsp6faayinvwds092ylk9sb6894rl9ddm87y31a7mjzsb5y"))
+ "0zhxp4m1fxyd3a2qyvs97gzlrb0h0ah1gjrqcbilgydiffws2nan"))
(patches (search-patches "tcsh-fix-autotest.patch"))
(patch-flags '("-p0"))))
(build-system gnu-build-system)
@@ -415,16 +415,16 @@ written by Paul Haahr and Byron Rakitzis.")
(inputs
(list ncurses))
(arguments
- `(#:phases
- (modify-phases %standard-phases
- ,@(if (%current-target-system)
- '((add-before 'configure 'set-cross-cc
- (lambda _
- (substitute* "configure"
- (("CC_FOR_GETHOST=\"cc\"")
- "CC_FOR_GETHOST=\"gcc\""))
- #t)))
- '())
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ #$@(if (%current-target-system)
+ #~((add-before 'configure 'set-cross-cc
+ (lambda _
+ (substitute* "configure"
+ (("CC_FOR_GETHOST=\"cc\"")
+ "CC_FOR_GETHOST=\"gcc\"")))))
+ #~())
(add-before 'check 'patch-test-scripts
(lambda _
;; Take care of pwd
@@ -451,15 +451,11 @@ written by Paul Haahr and Byron Rakitzis.")
;; This file is ISO-8859-1 encoded.
(with-fluids ((%default-port-encoding #f))
(substitute* "tests/testsuite"
- (("/bin/sh") (which "sh"))))
- #t))
+ (("/bin/sh") (which "sh"))))))
(add-after 'install 'post-install
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (let* ((out (assoc-ref %outputs "out"))
- (bin (string-append out "/bin")))
- (with-directory-excursion bin
- (symlink "tcsh" "csh"))
- #t))))))
+ (lambda _
+ (with-directory-excursion (string-append #$output "/bin")
+ (symlink "tcsh" "csh")))))))
(home-page "https://www.tcsh.org/")
(synopsis "Unix shell based on csh")
(description
@@ -903,29 +899,19 @@ scripts.")
(define-public gash
(package
(name "gash")
- (version "0.2.0")
+ (version "0.3.0")
(source
(origin (method url-fetch)
(uri (string-append "mirror://savannah/gash/gash-"
version ".tar.gz"))
(sha256
(base32
- "13m0yz5h9nj3x40mr6wr5xcpq1lscndfwcicw3skrz801025hhgf"))
- (modules '((guix build utils)))
- (snippet
- '(begin
- ;; Allow builds with Guile 3.0.
- (substitute* "configure"
- (("search=\"2\\.2 2\\.0\"")
- "search=\"3.0 2.2 2.0\""))
- #t))))
+ "1af2jz4a6rzsshi379wzw4b8d04zvfamdhfzip2pgmk821lyqsjl"))))
(build-system gnu-build-system)
(native-inputs
(list pkg-config))
(inputs
(list guile-3.0))
- (arguments
- '(#:make-flags '("XFAIL_TESTS=tests/redirects.org")))
(home-page "https://savannah.nongnu.org/projects/gash/")
(synopsis "POSIX-compatible shell written in Guile Scheme")
(description "Gash is a POSIX-compatible shell written in Guile
@@ -937,23 +923,14 @@ as part of the Guix bootstrap process.")
(define-public gash-utils
(package
(name "gash-utils")
- (version "0.1.0")
+ (version "0.2.0")
(source (origin
(method url-fetch)
(uri (string-append "mirror://savannah/gash/gash-utils-"
version ".tar.gz"))
(sha256
(base32
- "0ib2p52qmbac5n0s5bys4fiwim461ps546976l1n7pwbs0avh7fk"))
- (patches (search-patches "gash-utils-ls-test.patch"))
- (modules '((guix build utils)))
- (snippet
- '(begin
- ;; Allow builds with Guile 3.0.
- (substitute* "configure"
- (("search=\"2\\.2 2\\.0\"")
- "search=\"3.0 2.2 2.0\""))
- #t))))
+ "18ylb54l9lmaynapbncc1zhbsirhihznrxihhxgqrpqgyjkfbap6"))))
(build-system gnu-build-system)
(native-inputs
(list pkg-config))