summaryrefslogtreecommitdiff
path: root/gnu/packages/sphinx.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/sphinx.scm')
-rw-r--r--gnu/packages/sphinx.scm28
1 files changed, 15 insertions, 13 deletions
diff --git a/gnu/packages/sphinx.scm b/gnu/packages/sphinx.scm
index a7a3443707..5fd63a617c 100644
--- a/gnu/packages/sphinx.scm
+++ b/gnu/packages/sphinx.scm
@@ -17,6 +17,7 @@
;;; Copyright © 2021 Eric Bavier <bavier@posteo.net>
;;; Copyright © 2021 Vinicius Monego <monego@posteo.net>
;;; Copyright © 2021 Hugo Lecomte <hugo.lecomte@inria.fr>
+;;; Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -56,26 +57,27 @@
(define-public python-sphinx
(package
(name "python-sphinx")
- (version "3.3.1")
+ (version "4.2.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "Sphinx" version))
(sha256
(base32
- "0023vc2i29pjxmvdqbz1wdbi7gbj56y1br1b2z8h8wa44li5k38y"))))
+ "19jq21py7m061v8142y2dbqrbv0adqcdjmharrdy34a432wqs1wl"))))
(build-system python-build-system)
(arguments
`(#:phases
(modify-phases %standard-phases
(replace 'check
- (lambda _
- ;; Requires Internet access.
- (delete-file "tests/test_build_linkcheck.py")
- (substitute* "tests/test_build_latex.py"
- (("@pytest.mark.sphinx\\('latex', testroot='images'\\)")
- "@pytest.mark.skip()"))
- (invoke "make" "test"))))))
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ ;; Requires Internet access.
+ (delete-file "tests/test_build_linkcheck.py")
+ (substitute* "tests/test_build_latex.py"
+ (("@pytest.mark.sphinx\\('latex', testroot='images'\\)")
+ "@pytest.mark.skip()"))
+ (invoke "make" "test")))))))
(propagated-inputs
`(("python-babel" ,python-babel)
("python-docutils" ,python-docutils)
@@ -245,13 +247,13 @@ users from Sphinx docs.")
(define-public python-sphinxcontrib-htmlhelp
(package
(name "python-sphinxcontrib-htmlhelp")
- (version "1.0.3")
+ (version "2.0.0")
(source (origin
(method url-fetch)
(uri (pypi-uri "sphinxcontrib-htmlhelp" version))
(sha256
(base32
- "16v5jdnibwrqjdr5aqchgyzpwy3rgamwhdf4kidv5nxj65zbpxg8"))))
+ "1ckd5xx4ngd6f4prxbc1bbvnafy1gg06j3bxyj5kk7v21lnvpy7m"))))
(build-system python-build-system)
(arguments
`(#:tests? #f)) ;XXX: circular dependency on Sphinx
@@ -350,13 +352,13 @@ documents.")
(define-public python-sphinxcontrib-serializinghtml
(package
(name "python-sphinxcontrib-serializinghtml")
- (version "1.1.4")
+ (version "1.1.5")
(source (origin
(method url-fetch)
(uri (pypi-uri "sphinxcontrib-serializinghtml" version))
(sha256
(base32
- "1g3pbx0g88zd9xzcrbaypa2k60axrh92vf5j76wsk0p9hv6fr87a"))))
+ "0lk91cl9bi4ynhz971zjs0bsr7jwxx8mx2f40psrx06zvzjnspxa"))))
(build-system python-build-system)
(arguments
`(#:tests? #f)) ;XXX: circular dependency on Sphinx