summaryrefslogtreecommitdiff
path: root/gnu/packages/statistics.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/statistics.scm')
-rw-r--r--gnu/packages/statistics.scm122
1 files changed, 68 insertions, 54 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 4ae40d0a46..ee3df4dd83 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -227,7 +227,7 @@ This package also provides @command{xls2csv} to export Excel files to CSV.")
(define r-with-tests
(package
(name "r-with-tests")
- (version "4.3.3")
+ (version "4.4.0")
(source (origin
(method url-fetch)
(uri (string-append "mirror://cran/src/base/R-"
@@ -235,7 +235,7 @@ This package also provides @command{xls2csv} to export Excel files to CSV.")
version ".tar.gz"))
(sha256
(base32
- "0c03abq3kqg6d2yhrijy9j3fsl77har3k7pffwwbz19v74qi51c0"))))
+ "0c7hnmr0w26vpaf8b10m83f4w3g3fl6a7z65pi9jqvcpkdgi5r5c"))))
(build-system gnu-build-system)
(arguments
(list
@@ -539,14 +539,14 @@ D.V. Hinkley (1997, CUP), originally written by Angelo Canty for S.")
(define-public r-mass
(package
(name "r-mass")
- (version "7.3-60.0.1")
+ (version "7.3-60.2")
(source
(origin
(method url-fetch)
(uri (cran-uri "MASS" version))
(sha256
(base32
- "1gdd2gyqngvgnm0bxc3a33nykrx2rbfmxj82i7bh7f1961cr7pvl"))))
+ "13ky8mbni09zviv5lan10ff6l2klsfv7v3vmfq88dxpz8xknx75v"))))
(properties `((upstream-name . "MASS")))
(build-system r-build-system)
(home-page "https://www.stats.ox.ac.uk/pub/MASS4/")
@@ -687,14 +687,14 @@ also flexible enough to handle most nonstandard requirements.")
(define-public r-matrix
(package
(name "r-matrix")
- (version "1.6-5")
+ (version "1.7-0")
(source
(origin
(method url-fetch)
(uri (cran-uri "Matrix" version))
(sha256
(base32
- "0zdrrss4q0g7jify9bp1vvzrdpy62fc6fx3awzbd2wvfc938sv3j"))))
+ "0dxd13y6x6pz54ccbcalw2sm646h9pls4bby9zmj40ipvyhbp5zv"))))
(properties `((upstream-name . "Matrix")))
(build-system r-build-system)
(propagated-inputs
@@ -811,14 +811,14 @@ analysis.")
(define-public r-survival
(package
(name "r-survival")
- (version "3.5-8")
+ (version "3.6-4")
(source
(origin
(method url-fetch)
(uri (cran-uri "survival" version))
(sha256
(base32
- "1d0qvw4200mjldna9n0acis0fk8xj28wwzqb8c3d4537l92zivbi"))))
+ "1zpfqslpzck10pmaiyc8x7852ajbjd0l6aw18hwfrm418wjamy1f"))))
(build-system r-build-system)
(propagated-inputs
(list r-matrix))
@@ -1007,13 +1007,13 @@ OpenSSL should be used.")
(define-public r-estimability
(package
(name "r-estimability")
- (version "1.5")
+ (version "1.5.1")
(source (origin
(method url-fetch)
(uri (cran-uri "estimability" version))
(sha256
(base32
- "0s6w8vnq0jc136d2mpf6pgg45rbxccrlsgdy89pgksnbaxhmyb5k"))))
+ "1sa42rczhzfj0dkn8v1pq6b752rh6h7x553gcgl7g27x75mbk9iw"))))
(build-system r-build-system)
(native-inputs (list r-knitr))
(home-page "https://cran.r-project.org/web/packages/estimability")
@@ -1194,14 +1194,14 @@ solution for sending email, including attachments, from within R.")
(define-public r-stringi
(package
(name "r-stringi")
- (version "1.8.3")
+ (version "1.8.4")
(source
(origin
(method url-fetch)
(uri (cran-uri "stringi" version))
(sha256
(base32
- "09a964g8q3iphq24ln9c9g5158ynr75pfh3ghddarn0xvn7bw0hn"))))
+ "1wv9qqxl84l44kpvkx0lmyciinrh9pa5512jm56gsaqs9pvgh6f2"))))
(build-system r-build-system)
(inputs (list icu4c))
(native-inputs (list pkg-config))
@@ -1268,13 +1268,13 @@ using just two functions: melt and dcast (or acast).")
(define-public r-ggplot2
(package
(name "r-ggplot2")
- (version "3.5.0")
+ (version "3.5.1")
(source
(origin
(method url-fetch)
(uri (cran-uri "ggplot2" version))
(sha256
- (base32 "1qlh231dwsa7j0pzlw6xdm68d7r0v64916p66bg9lh1dw3a1ryh7"))))
+ (base32 "08a72kizg42mdm35170fnpn8l6r4n3j1yvbgiq1k8dlvz4jb8n3w"))))
(build-system r-build-system)
(propagated-inputs
(list r-cli
@@ -1768,13 +1768,13 @@ R packages that praise their users.")
(define-public r-testthat
(package
(name "r-testthat")
- (version "3.2.1")
+ (version "3.2.1.1")
(source (origin
(method url-fetch)
(uri (cran-uri "testthat" version))
(sha256
(base32
- "1ba80zk9jzs91xl82bykhrvvgamfvp1h189rfq099h813dhhx60x"))))
+ "1xz94i0r62lslyqya8gz6i2r100wi26y5c2822v2i7lkflwwx1fp"))))
(build-system r-build-system)
(propagated-inputs
(list r-brio
@@ -2359,6 +2359,12 @@ building design matrices.")
(base32
"13kgyqk1hp603n9zym835kp1pqs83k0j7ymayw4fk0zx4z1nmvdx"))))
(build-system pyproject-build-system)
+ ;; See https://github.com/scikit-learn-contrib/MAPIE/issues/432
+ (arguments
+ (list
+ #:test-flags
+ '(list "-k" (string-append "not test_correct_results"
+ " and not test_correct_results_binary"))))
(native-inputs (list python-pandas python-pytest))
(propagated-inputs (list python-numpy python-scikit-learn))
(home-page "https://github.com/scikit-learn-contrib/MAPIE")
@@ -2894,14 +2900,14 @@ collation, and NAMESPACE files.")
(define-public r-openssl
(package
(name "r-openssl")
- (version "2.1.1")
+ (version "2.1.2")
(source
(origin
(method url-fetch)
(uri (cran-uri "openssl" version))
(sha256
(base32
- "1p2bnr4z4vx3yqq5isqb3z4d9vg2isiz8i0h3vxdb5ramzwjd9zs"))))
+ "0mm0rlf3m6wkvz5p8prxwjr37rn30lmhddsdi4ffnsmrysfl3rbp"))))
(properties
`((upstream-name . "openssl")
(updater-extra-inputs . ("openssl"))))
@@ -3184,13 +3190,13 @@ well as additional utilities such as panel and axis annotation functions.")
(define-public r-rcpparmadillo
(package
(name "r-rcpparmadillo")
- (version "0.12.8.2.0")
+ (version "0.12.8.3.0")
(source (origin
(method url-fetch)
(uri (cran-uri "RcppArmadillo" version))
(sha256
(base32
- "0w1c0mpqqf6m2gk4221kjxx299bs4qpxn867fgnkpg69kj3mh8gd"))))
+ "02sj42apznls45sapiisaggfijdvg69a2ja2mz4fraqaajrkkwc7"))))
(properties `((upstream-name . "RcppArmadillo")))
(build-system r-build-system)
(propagated-inputs
@@ -3311,13 +3317,13 @@ variety of formats.")
(define-public r-gtable
(package
(name "r-gtable")
- (version "0.3.4")
+ (version "0.3.5")
(source (origin
(method url-fetch)
(uri (cran-uri "gtable" version))
(sha256
(base32
- "0xvrkhcv1896mf3n43mva2mrmk0d8np7sjrykpg1pv54f69h6ckh"))))
+ "0wpavsypw2yp0pklmqw0qcwsh8smx5gr2kkxmgdmm52r0fiw37xi"))))
(properties `((upstream-name . "gtable")))
(build-system r-build-system)
(propagated-inputs
@@ -3589,14 +3595,14 @@ statements.")
(define-public r-segmented
(package
(name "r-segmented")
- (version "2.0-3")
+ (version "2.0-4")
(source
(origin
(method url-fetch)
(uri (cran-uri "segmented" version))
(sha256
(base32
- "1f89v6zbxwl6yhx3qi7wrr3rndnxfwaf49mygw357f7cf3i8ma77"))))
+ "0a7qfs83kgn7g98kiwlk8zm2q9pzgkvmms9l15sgc5y952yig926"))))
(build-system r-build-system)
(propagated-inputs (list r-mass r-nlme))
(home-page "https://cran.r-project.org/web/packages/segmented")
@@ -4456,13 +4462,13 @@ t-probabilities, quantiles, random deviates and densities.")
(define-public r-matrixstats
(package
(name "r-matrixstats")
- (version "1.2.0")
+ (version "1.3.0")
(source (origin
(method url-fetch)
(uri (cran-uri "matrixStats" version))
(sha256
(base32
- "0ws5lmzqm42vrn5791l21zr05l78x0xi6b89jw0gi0vjb4pc20z4"))))
+ "0ni4jgw3jfbwakzrcz6jcjr1zsnaq924jz2a9d8kq92vv43ycgj1"))))
(properties `((upstream-name . "matrixStats")))
(build-system r-build-system)
(arguments
@@ -5064,14 +5070,14 @@ existing packages provide.")
(define-public r-sfsmisc
(package
(name "r-sfsmisc")
- (version "1.1-17")
+ (version "1.1-18")
(source
(origin
(method url-fetch)
(uri (cran-uri "sfsmisc" version))
(sha256
(base32
- "06ih8zljs57scy7jfnv32yxijgv1i60vggmlyyblwnff6mr2fm60"))))
+ "1bc3qjnh3k4ia7w2sdbawr4rp8w9pmcbzbdjg7qbiwmpx6h2w19k"))))
(build-system r-build-system)
(home-page "https://cran.r-project.org/web/packages/sfsmisc")
(synopsis "Utilities from \"Seminar fuer Statistik\" ETH Zurich")
@@ -5559,14 +5565,14 @@ forest of trees using random inputs, for classification and regression.")
(define-public r-diptest
(package
(name "r-diptest")
- (version "0.77-0")
+ (version "0.77-1")
(source
(origin
(method url-fetch)
(uri (cran-uri "diptest" version))
(sha256
(base32
- "0cnaz1akl86vg5p0g4yl4r66407dxssfki130rrwxpbbbqakbj63"))))
+ "04r8c6xy5vympxaxmgnjib4pqh97f9k6b43i66qhzkl3yh0awki2"))))
(build-system r-build-system)
(home-page "https://cran.r-project.org/web/packages/diptest")
(synopsis "Hartigan's dip test statistic for unimodality")
@@ -5623,14 +5629,14 @@ models, generalized linear models and model-based clustering.")
(define-public r-mclust
(package
(name "r-mclust")
- (version "6.1")
+ (version "6.1.1")
(source
(origin
(method url-fetch)
(uri (cran-uri "mclust" version))
(sha256
(base32
- "0mchdxkc3y0v6dw8fzjnlqd6f3zrafm3xf1c53s6ps529b66kx2x"))))
+ "0xb726ssy224mzfg37nq5hffkdwi2hwjp1y9gwngk9vfbs703myx"))))
(build-system r-build-system)
(native-inputs
(list gfortran r-knitr))
@@ -5833,14 +5839,14 @@ of the points.")
(define-public r-fpc
(package
(name "r-fpc")
- (version "2.2-11")
+ (version "2.2-12")
(source
(origin
(method url-fetch)
(uri (cran-uri "fpc" version))
(sha256
(base32
- "06j1dzlf96qcaiqg8m5iah9rmwdppky04xjhs8k4rh0k12wr0mc2"))))
+ "11s7211mnb9c72061mrcdfdwfph6nmbwcnpjgl32i2p7qys9cnam"))))
(build-system r-build-system)
(propagated-inputs
(list r-class
@@ -6060,14 +6066,14 @@ algorithms.")
(define-public r-lme4
(package
(name "r-lme4")
- (version "1.1-35.2")
+ (version "1.1-35.3")
(source
(origin
(method url-fetch)
(uri (cran-uri "lme4" version))
(sha256
(base32
- "0nvvkvpasna9hy0y3fxd4fy2b2gxzgdga9kmxvli59dlkdy28ipc"))))
+ "0ij37wly0d28x143xdkjry5jsj4chlbli2fl9zbp8fkcgh95r1xl"))))
(build-system r-build-system)
(propagated-inputs
(list r-boot
@@ -6290,18 +6296,18 @@ multivariate case.")
(define-public r-tclust
(package
(name "r-tclust")
- (version "1.5-6")
+ (version "2.0-4")
(source
(origin
(method url-fetch)
(uri (cran-uri "tclust" version))
(sha256
(base32
- "1p7y58mklcwq76msh1q8pm2v6v19ja6fy07xg1j07d2zw2wa0phy"))))
+ "0y05aqpmal7ky33hs8n1phai94d7f48ich43jvy4m5wbfxkp2rm6"))))
(build-system r-build-system)
;; These are all suggested packages, not build dependencies.
(propagated-inputs
- (list r-cluster r-mclust r-mvtnorm r-sn))
+ (list r-doparallel r-foreach r-mass r-rcpp r-rcpparmadillo))
(home-page "https://cran.r-project.org/web/packages/tclust")
(synopsis "Robust trimmed clustering")
(description
@@ -6907,6 +6913,8 @@ Java package that provides routines for various statistical distributions.")
(disable-tests (list "test/ess-test-inf.el"
"test/ess-test-r.el")
("ess--derive-connection-path"
+ ;; Looks like an off-by-one error.
+ "ess--command-browser-unscoped-essr"
"ess-eval-line-test"
"ess-eval-region-test"
"ess-mock-remote-process"
@@ -7201,14 +7209,14 @@ or eta squared effect size.")
(define-public r-logspline
(package
(name "r-logspline")
- (version "2.1.21")
+ (version "2.1.22")
(source
(origin
(method url-fetch)
(uri (cran-uri "logspline" version))
(sha256
(base32
- "0xqbk3h28gkx3haj7hdg314616x673cmg9ia148g0q9j3zqkqflf"))))
+ "00pdcfj1hmafxzs7gqw3n072p6pxp9hvsdm062n0xkiby6igffkp"))))
(properties `((upstream-name . "logspline")))
(build-system r-build-system)
(native-inputs (list gfortran))
@@ -7503,20 +7511,26 @@ Calculates confidence intervals for the difference in proportion.")
(base32 "16qbm1l1281yj1cg6fp8xgd8xdshpz9a09f0b9cyimsjbm01c2j7"))))
(properties `((upstream-name . "DescTools")))
(build-system r-build-system)
+ (arguments
+ (list
+ #:phases
+ '(modify-phases %standard-phases
+ (add-before 'check 'pre-check
+ (lambda _ (setenv "HOME" "/tmp"))))))
(propagated-inputs
- (list r-boot
- r-cli
- r-data-table
- r-exact
- r-expm
- r-gld
- r-httr
- r-mass
- r-mvtnorm
- r-rcpp
- r-readxl
- r-rstudioapi
- r-withr))
+ (list r-boot
+ r-cli
+ r-data-table
+ r-exact
+ r-expm
+ r-gld
+ r-httr
+ r-mass
+ r-mvtnorm
+ r-rcpp
+ r-readxl
+ r-rstudioapi
+ r-withr))
(native-inputs (list gfortran r-r-rsp))
(home-page "https://andrisignorell.github.io/DescTools/")
(synopsis "Tools for Descriptive Statistics")