summaryrefslogtreecommitdiff
path: root/gnu/packages/statistics.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/statistics.scm')
-rw-r--r--gnu/packages/statistics.scm220
1 files changed, 128 insertions, 92 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 0c830db6e5..572f4539d7 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -115,7 +115,7 @@
(define-public pspp
(package
(name "pspp")
- (version "2.0.0")
+ (version "2.0.1")
(source
(origin
(method url-fetch)
@@ -123,7 +123,7 @@
version ".tar.gz"))
(sha256
(base32
- "1pyqlab9kw65wxc8pilcwb64l18w37xxdg3r6n287c7mda4cpxm8"))))
+ "002c08rxym056mn7a73jwjmcazqd4gh5j1cyml603y4ckvqb1nwf"))))
(build-system gnu-build-system)
(arguments
(list #:phases
@@ -180,9 +180,13 @@ be output in text, PostScript, PDF or HTML.")
(base32
"0aa2w4g5057vn1qjp954s2kwxfmy1h7p5yn56fyi7sz9nmaq69gr"))))
(build-system gnu-build-system)
+ (arguments
+ (list #:configure-flags
+ #~(list "--with-lapack=-lopenblas"
+ "--with-blas=-lopenblas")))
(home-page "https://mcmc-jags.sourceforge.net/")
(native-inputs
- (list gfortran lapack))
+ (list gfortran openblas))
(synopsis "Gibbs sampler")
(description "JAGS is Just Another Gibbs Sampler. It is a program for
analysis of Bayesian hierarchical models using Markov Chain Monte Carlo (MCMC)
@@ -223,7 +227,7 @@ This package also provides @command{xls2csv} to export Excel files to CSV.")
(define r-with-tests
(package
(name "r-with-tests")
- (version "4.3.2")
+ (version "4.4.0")
(source (origin
(method url-fetch)
(uri (string-append "mirror://cran/src/base/R-"
@@ -231,7 +235,7 @@ This package also provides @command{xls2csv} to export Excel files to CSV.")
version ".tar.gz"))
(sha256
(base32
- "0aj51j34q2b28y28xvlf0dwdj8vpnhjwpvqf7xm05s7fq857dxdk"))))
+ "0c7hnmr0w26vpaf8b10m83f4w3g3fl6a7z65pi9jqvcpkdgi5r5c"))))
(build-system gnu-build-system)
(arguments
(list
@@ -535,14 +539,14 @@ D.V. Hinkley (1997, CUP), originally written by Angelo Canty for S.")
(define-public r-mass
(package
(name "r-mass")
- (version "7.3-60.0.1")
+ (version "7.3-60.2")
(source
(origin
(method url-fetch)
(uri (cran-uri "MASS" version))
(sha256
(base32
- "1gdd2gyqngvgnm0bxc3a33nykrx2rbfmxj82i7bh7f1961cr7pvl"))))
+ "13ky8mbni09zviv5lan10ff6l2klsfv7v3vmfq88dxpz8xknx75v"))))
(properties `((upstream-name . "MASS")))
(build-system r-build-system)
(home-page "https://www.stats.ox.ac.uk/pub/MASS4/")
@@ -600,14 +604,14 @@ Hubert, based on Kaufman and Rousseeuw (1990) \"Finding Groups in Data\".")
(define-public r-codetools
(package
(name "r-codetools")
- (version "0.2-19")
+ (version "0.2-20")
(source
(origin
(method url-fetch)
(uri (cran-uri "codetools" version))
(sha256
(base32
- "1ardg28x2cvilkgsj6bdvvp5snsy3rj7jbz9bpcdlcvzr1kybdy4"))))
+ "0qx8zrlickl45wzzbydsbx5f1vmzhn71x7amzpfj71qpxisz7riv"))))
(build-system r-build-system)
(home-page "https://cran.r-project.org/web/packages/codetools")
(synopsis "Code analysis tools for R")
@@ -663,13 +667,13 @@ estimation) corresponding to the book: Wand, M.P. and Jones, M.C. (1995)
(define-public r-lattice
(package
(name "r-lattice")
- (version "0.22-5")
+ (version "0.22-6")
(source (origin
(method url-fetch)
(uri (cran-uri "lattice" version))
(sha256
(base32
- "1wd5dlxi0hd4l08g999y3xnxnaq06gwvflcqr9ym0cx131gbw7xs"))))
+ "1xq09lfjlca6c7mn412hjjav0q66p7wmjrwx5f3ygv3jwh8p4dsb"))))
(build-system r-build-system)
(home-page "https://lattice.r-forge.r-project.org/")
(synopsis "High-level data visualization system")
@@ -683,14 +687,14 @@ also flexible enough to handle most nonstandard requirements.")
(define-public r-matrix
(package
(name "r-matrix")
- (version "1.6-5")
+ (version "1.7-0")
(source
(origin
(method url-fetch)
(uri (cran-uri "Matrix" version))
(sha256
(base32
- "0zdrrss4q0g7jify9bp1vvzrdpy62fc6fx3awzbd2wvfc938sv3j"))))
+ "0dxd13y6x6pz54ccbcalw2sm646h9pls4bby9zmj40ipvyhbp5zv"))))
(properties `((upstream-name . "Matrix")))
(build-system r-build-system)
(propagated-inputs
@@ -807,14 +811,14 @@ analysis.")
(define-public r-survival
(package
(name "r-survival")
- (version "3.5-8")
+ (version "3.6-4")
(source
(origin
(method url-fetch)
(uri (cran-uri "survival" version))
(sha256
(base32
- "1d0qvw4200mjldna9n0acis0fk8xj28wwzqb8c3d4537l92zivbi"))))
+ "1zpfqslpzck10pmaiyc8x7852ajbjd0l6aw18hwfrm418wjamy1f"))))
(build-system r-build-system)
(propagated-inputs
(list r-matrix))
@@ -972,13 +976,13 @@ effects of different types of color-blindness.")
(define-public r-digest
(package
(name "r-digest")
- (version "0.6.34")
+ (version "0.6.35")
(source
(origin
(method url-fetch)
(uri (cran-uri "digest" version))
(sha256
- (base32 "1na47pywh059g9ymf56z232h5yxbj0gn755cb10ms5igjd97awqb"))))
+ (base32 "07vqv2mnf8ppan2a3gydh4yr84n8489hypfas1rlk7050nxkycyc"))))
(build-system r-build-system)
;; Vignettes require r-knitr, which requires r-digest, so we have to
;; disable them and the tests.
@@ -1064,13 +1068,13 @@ see package vignette. To quote Rene Magritte, \"Ceci n'est pas un pipe.\"")
(define-public r-munsell
(package
(name "r-munsell")
- (version "0.5.0")
+ (version "0.5.1")
(source
(origin
(method url-fetch)
(uri (cran-uri "munsell" version))
(sha256
- (base32 "16g1fzisbpqb15yh3pqf3iia4csppva5dnv1z88x9dg263xskwyh"))))
+ (base32 "19i9jjawlqciw4n4h99a4sm0lbc77la3pqyzjvnwsrh7qjdgv8h3"))))
(build-system r-build-system)
(propagated-inputs
(list r-colorspace))
@@ -1190,14 +1194,14 @@ solution for sending email, including attachments, from within R.")
(define-public r-stringi
(package
(name "r-stringi")
- (version "1.8.3")
+ (version "1.8.4")
(source
(origin
(method url-fetch)
(uri (cran-uri "stringi" version))
(sha256
(base32
- "09a964g8q3iphq24ln9c9g5158ynr75pfh3ghddarn0xvn7bw0hn"))))
+ "1wv9qqxl84l44kpvkx0lmyciinrh9pa5512jm56gsaqs9pvgh6f2"))))
(build-system r-build-system)
(inputs (list icu4c))
(native-inputs (list pkg-config))
@@ -1264,13 +1268,13 @@ using just two functions: melt and dcast (or acast).")
(define-public r-ggplot2
(package
(name "r-ggplot2")
- (version "3.5.0")
+ (version "3.5.1")
(source
(origin
(method url-fetch)
(uri (cran-uri "ggplot2" version))
(sha256
- (base32 "1qlh231dwsa7j0pzlw6xdm68d7r0v64916p66bg9lh1dw3a1ryh7"))))
+ (base32 "08a72kizg42mdm35170fnpn8l6r4n3j1yvbgiq1k8dlvz4jb8n3w"))))
(build-system r-build-system)
(propagated-inputs
(list r-cli
@@ -1620,13 +1624,13 @@ emitter (http://pyyaml.org/wiki/LibYAML) for R.")
(define-public r-knitr
(package
(name "r-knitr")
- (version "1.45")
+ (version "1.46")
(source (origin
(method url-fetch)
(uri (cran-uri "knitr" version))
(sha256
(base32
- "1yw4fnzm8lvh6kpcdlvr1fahz7421h5mmaris58zlgn57fjxwbpf"))))
+ "0ng8kw79csvcg46lsm3yf147jh6rf91jbj8qlryaihd8jcyc6lcg"))))
(build-system r-build-system)
(propagated-inputs
(list r-evaluate r-highr r-xfun r-yaml))
@@ -1764,13 +1768,13 @@ R packages that praise their users.")
(define-public r-testthat
(package
(name "r-testthat")
- (version "3.2.1")
+ (version "3.2.1.1")
(source (origin
(method url-fetch)
(uri (cran-uri "testthat" version))
(sha256
(base32
- "1ba80zk9jzs91xl82bykhrvvgamfvp1h189rfq099h813dhhx60x"))))
+ "1xz94i0r62lslyqya8gz6i2r100wi26y5c2822v2i7lkflwwx1fp"))))
(build-system r-build-system)
(propagated-inputs
(list r-brio
@@ -1908,14 +1912,14 @@ database.")
(define-public r-dbplyr
(package
(name "r-dbplyr")
- (version "2.4.0")
+ (version "2.5.0")
(source
(origin
(method url-fetch)
(uri (cran-uri "dbplyr" version))
(sha256
(base32
- "1rzi8112fi0bx2fj0j5ak9bfgqgjk5k5dv66qrb890gsf5bz6m4i"))))
+ "1zxw4ignzm2fzixsf6n80f44b9q7434vamy2xj4v31wlx3dmnixv"))))
(build-system r-build-system)
(propagated-inputs
(list r-blob
@@ -2033,13 +2037,13 @@ times.")
(define-public r-data-table
(package
(name "r-data-table")
- (version "1.15.2")
+ (version "1.15.4")
(source (origin
(method url-fetch)
(uri (cran-uri "data.table" version))
(sha256
(base32
- "04pfcm3pyl997rpyj5zdmbhi4ndaai81vfgv4whjp8rhqzjk7i6j"))))
+ "0lyb82kl2bn70l9ag5xdr8q7rh4majbimygaynmfqnbdjkznb05b"))))
(properties `((upstream-name . "data.table")))
(build-system r-build-system)
(inputs
@@ -2176,7 +2180,7 @@ machine learning, computer vision, and high-dimensional statistics.")
(define-public python-arviz
(package
(name "python-arviz")
- (version "0.17.0")
+ (version "0.17.1")
(source (origin
(method git-fetch) ; PyPI misses some test files
(uri (git-reference
@@ -2185,7 +2189,7 @@ machine learning, computer vision, and high-dimensional statistics.")
(file-name (git-file-name name version))
(sha256
(base32
- "0rmv7nniciq2jjnmk3qslc777wm8mjp7vsbk5dqx87a94dp7198f"))))
+ "1rpm2a9swzhnqn84dfsbc8kvz6qnn8w2icr3p08gwax9h9pg4ksp"))))
(build-system pyproject-build-system)
(arguments
;; FIXME: matplotlib tests fail because of the "--save" test flag.
@@ -2224,7 +2228,7 @@ comparison and diagnostics.")
(define-public python-pymc
(package
(name "python-pymc")
- (version "5.10.3")
+ (version "5.11.0")
(source (origin
(method git-fetch) ; no tests in PyPI
(uri (git-reference
@@ -2233,7 +2237,7 @@ comparison and diagnostics.")
(file-name (git-file-name name version))
(sha256
(base32
- "0ydngbki4xb0i4j0nayzqqrvwlxp30fp56kiwm95n2i7iwgmki02"))))
+ "0x94qzq3z02fxlliz1xfdpb2pbn7nhp4skzcxz6qdavbj9xqcxys"))))
(build-system pyproject-build-system)
(arguments
(list #:tests? #f ; tests are too computationally intensive
@@ -2347,14 +2351,20 @@ building design matrices.")
(define-public python-mapie
(package
(name "python-mapie")
- (version "0.8.2")
+ (version "0.8.3")
(source (origin
(method url-fetch)
(uri (pypi-uri "MAPIE" version))
(sha256
(base32
- "185nnsl6ag2xzkfxpmc86d9dd8wf2v87b2psan10sma399fbqd0x"))))
+ "13kgyqk1hp603n9zym835kp1pqs83k0j7ymayw4fk0zx4z1nmvdx"))))
(build-system pyproject-build-system)
+ ;; See https://github.com/scikit-learn-contrib/MAPIE/issues/432
+ (arguments
+ (list
+ #:test-flags
+ '(list "-k" (string-append "not test_correct_results"
+ " and not test_correct_results_binary"))))
(native-inputs (list python-pandas python-pytest))
(propagated-inputs (list python-numpy python-scikit-learn))
(home-page "https://github.com/scikit-learn-contrib/MAPIE")
@@ -2437,7 +2447,8 @@ sampler for Markov chain Monte Carlo (MCMC).")
python-pytest-randomly
python-pytest-xdist
python-setuptools-scm))
- (home-page "https://statsmodels.sourceforge.net/")
+ (home-page
+ (string-append "https://www.statsmodels.org/v" version "/"))
(synopsis "Statistical modeling and econometrics in Python")
(description
"Statsmodels is a Python package that provides a complement to scipy for
@@ -2889,14 +2900,14 @@ collation, and NAMESPACE files.")
(define-public r-openssl
(package
(name "r-openssl")
- (version "2.1.1")
+ (version "2.1.2")
(source
(origin
(method url-fetch)
(uri (cran-uri "openssl" version))
(sha256
(base32
- "1p2bnr4z4vx3yqq5isqb3z4d9vg2isiz8i0h3vxdb5ramzwjd9zs"))))
+ "0mm0rlf3m6wkvz5p8prxwjr37rn30lmhddsdi4ffnsmrysfl3rbp"))))
(properties
`((upstream-name . "openssl")
(updater-extra-inputs . ("openssl"))))
@@ -2981,13 +2992,13 @@ pure C implementation of the Git core methods.")
(define-public r-rstudioapi
(package
(name "r-rstudioapi")
- (version "0.15.0")
+ (version "0.16.0")
(source (origin
(method url-fetch)
(uri (cran-uri "rstudioapi" version))
(sha256
(base32
- "1kvc870gx02cpb800zjvdrhfhyfpzgkydgw2g7kxdlrpr8fwhnwk"))))
+ "1rjgxn7p15a69vfkhwrxywag6w9k4ccnklpvhr1sb1wy35ksizvl"))))
(build-system r-build-system)
(native-inputs
(list r-knitr))
@@ -3179,13 +3190,13 @@ well as additional utilities such as panel and axis annotation functions.")
(define-public r-rcpparmadillo
(package
(name "r-rcpparmadillo")
- (version "0.12.8.1.0")
+ (version "0.12.8.2.1")
(source (origin
(method url-fetch)
(uri (cran-uri "RcppArmadillo" version))
(sha256
(base32
- "0ax4812dm33c67ckd902qabis3dgqmpkchk4s30bshnfv4fxx1z2"))))
+ "11w92xjjwfhb3sv3g0m6hdhm27nnx73ahb404zm79a29ihwrj55w"))))
(properties `((upstream-name . "RcppArmadillo")))
(build-system r-build-system)
(propagated-inputs
@@ -3271,30 +3282,29 @@ certain criterion, e.g., it contains a certain regular file.")
(define-public r-rmarkdown
(package
(name "r-rmarkdown")
- (version "2.25")
+ (version "2.26")
(source
(origin
(method url-fetch)
(uri (cran-uri "rmarkdown" version))
(sha256
- (base32 "0m814598vc67sjwk83xh9g17n72618l32dgg7fz8y0gycqk6dr06"))))
+ (base32 "1q6z2j1y6pjdz4nzw44srv9j62irnxqhkvrsi46ma7xrzq6ig34g"))))
(properties
`((upstream-name . "rmarkdown")
(updater-extra-propagated-inputs . ("pandoc"))))
(build-system r-build-system)
(propagated-inputs
- (list r-bslib
+ (list pandoc
+ r-bslib
r-evaluate
r-fontawesome
r-htmltools
r-jquerylib
r-jsonlite
r-knitr
- r-stringr
r-tinytex
r-xfun
- r-yaml
- pandoc))
+ r-yaml))
(native-inputs
(list esbuild r-knitr))
(home-page "https://rmarkdown.rstudio.com")
@@ -3307,13 +3317,13 @@ variety of formats.")
(define-public r-gtable
(package
(name "r-gtable")
- (version "0.3.4")
+ (version "0.3.5")
(source (origin
(method url-fetch)
(uri (cran-uri "gtable" version))
(sha256
(base32
- "0xvrkhcv1896mf3n43mva2mrmk0d8np7sjrykpg1pv54f69h6ckh"))))
+ "0wpavsypw2yp0pklmqw0qcwsh8smx5gr2kkxmgdmm52r0fiw37xi"))))
(properties `((upstream-name . "gtable")))
(build-system r-build-system)
(propagated-inputs
@@ -3393,13 +3403,13 @@ a column in data frame.")
(define-public r-rsqlite
(package
(name "r-rsqlite")
- (version "2.3.5")
+ (version "2.3.6")
(source (origin
(method url-fetch)
(uri (cran-uri "RSQLite" version))
(sha256
(base32
- "1wvfadwcr8iv0z6pddfpvl60dq4p8l68v16p9daa002srgzpwlw1"))))
+ "1wpqr71wckxrh8ih5f01wkqqqnq5s3zaj0m8b40g76pliyjvgcgv"))))
(properties `((upstream-name . "RSQLite")))
(build-system r-build-system)
(propagated-inputs
@@ -3585,14 +3595,14 @@ statements.")
(define-public r-segmented
(package
(name "r-segmented")
- (version "2.0-3")
+ (version "2.0-4")
(source
(origin
(method url-fetch)
(uri (cran-uri "segmented" version))
(sha256
(base32
- "1f89v6zbxwl6yhx3qi7wrr3rndnxfwaf49mygw357f7cf3i8ma77"))))
+ "0a7qfs83kgn7g98kiwlk8zm2q9pzgkvmms9l15sgc5y952yig926"))))
(build-system r-build-system)
(propagated-inputs (list r-mass r-nlme))
(home-page "https://cran.r-project.org/web/packages/segmented")
@@ -3830,13 +3840,13 @@ using the multicore functionality of the parallel package.")
"datatables-extensions/Buttons"))))
(package
(name "r-dt")
- (version "0.32")
+ (version "0.33")
(source (origin
(method url-fetch)
(uri (cran-uri "DT" version))
(sha256
(base32
- "0nvj2bc441b9h13085fa7q281f86lgx4k0d8lr64xgdpbmbvkl21"))
+ "1f17gdqjk1aj7vwjvv3363k8lnsvc6ssh4s3gy1prnz33kdxlig1"))
(modules '((guix build utils)
(ice-9 match)))
(snippet
@@ -4452,13 +4462,13 @@ t-probabilities, quantiles, random deviates and densities.")
(define-public r-matrixstats
(package
(name "r-matrixstats")
- (version "1.2.0")
+ (version "1.3.0")
(source (origin
(method url-fetch)
(uri (cran-uri "matrixStats" version))
(sha256
(base32
- "0ws5lmzqm42vrn5791l21zr05l78x0xi6b89jw0gi0vjb4pc20z4"))))
+ "0ni4jgw3jfbwakzrcz6jcjr1zsnaq924jz2a9d8kq92vv43ycgj1"))))
(properties `((upstream-name . "matrixStats")))
(build-system r-build-system)
(arguments
@@ -4534,14 +4544,14 @@ more complete @code{viridis} package.")
(define-public r-tidyselect
(package
(name "r-tidyselect")
- (version "1.2.0")
+ (version "1.2.1")
(source
(origin
(method url-fetch)
(uri (cran-uri "tidyselect" version))
(sha256
(base32
- "0fwy4qp3j0ksy15rkrh3588h7wa8c21h0fzx5s762zg34yvjd3ak"))))
+ "0g4h8mfm5ima0izy4h0c65q478473xsj4hskh15dzg5z1fx9g7hn"))))
(build-system r-build-system)
(propagated-inputs
(list r-cli r-glue r-lifecycle r-rlang r-vctrs r-withr))
@@ -4953,13 +4963,13 @@ package instead.")
(define-public r-hmisc
(package
(name "r-hmisc")
- (version "5.1-1")
+ (version "5.1-2")
(source
(origin
(method url-fetch)
(uri (cran-uri "Hmisc" version))
(sha256
- (base32 "0laan26ja6m9k3spkk1ymalwb181ramzjq6ii3b0404xv2kfywa9"))))
+ (base32 "088gniwbymzhqg3vp0kpkbazryjzy9iq6wdvf9hg9qf0sjbibpg7"))))
(properties `((upstream-name . "Hmisc")))
(build-system r-build-system)
(native-inputs
@@ -5060,14 +5070,14 @@ existing packages provide.")
(define-public r-sfsmisc
(package
(name "r-sfsmisc")
- (version "1.1-17")
+ (version "1.1-18")
(source
(origin
(method url-fetch)
(uri (cran-uri "sfsmisc" version))
(sha256
(base32
- "06ih8zljs57scy7jfnv32yxijgv1i60vggmlyyblwnff6mr2fm60"))))
+ "1bc3qjnh3k4ia7w2sdbawr4rp8w9pmcbzbdjg7qbiwmpx6h2w19k"))))
(build-system r-build-system)
(home-page "https://cran.r-project.org/web/packages/sfsmisc")
(synopsis "Utilities from \"Seminar fuer Statistik\" ETH Zurich")
@@ -5555,14 +5565,14 @@ forest of trees using random inputs, for classification and regression.")
(define-public r-diptest
(package
(name "r-diptest")
- (version "0.77-0")
+ (version "0.77-1")
(source
(origin
(method url-fetch)
(uri (cran-uri "diptest" version))
(sha256
(base32
- "0cnaz1akl86vg5p0g4yl4r66407dxssfki130rrwxpbbbqakbj63"))))
+ "04r8c6xy5vympxaxmgnjib4pqh97f9k6b43i66qhzkl3yh0awki2"))))
(build-system r-build-system)
(home-page "https://cran.r-project.org/web/packages/diptest")
(synopsis "Hartigan's dip test statistic for unimodality")
@@ -5619,14 +5629,14 @@ models, generalized linear models and model-based clustering.")
(define-public r-mclust
(package
(name "r-mclust")
- (version "6.1")
+ (version "6.1.1")
(source
(origin
(method url-fetch)
(uri (cran-uri "mclust" version))
(sha256
(base32
- "0mchdxkc3y0v6dw8fzjnlqd6f3zrafm3xf1c53s6ps529b66kx2x"))))
+ "0xb726ssy224mzfg37nq5hffkdwi2hwjp1y9gwngk9vfbs703myx"))))
(build-system r-build-system)
(native-inputs
(list gfortran r-knitr))
@@ -5829,14 +5839,14 @@ of the points.")
(define-public r-fpc
(package
(name "r-fpc")
- (version "2.2-11")
+ (version "2.2-12")
(source
(origin
(method url-fetch)
(uri (cran-uri "fpc" version))
(sha256
(base32
- "06j1dzlf96qcaiqg8m5iah9rmwdppky04xjhs8k4rh0k12wr0mc2"))))
+ "11s7211mnb9c72061mrcdfdwfph6nmbwcnpjgl32i2p7qys9cnam"))))
(build-system r-build-system)
(propagated-inputs
(list r-class
@@ -6056,14 +6066,14 @@ algorithms.")
(define-public r-lme4
(package
(name "r-lme4")
- (version "1.1-35.1")
+ (version "1.1-35.3")
(source
(origin
(method url-fetch)
(uri (cran-uri "lme4" version))
(sha256
(base32
- "0nzv1a22pfsf2ryw91h16ic4cb8y8g6wh0gx3msr7gv8dwwi3974"))))
+ "0ij37wly0d28x143xdkjry5jsj4chlbli2fl9zbp8fkcgh95r1xl"))))
(build-system r-build-system)
(propagated-inputs
(list r-boot
@@ -6286,18 +6296,18 @@ multivariate case.")
(define-public r-tclust
(package
(name "r-tclust")
- (version "1.5-6")
+ (version "2.0-3")
(source
(origin
(method url-fetch)
(uri (cran-uri "tclust" version))
(sha256
(base32
- "1p7y58mklcwq76msh1q8pm2v6v19ja6fy07xg1j07d2zw2wa0phy"))))
+ "0l0m77a4r7izzw8akx7cz1qcxpvbjgg364yjapazji290741rfs6"))))
(build-system r-build-system)
;; These are all suggested packages, not build dependencies.
(propagated-inputs
- (list r-cluster r-mclust r-mvtnorm r-sn))
+ (list r-doparallel r-foreach r-mass r-rcpp r-rcpparmadillo))
(home-page "https://cran.r-project.org/web/packages/tclust")
(synopsis "Robust trimmed clustering")
(description
@@ -6884,17 +6894,37 @@ Java package that provides routines for various statistical distributions.")
(((string-append "^\\(ert-deftest " test-name ".*")
all)
(string-append all "(skip-unless nil)\n"))
- ...)))))
+ ...))))
+ (disable-etests ;different test syntax
+ (syntax-rules ()
+ ((_ file ())
+ (syntax-error "test names list must not be empty"))
+ ((_ file (test-name ...))
+ (emacs-batch-edit-file file
+ '(progn
+ (mapc (lambda (test)
+ (goto-char (point-min))
+ (search-forward
+ (format "etest-deftest %s " test))
+ (beginning-of-line)
+ (kill-sexp))
+ (list test-name ...))
+ (basic-save-buffer)))))))
(disable-tests (list "test/ess-test-inf.el"
"test/ess-test-r.el")
("ess--derive-connection-path"
+ ;; Looks like an off-by-one error.
+ "ess--command-browser-unscoped-essr"
"ess-eval-line-test"
"ess-eval-region-test"
"ess-mock-remote-process"
"ess-r-load-ESSR-github-fetch-no"
"ess-r-load-ESSR-github-fetch-yes"
"ess-set-working-directory-test"
- "ess-test-r-startup-directory")))))
+ "ess-test-r-startup-directory"))
+ (disable-etests "test/ess-test-r-eval.el"
+ ("ess-r-eval-ns-env-roxy-tracebug-test"
+ "ess-r-eval-sink-freeze-test")))))
(replace 'check
(lambda* (#:key tests? #:allow-other-keys)
(when tests? (invoke "make" "test"))))))))
@@ -7481,20 +7511,26 @@ Calculates confidence intervals for the difference in proportion.")
(base32 "16qbm1l1281yj1cg6fp8xgd8xdshpz9a09f0b9cyimsjbm01c2j7"))))
(properties `((upstream-name . "DescTools")))
(build-system r-build-system)
+ (arguments
+ (list
+ #:phases
+ '(modify-phases %standard-phases
+ (add-before 'check 'pre-check
+ (lambda _ (setenv "HOME" "/tmp"))))))
(propagated-inputs
- (list r-boot
- r-cli
- r-data-table
- r-exact
- r-expm
- r-gld
- r-httr
- r-mass
- r-mvtnorm
- r-rcpp
- r-readxl
- r-rstudioapi
- r-withr))
+ (list r-boot
+ r-cli
+ r-data-table
+ r-exact
+ r-expm
+ r-gld
+ r-httr
+ r-mass
+ r-mvtnorm
+ r-rcpp
+ r-readxl
+ r-rstudioapi
+ r-withr))
(native-inputs (list gfortran r-r-rsp))
(home-page "https://andrisignorell.github.io/DescTools/")
(synopsis "Tools for Descriptive Statistics")