summaryrefslogtreecommitdiff
path: root/gnu/packages/statistics.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/statistics.scm')
-rw-r--r--gnu/packages/statistics.scm9
1 files changed, 9 insertions, 0 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index bebd574f41..3f65e6afa5 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -269,6 +269,15 @@ as.POSIXct(if (\"\" != Sys.getenv(\"SOURCE_DATE_EPOCH\")) {\
(substitute* "tools/help2man.pl"
(("my \\$date = strftime \"%B %Y\", localtime" line)
(string-append line " 1"))))
+
+ ;; The "References" section of this file when converted to
+ ;; package.rds is sometimes stored with a newline, sometimes with
+ ;; a space. We avoid this problem by adding characters to break
+ ;; up the series of line break and spaces that is suspected to be
+ ;; the culprit.
+ (substitute* "src/library/methods/DESCRIPTION.in"
+ ((" ``Software")
+ " -- ``Software"))
#t))
(add-before 'build 'set-locales
(lambda _