summaryrefslogtreecommitdiff
path: root/gnu/packages/statistics.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/statistics.scm')
-rw-r--r--gnu/packages/statistics.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index e02c342c6f..7282c3cf8f 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -4169,3 +4169,23 @@ perform @dfn{independent component analysis} (ICA) and projection pursuit.")
"This package provides the Breiman and Cutler's random forests algorithm, based on a
forest of trees using random inputs, for classification and regression.")
(license license:gpl2+)))
+
+(define-public r-diptest
+ (package
+ (name "r-diptest")
+ (version "0.75-7")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "diptest" version))
+ (sha256
+ (base32
+ "06xnc5gv1284ll0addxnxb6ljz6fn8dbyrp5vchyz6551h800aa6"))))
+ (build-system r-build-system)
+ (home-page "http://cran.r-project.org/web/packages/diptest")
+ (synopsis "Hartigan's dip test statistic for unimodality")
+ (description
+ "This package computes Hartigan's dip test statistic for unimodality,
+multimodality and provides a test with simulation based p-values, where the
+original public code has been corrected.")
+ (license license:gpl2+)))