summaryrefslogtreecommitdiff
path: root/gnu/packages/sugar.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/sugar.scm')
-rw-r--r--gnu/packages/sugar.scm7
1 files changed, 3 insertions, 4 deletions
diff --git a/gnu/packages/sugar.scm b/gnu/packages/sugar.scm
index 94c6f6d80f..6fec47b14f 100644
--- a/gnu/packages/sugar.scm
+++ b/gnu/packages/sugar.scm
@@ -120,12 +120,11 @@
;; XXX: The brightness component crashes, so we disable it here.
(substitute* "src/jarabe/main.py"
(("brightness.get_instance\\(\\)") ""))
- ;; TODO: these locations should be set to places that exist on
- ;; Guix System.
- #;
+ ;; This is a global location on Guix System. Ideally we would
+ ;; have a search path here.
(substitute* "extensions/cpsection/background/model.py"
(("\\('/usr', 'share', 'backgrounds'\\)")
- "('TODO')"))
+ "('/run', 'current-system', 'profile', 'share', 'backgrounds')"))
(substitute* "src/jarabe/view/viewhelp.py"
(("/usr/share/sugar/activities/")
"/run/current-system/profile/share/sugar/activities/"))))