summaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm72
1 files changed, 72 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index c4f9f6cfb7..63b144c45b 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -13,6 +13,7 @@
;;; Copyright © 2018 Danny Milosavljevic <dannym+a@scratchpost.org>
;;; Copyright © 2018, 2020 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
+;;; Copyright © 2020 Paul Garlick <pgarlick@tourbillion-technology.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -7308,3 +7309,74 @@ facilities designed to cope with the more specific demands of academic
writing, especially in the humanities and the social sciences. All quote
styles as well as the optional active quotes are freely configurable.")
(license license:lppl1.3c+))))
+
+(define-public texlive-logreq
+ (let ((template (simple-texlive-package
+ "texlive-logreq"
+ (list "/doc/latex/logreq/"
+ "/tex/latex/logreq/")
+ (base32
+ "13difccs3cxlkqlnhw286yb0c7mifrxfd402a2x5wwxv0m1kgfqd")
+ #:trivial? #t)))
+ (package
+ (inherit template)
+ (propagated-inputs
+ `(("texlive-etoolbox" ,texlive-etoolbox)))
+ (home-page "https://www.ctan.org/pkg/logreq")
+ (synopsis "Support for automation of the LaTeX workflow")
+ (description "The package helps to automate a typical LaTeX
+workflow that involves running LaTeX several times and running tools
+such as BibTeX or makeindex. It will log requests like \"please rerun
+LaTeX\" or \"please run BibTeX on file X\" to an external file in a
+machine-readable format. Compiler scripts and integrated LaTeX
+editing environments may parse this file to determine the next steps
+in the workflow. In sum, the package will do two things:
+
+@enumerate
+@item
+enable package authors to use LaTeX commands to issue requests, and
+
+@item
+collect all requests from all packages and write them to an external
+XML file.
+@end enumerate\n")
+ (license license:lppl1.3c))))
+
+(define-public texlive-biblatex
+ (let ((template (simple-texlive-package
+ "texlive-biblatex"
+ (list "/doc/latex/biblatex/"
+ "/tex/latex/biblatex/")
+ (base32
+ "11kzvny50iklzkamr0rqd5x532q8rxny1xhmf96jl8mzj1d2zmay")
+ #:trivial? #t)))
+ (package
+ (inherit template)
+ (propagated-inputs
+ `(("texlive-logreq" ,texlive-logreq)
+ ("texlive-url" ,texlive-url)))
+ (home-page "https://www.ctan.org/pkg/biblatex")
+ (synopsis "Sophisticated bibliographies in LaTeX")
+ (description "BibLaTeX is a complete reimplementation of the
+bibliographic facilities provided by LaTeX. Formatting of the
+bibliography is entirely controlled by LaTeX macros, facilitating the
+design of new bibliography and citation styles. BibLaTeX uses its own
+data backend program \"biber\" to read and process the bibliographic
+data. With biber, the range of features provided by biblatex
+includes:
+
+@enumerate
+@item
+full unicode support,
+
+@item
+customisable bibliography labels,
+
+@item
+multiple bibliographies in the same document, and
+
+@item
+subdivided bibliographies, such as bibliographies per chapter or
+section.
+@end enumerate\n")
+ (license license:lppl1.3c))))