summaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm7
1 files changed, 7 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index a31e2695e7..d95434aa8f 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -2402,6 +2402,13 @@ formats.")
(srfi srfi-26)))
((#:phases phases)
`(modify-phases ,phases
+ ;; The literal tab in the dtx file is translated to the string
+ ;; "^^I" in the generated Lua file, which causes a syntax error.
+ (add-after 'unpack 'fix-lua-sources
+ (lambda _
+ (substitute* "source/latex/base/ltluatex.dtx"
+ ((" ") " "))
+ #t))
(replace 'build
(lambda* (#:key inputs #:allow-other-keys)
;; Find required fonts