summaryrefslogtreecommitdiff
path: root/gnu/packages/texinfo.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/texinfo.scm')
-rw-r--r--gnu/packages/texinfo.scm21
1 files changed, 19 insertions, 2 deletions
diff --git a/gnu/packages/texinfo.scm b/gnu/packages/texinfo.scm
index f254d59db6..9200083eab 100644
--- a/gnu/packages/texinfo.scm
+++ b/gnu/packages/texinfo.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012, 2013, 2015, 2016, 2017, 2019 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2012, 2013, 2015, 2016, 2017, 2019, 2022 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2014, 2016 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2017, 2019, 2022 Efraim Flashner <efraim@flashner.co.il>
@@ -40,6 +40,7 @@
#:use-module (gnu packages autotools)
#:use-module (gnu packages compression)
#:use-module (gnu packages gettext)
+ #:use-module ((gnu packages hurd) #:select (hurd-target?))
#:use-module (gnu packages ncurses)
#:use-module (gnu packages perl)
#:use-module (gnu packages readline))
@@ -72,7 +73,11 @@
(("env -i")
"env "))
#t)))
- %standard-phases)))
+ %standard-phases)
+
+ ;; XXX: Work around <https://issues.guix.gnu.org/59616>.
+ #:tests? ,(and (not (hurd-target?))
+ (not (%current-target-system)))))
(inputs (list ncurses perl))
;; When cross-compiling, texinfo will build some of its own binaries with
;; the native compiler. This means ncurses is needed both in both inputs
@@ -96,6 +101,18 @@ their source and the command-line Info reader. The emphasis of the language
is on expressing the content semantically, avoiding physical markup commands.")
(license gpl3+)))
+(define-public texinfo-7
+ (package
+ (inherit texinfo)
+ (version "7.0.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnu/texinfo/texinfo-"
+ version ".tar.xz"))
+ (sha256
+ (base32
+ "1balvbkdlwa8zwnzp4irkixq1zhps2wr6njmwj4ilgiqc4rfq4gj"))))))
+
(define-public texinfo-5
(package (inherit texinfo)
(version "5.2")