summaryrefslogtreecommitdiff
path: root/gnu/packages/text-editors.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/text-editors.scm')
-rw-r--r--gnu/packages/text-editors.scm17
1 files changed, 12 insertions, 5 deletions
diff --git a/gnu/packages/text-editors.scm b/gnu/packages/text-editors.scm
index a0518f9481..e1d85d411c 100644
--- a/gnu/packages/text-editors.scm
+++ b/gnu/packages/text-editors.scm
@@ -911,7 +911,7 @@ in plain text file format.")
(define-public editorconfig-core-c
(package
(name "editorconfig-core-c")
- (version "0.12.5")
+ (version "0.12.6")
(source
(origin
(method git-fetch)
@@ -920,7 +920,7 @@ in plain text file format.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "073sh18y0v8wm10iphaia54pkdmwylalccpn1k5i9dwyfjzgj7yg"))))
+ (base32 "05qllpls3r95nfl14gqq3cv4lisf07fgn85n52w8blc5pfl1h93g"))))
(build-system cmake-build-system)
(arguments
'(#:phases
@@ -930,6 +930,13 @@ in plain text file format.")
(let ((tests (assoc-ref inputs "tests")))
(copy-recursively tests "tests"))
#t))
+ (add-after 'insert-tests 'disable-failing-tests
+ (lambda _
+ (substitute* "tests/parser/CMakeLists.txt"
+ (("# Test max property name and values")
+ "# Disabled: test max property name and values\nif(FALSE)\n")
+ (("# Test max section names")
+ "endif()\n\n# Test max section names"))))
(add-after 'install 'delete-static-library
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
@@ -1060,7 +1067,7 @@ Octave. TeXmacs is completely extensible via Guile.")
(build-system meson-build-system)
(native-inputs
(list appstream-glib
- blueprint-compiler
+ blueprint-compiler-0.4
desktop-file-utils
gettext-minimal
`(,glib "bin")
@@ -1100,14 +1107,14 @@ The basic features of Text Pieces are:
(define-public scintilla
(package
(name "scintilla")
- (version "5.3.4")
+ (version "5.4.3")
(source
(origin
(method url-fetch)
(uri (string-append "https://www.scintilla.org/scintilla"
(string-delete #\. version) ".tgz"))
(sha256
- (base32 "0inbhzqdikisvnbdzn8153p1apbghxjzkkzji9i8zsdpyapb209z"))))
+ (base32 "1ysdi9rsg14w5mn581gjvr9jrdg1yp9rmg1r9jz7gngdgcz7q5ij"))))
(build-system gnu-build-system)
(arguments
(list