summaryrefslogtreecommitdiff
path: root/gnu/packages/text-editors.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/text-editors.scm')
-rw-r--r--gnu/packages/text-editors.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/text-editors.scm b/gnu/packages/text-editors.scm
index 91e37b16d7..47a8fa81c8 100644
--- a/gnu/packages/text-editors.scm
+++ b/gnu/packages/text-editors.scm
@@ -862,14 +862,14 @@ Octave. TeXmacs is completely extensible via Guile.")
(define-public scintilla
(package
(name "scintilla")
- (version "4.4.6")
+ (version "5.0.1")
(source
(origin
(method url-fetch)
(uri (let ((v (apply string-append (string-split version #\.))))
(string-append "https://www.scintilla.org/scintilla" v ".tgz")))
(sha256
- (base32 "1p62dq2fgdkvdn2clz1xjdj09acv87rbifl67zhlz7skqip31y9d"))))
+ (base32 "0w5550fijkhmzvdydd8770qq9dgnbq1sd0a8rn4g6mwyfpcyhbfy"))))
(build-system gnu-build-system)
(arguments
`(#:make-flags (list "GTK3=1" "CC=gcc" "-Cgtk")
@@ -889,7 +889,8 @@ Octave. TeXmacs is completely extensible via Guile.")
(find-files "include/" "."))
#t))))))
(native-inputs
- `(("pkg-config" ,pkg-config)
+ `(("gcc" ,gcc-9) ;Code has C++17 requirements
+ ("pkg-config" ,pkg-config)
("python" ,python-wrapper)))
(inputs
`(("gtk+" ,gtk+)))
@@ -966,7 +967,7 @@ The basic features of Geany are:
(define-public fe
(package
(name "fe")
- ;; Stable release is 1.8. However, this development version
+ ;; Stable release is 1.9. However, this development version
;; introduces support for UTF-8.
(version "2.0")
(source (origin
@@ -975,7 +976,7 @@ The basic features of Geany are:
"fe-" version ".tar.gz"))
(sha256
(base32
- "1hwws7si1752z6hp61zxznvgsb6846lp8zl1hn5ddhsbafwalwb9"))))
+ "10mk5wc3dsdp46b3hkjyd740gcdv6m1gvlr3p8xjxf55b3vfs0la"))))
(build-system gnu-build-system)
(arguments
`(#:tests? #f ;no test