summaryrefslogtreecommitdiff
path: root/gnu/packages/time.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/time.scm')
-rw-r--r--gnu/packages/time.scm19
1 files changed, 11 insertions, 8 deletions
diff --git a/gnu/packages/time.scm b/gnu/packages/time.scm
index 69aff5efaa..895cf6ac3b 100644
--- a/gnu/packages/time.scm
+++ b/gnu/packages/time.scm
@@ -88,17 +88,15 @@ to a file.")
(define-public python-pytz
(package
(name "python-pytz")
- (version "2017.3")
+ (version "2018.5")
(source
(origin
(method url-fetch)
- (uri (pypi-uri "pytz" version ".zip"))
+ (uri (pypi-uri "pytz" version ".tar.gz"))
(sha256
(base32
- "1dw5l527vcafvdqq4wadwl7ikhb2sssz0v0cssibh8890kyczr7s"))))
+ "0xzj5gkpdn2da8m6j47chlp6zrzcypv9m0fjv4236q3jw4fyzfgz"))))
(build-system python-build-system)
- (native-inputs
- `(("unzip" ,unzip)))
(home-page "http://pythonhosted.org/pytz")
(synopsis "Python timezone library")
(description "This library brings the Olson tz database into Python. It
@@ -143,15 +141,17 @@ Pendulum instances.")
(define-public python-dateutil
(package
(name "python-dateutil")
- (version "2.6.1")
+ (version "2.7.3")
(source
(origin
(method url-fetch)
(uri (pypi-uri "python-dateutil" version))
(sha256
(base32
- "1jkahssf0ir5ssxc3ydbp8cpv77limn8d4s77szb2nrgl2r3h749"))))
+ "1f7h54lg0w2ckch7592xpjkh8dg87k2br256h0iw49zn6bg02w72"))))
(build-system python-build-system)
+ (native-inputs
+ `(("python-setuptools-scm" ,python-setuptools-scm)))
(propagated-inputs
`(("python-six" ,python-six)))
(home-page "https://dateutil.readthedocs.io/en/stable/")
@@ -159,7 +159,10 @@ Pendulum instances.")
(description
"The dateutil module provides powerful extensions to the standard
datetime module, available in Python 2.3+.")
- (license bsd-3)))
+ ;; The license was changed from the three-clause BSD license to a dual
+ ;; Apache 2.0/BSD-3 variant at 2017-12-01. Some code is only available as
+ ;; BSD-3 still; but all new code is dual licensed (the user can choose).
+ (license (list bsd-3 asl2.0))))
(define-public python2-dateutil
(package-with-python2 python-dateutil))