summaryrefslogtreecommitdiff
path: root/gnu/packages/tls.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/tls.scm')
-rw-r--r--gnu/packages/tls.scm9
1 files changed, 8 insertions, 1 deletions
diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index 510f0571c1..d60eeea692 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -86,7 +86,14 @@
"179jskl7dmfp1rd2khkzmlibzgki4wi6hvmmwfv7q49r728b03qf"))))
(build-system gnu-build-system)
(arguments
- `(#:configure-flags '("--disable-static")))
+ `(#:configure-flags '("--disable-static")
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'ensure-file-offset-bits-64
+ ;; Note: lib/gl/sys/types.h has off_t, but only for Windows.
+ (lambda _
+ (setenv "CFLAGS" "-D_FILE_OFFSET_BITS=64")
+ #t)))))
(native-inputs `(("perl" ,perl)))
(home-page "https://www.gnu.org/software/libtasn1/")
(synopsis "ASN.1 library")