summaryrefslogtreecommitdiff
path: root/gnu/packages/tls.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/tls.scm')
-rw-r--r--gnu/packages/tls.scm23
1 files changed, 9 insertions, 14 deletions
diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index 70d985da14..90147ed805 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -449,6 +449,15 @@ OpenSSL for TARGET."
(arguments
(list
#:parallel-tests? #f
+ #:make-flags
+ ;; 'test_ssl_new.t' in 1.1.1n and 3.0.3 fails due to an expired
+ ;; certificate: <https://github.com/openssl/openssl/issues/18441>. Skip
+ ;; it.
+ #~(list #$@(if (or (target-arm?) (target-riscv64?))
+ ;; 'test_afalg' seems to be dependent on kernel features:
+ ;; <https://github.com/openssl/openssl/issues/12242>.
+ #~("TESTS=-test_afalg -tls_ssl_new")
+ #~("TESTS=-test_ssl_new")))
#:test-target "test"
;; Changes to OpenSSL sometimes cause Perl to "sneak in" to the closure,
;; so we explicitly disallow it here.
@@ -463,20 +472,6 @@ OpenSSL for TARGET."
#$(target->openssl-target
(%current-target-system))))))
#~())
- (replace 'check
- (lambda* (#:key tests? test-target #:allow-other-keys)
- (when tests?
- ;; 'test_ssl_new.t' in 1.1.1n and 3.0.3 fails due to an expired
- ;; certificate:
- ;; <https://github.com/openssl/openssl/issues/18441>.
- ;; Skip it.
- ;;
- ;; 'test_afalg' seems to be dependent on kernel features:
- ;; <https://github.com/openssl/openssl/issues/12242>.
- (invoke "make" test-target
- #$(if (or (target-arm?) (target-riscv64?))
- "TESTS=-test_afalg -tls_ssl_new"
- "TESTS=-test_ssl_new")))))
(replace 'configure
(lambda* (#:key configure-flags #:allow-other-keys)
;; It's not a shebang so patch-source-shebangs misses it.