summaryrefslogtreecommitdiff
path: root/gnu/packages/valgrind.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/valgrind.scm')
-rw-r--r--gnu/packages/valgrind.scm21
1 files changed, 19 insertions, 2 deletions
diff --git a/gnu/packages/valgrind.scm b/gnu/packages/valgrind.scm
index e044541282..1cdc0f3b71 100644
--- a/gnu/packages/valgrind.scm
+++ b/gnu/packages/valgrind.scm
@@ -1,8 +1,8 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013, 2014 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2013, 2014, 2022 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
-;;; Copyright © 2016, 2020 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016, 2020, 2022 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2020 Marius Bakke <marius@gnu.org>
;;;
@@ -82,6 +82,8 @@
tools. There are Valgrind tools that can automatically detect many memory
management and threading bugs, and profile your programs in detail. You can
also use Valgrind to build new tools.")
+ ;; https://valgrind.org/info/platforms.html
+ (supported-systems (delete "riscv64-linux" %supported-systems))
(license gpl2+)
;; Hide this variant so end users get the "interactive" Valgrind below.
@@ -94,3 +96,18 @@ also use Valgrind to build new tools.")
;; GDB is needed to provide a sane default for `--db-command'.
`(("gdb" ,gdb)))
(properties '())))
+
+(define-public valgrind-3.18
+ (package
+ (inherit valgrind/interactive)
+ (version "3.18.1")
+ (source (origin
+ (method url-fetch)
+ (uri (list (string-append "https://sourceware.org/pub/valgrind"
+ "/valgrind-" version ".tar.bz2")
+ (string-append "ftp://sourceware.org/pub/valgrind"
+ "/valgrind-" version ".tar.bz2")))
+ (sha256
+ (base32
+ "1xgph509i6adv9w2glviw3xrmlz0dssg8992hbvxsbkp7ahrm180"))
+ (patches (search-patches "valgrind-enable-arm.patch"))))))