summaryrefslogtreecommitdiff
path: root/gnu/packages/version-control.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/version-control.scm')
-rw-r--r--gnu/packages/version-control.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index c8e7ce1ee8..29be20699d 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -1602,7 +1602,7 @@ be served with a HTTP file server of your choice.")
(define-public darcs
(package
(name "darcs")
- (version "2.12.4")
+ (version "2.12.5")
(source
(origin
(method url-fetch)
@@ -1610,7 +1610,7 @@ be served with a HTTP file server of your choice.")
"darcs-" version ".tar.gz"))
(sha256
(base32
- "0jfwiwl5k8wspciq1kpmvh5yap4japrf97s9pvhcybxxhaj3ds28"))
+ "0lrm0sal5pl453mkqn8b9fc9l7lwinc140iqihya9g17bk408nrm"))
(modules '((guix build utils)))
;; Remove time-dependent code for reproducibility.
(snippet
@@ -1625,8 +1625,10 @@ be served with a HTTP file server of your choice.")
(arguments
`(#:configure-flags '("-fpkgconfig" "-fcurl" "-flibiconv" "-fthreaded"
"-fnetwork-uri" "-fhttp" "--flag=executable"
- "--flag=library")
- #:tests? #f)) ; 20 failing shell tests out of over 400
+ "--flag=library"
+ "--allow-newer=shelly")
+ ;; FIXME: darcs is not compatible with the latest QuickCheck
+ #:tests? #f))
(inputs
`(("ghc-cmdargs" ,ghc-cmdargs)
("ghc-split" ,ghc-split)
@@ -1644,7 +1646,6 @@ be served with a HTTP file server of your choice.")
("ghc-bytestring-builder" ,ghc-bytestring-builder)
("ghc-cryptohash" ,ghc-cryptohash)
("ghc-data-ordlist" ,ghc-data-ordlist)
- ("ghc-directory" ,ghc-directory)
("ghc-fgl" ,ghc-fgl)
("ghc-system-filepath" ,ghc-system-filepath)
("ghc-graphviz" ,ghc-graphviz)
@@ -1655,7 +1656,6 @@ be served with a HTTP file server of your choice.")
("ghc-mtl" ,ghc-mtl)
("ghc-old-time" ,ghc-old-time)
("ghc-parsec" ,ghc-parsec)
- ("ghc-process" ,ghc-process)
("ghc-random" ,ghc-random)
("ghc-regex-applicative" ,ghc-regex-applicative)
("ghc-regex-compat-tdfa" ,ghc-regex-compat-tdfa)