summaryrefslogtreecommitdiff
path: root/gnu/packages/version-control.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/version-control.scm')
-rw-r--r--gnu/packages/version-control.scm18
1 files changed, 8 insertions, 10 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index a3f4a4dd4b..70197744e7 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -1,7 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013 Nikita Karetnikov <nikita@karetnikov.org>
;;; Copyright © 2013 Cyril Roelandt <tipecaml@gmail.com>
-;;; Copyright © 2013, 2014, 2015, 2016, 2017 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2013, 2014, 2015, 2016, 2017, 2018 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2013, 2014 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2015, 2016 Mathieu Lirzin <mthl@gnu.org>
;;; Copyright © 2014, 2015, 2016 Mark H Weaver <mhw@netris.org>
@@ -391,7 +391,9 @@ everything from small to very large projects with speed and efficiency.")
(patches (search-patches "libgit2-0.25.1-mtime-0.patch"))
;; Remove bundled software.
- (snippet '(delete-file-recursively "deps"))
+ (snippet '(begin
+ (delete-file-recursively "deps")
+ #t))
(modules '((guix build utils)))))
(build-system cmake-build-system)
(outputs '("out" "debug"))
@@ -1539,11 +1541,6 @@ output of the 'git' command.")
(base32
"1ydis4y0amkgfr4y60sn076f1l41ya2kn89kfd9fqf44f9ccgb5r"))))
(build-system gnu-build-system)
- (arguments
- '(#:phases (modify-phases %standard-phases
- (add-after 'unpack 'bootstrap
- (lambda _
- (zero? (system* "autoreconf" "-vfi")))))))
(native-inputs `(("autoconf" ,autoconf)
("automake" ,automake)))
(home-page "https://github.com/0-wiz-0/findnewest/releases")
@@ -1615,7 +1612,7 @@ repository\" with git-annex.")
(define-public fossil
(package
(name "fossil")
- (version "2.4")
+ (version "2.5")
(source
(origin
(method url-fetch)
@@ -1629,7 +1626,7 @@ repository\" with git-annex.")
"fossil-src-" version ".tar.gz")))
(sha256
(base32
- "0add35lk2ac4qg29d7ygj7pskv8lfln33f3kgf6x3548msv9hd6j"))))
+ "1lxawkhr1ki9fqw8076fxib2b1w673449yzb6vxjshqzh5h77c7r"))))
(build-system gnu-build-system)
(native-inputs
`(("tcl" ,tcl) ;for configuration only
@@ -1721,7 +1718,8 @@ be served with a HTTP file server of your choice.")
(("__TIME__") "\"00:00:00\""))
(substitute* "src/impossible.h"
(("__DATE__") "\"\"")
- (("__TIME__") "\"\""))))))
+ (("__TIME__") "\"\""))
+ #t))))
(build-system haskell-build-system)
(arguments
`(#:configure-flags '("-fpkgconfig" "-fcurl" "-flibiconv" "-fthreaded"