summaryrefslogtreecommitdiff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm107
1 files changed, 49 insertions, 58 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 00072055d3..e5ec161ba4 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -1257,7 +1257,8 @@ H.264 (MPEG-4 AVC) video streams.")
(native-inputs
(list perl-module-build perl-test-pod perl-test-simple))
(inputs
- (list perl-data-dump
+ (list bash-minimal
+ perl-data-dump
perl-digest-md5
perl-encode
ffmpeg
@@ -1711,6 +1712,7 @@ operate properly.")
soxr
speex
srt
+ svt-av1
twolame
vidstab
x265
@@ -1799,6 +1801,7 @@ operate properly.")
"--enable-libsoxr"
"--enable-libspeex"
"--enable-libsrt"
+ "--enable-libsvtav1"
"--enable-libtheora"
"--enable-libtwolame"
"--enable-libvidstab"
@@ -1888,7 +1891,9 @@ audio/video codec library.")
version ".tar.xz"))
(sha256
(base32
- "14xadxm1yaamp216nq09xwasxg5g133v86dbb33mdg5di1zrlhdg"))))
+ "14xadxm1yaamp216nq09xwasxg5g133v86dbb33mdg5di1zrlhdg"))
+ (patches (search-patches "ffmpeg-remove-compressed_ten_bit_format.patch"
+ "ffmpeg-4-binutils-2.41.patch"))))
(inputs (modify-inputs (package-inputs ffmpeg)
(replace "sdl2" sdl2-2.0)))
(arguments
@@ -1906,10 +1911,11 @@ audio/video codec library.")
version ".tar.xz"))
(sha256
(base32
- "0np0yalqdrm7rn7iykgfzz3ly4vbgigrajg48c1l6n7qrzqvfszv"))))
+ "0np0yalqdrm7rn7iykgfzz3ly4vbgigrajg48c1l6n7qrzqvfszv"))
+ (patches (search-patches "ffmpeg-4-binutils-2.41.patch"))))
(arguments
(substitute-keyword-arguments (package-arguments ffmpeg-4)
- ((#:modules modules %gnu-build-system-modules)
+ ((#:modules modules %default-gnu-modules)
`((srfi srfi-1)
,@modules))
((#:configure-flags flags)
@@ -1917,7 +1923,8 @@ audio/video codec library.")
'("--enable-libdav1d"
"--enable-libaom"
"--enable-librav1e"
- "--enable-libsrt")))))
+ "--enable-libsrt"
+ "--enable-libsvtav1")))))
(inputs (modify-inputs (package-inputs ffmpeg-4)
(delete "dav1d" "libaom" "rav1e" "srt")))))
@@ -1931,7 +1938,8 @@ audio/video codec library.")
version ".tar.xz"))
(sha256
(base32
- "0c8m4hhv2k5fybha908wzrpnf3wqkq52hayl658jq4bah0igdfqz"))))
+ "0c8m4hhv2k5fybha908wzrpnf3wqkq52hayl658jq4bah0igdfqz"))
+ (patches (search-patches "ffmpeg-4-binutils-2.41.patch"))))
(arguments
`(#:tests? #f ; XXX: Enable them later, if required
#:configure-flags
@@ -2473,8 +2481,7 @@ input files is possible, including video files.")
;; Some of the tests require using the display to test out VLC,
;; which fails in our sandboxed build system
(substitute* "test/run_vlc.sh"
- (("./vlc --ignore-config") "echo"))
- #t)))
+ (("./vlc --ignore-config") "echo")))))
(add-after 'strip 'regenerate-plugin-cache
(lambda* (#:key outputs #:allow-other-keys)
;; The 'install-exec-hook' rule in the top-level Makefile.am
@@ -2500,8 +2507,7 @@ input files is possible, including video files.")
(let ((out (assoc-ref outputs "out"))
(plugin-path (getenv "QT_PLUGIN_PATH")))
(wrap-program (string-append out "/bin/vlc")
- `("QT_PLUGIN_PATH" ":" prefix (,plugin-path))))
- #t)))))
+ `("QT_PLUGIN_PATH" ":" prefix (,plugin-path)))))))))
(home-page "https://www.videolan.org/")
(synopsis "Audio and video framework")
(description "VLC is a cross-platform multimedia player and framework
@@ -2642,43 +2648,31 @@ SVCD, DVD, 3ivx, DivX 3/4/5, WMV and H.264 movies.")
"-Ddvdnav=enabled"
"-Dbuild-date=false")))
(native-inputs
- (list perl ;for zsh completion file
- pkg-config
- python-docutils
- python-wrapper))
+ (list perl ; for zsh completion file
+ pkg-config python-docutils python-wrapper))
;; Missing features: libguess, V4L2.
(inputs
- (list enca
- ladspa
- lcms
- libbs2b
- mpg123
- rsound
- vulkan-headers
- vulkan-loader
- yt-dlp))
- ;; XXX: These are propagated for the mpv pkg-config package, as they are
- ;; listed in Requires.private and would break 'pkg-config --exists mpv' if
- ;; unavailable.
- (propagated-inputs
(list alsa-lib
+ enca
ffmpeg
jack-1
+ ladspa
+ lcms
libass
libbluray
libcaca
+ libbs2b
libcdio-paranoia
- libdrm
- libdvdnav
libdvdread
+ libdvdnav
libjpeg-turbo
libplacebo
libva
libvdpau
libx11
libxext
- libxinerama
libxkbcommon
+ libxinerama
libxpresent
libxrandr
libxscrnsaver
@@ -2686,10 +2680,15 @@ SVCD, DVD, 3ivx, DivX 3/4/5, WMV and H.264 movies.")
;; XXX: lua > 5.2 is not currently supported; see meson.build
lua-5.2
mesa
+ mpg123
pulseaudio
+ rsound
shaderc
+ vulkan-headers
+ vulkan-loader
wayland
wayland-protocols
+ yt-dlp
zimg
zlib))
(home-page "https://mpv.io/")
@@ -2907,7 +2906,6 @@ To load this plugin, specify the following option when starting mpv:
(package
(name "libvpx")
(version "1.12.0")
- (replacement libvpx/fixed)
(source (origin
(method git-fetch)
(uri (git-reference
@@ -2917,7 +2915,8 @@ To load this plugin, specify the following option when starting mpv:
(sha256
(base32
"1x12f2bd4jqd532rnixmwvcx8d29yxiacpcxqqh86qczc49la8gm"))
- (patches (search-patches "libvpx-CVE-2016-2818.patch"))))
+ (patches (search-patches "libvpx-CVE-2016-2818.patch"
+ "libvpx-CVE-2023-5217.patch"))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags (list "--enable-shared"
@@ -2946,15 +2945,6 @@ To load this plugin, specify the following option when starting mpv:
(license license:bsd-3)
(home-page "https://www.webmproject.org/")))
-(define libvpx/fixed
- (package
- (inherit libvpx)
- (source
- (origin
- (inherit (package-source libvpx))
- (patches (search-patches "libvpx-CVE-2016-2818.patch"
- "libvpx-CVE-2023-5217.patch"))))))
-
(define-public orf-dl
(let ((commit "2dbbe7ef4e0efe0f3c1d59c503108e22d9065999")
(revision "1"))
@@ -3243,7 +3233,8 @@ audio, images) from the Web. It can use either mpv or vlc for playback.")
(native-inputs
(list perl-module-build))
(inputs
- (list perl-data-dump
+ (list bash-minimal
+ perl-data-dump
perl-file-sharedir
perl-gtk2
perl-json
@@ -3277,8 +3268,7 @@ audio, images) from the Web. It can use either mpv or vlc for playback.")
"bin/gtk3-youtube-viewer")
(("'xdg-open'")
(format #f "'~a/bin/xdg-open'"
- (assoc-ref inputs "xdg-utils"))))
- #t))
+ (assoc-ref inputs "xdg-utils"))))))
(add-after 'install 'install-desktop
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
@@ -3286,8 +3276,7 @@ audio, images) from the Web. It can use either mpv or vlc for playback.")
(install-file "share/gtk-youtube-viewer.desktop"
(string-append sharedir "/applications"))
(install-file "share/icons/gtk-youtube-viewer.png"
- (string-append sharedir "/pixmaps"))
- #t)))
+ (string-append sharedir "/pixmaps")))))
(add-after 'install 'wrap-program
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
@@ -3296,8 +3285,7 @@ audio, images) from the Web. It can use either mpv or vlc for playback.")
(lib-path (getenv "PERL5LIB")))
(for-each (cut wrap-program <>
`("PERL5LIB" ":" prefix (,lib-path ,site-dir)))
- (find-files bin-dir))
- #t))))))
+ (find-files bin-dir))))))))
(synopsis
"Lightweight application for searching and streaming videos from YouTube")
(description
@@ -4439,17 +4427,17 @@ and MPEG system streams.")
(define-public libbdplus
(package
(name "libbdplus")
- (version "0.1.2")
+ (version "0.2.0")
(source
(origin
(method url-fetch)
(uri (string-append "https://ftp.videolan.org/pub/videolan/libbdplus/"
version "/" name "-" version ".tar.bz2"))
(sha256
- (base32 "02n87lysqn4kg2qk7d1ffrp96c44zkdlxdj0n16hbgrlrpiwlcd6"))))
+ (base32 "0n0ayjq2ld7lfhrfcdj9bam96m2hih34phyjan8nwggkmqzflgmr"))))
+ (build-system gnu-build-system)
(inputs
(list libgcrypt))
- (build-system gnu-build-system)
(home-page "https://www.videolan.org/developers/libbdplus.html")
(synopsis "Library for decrypting certain Blu-Ray discs")
(description "libbdplus is a library which implements the BD+ System
@@ -5521,7 +5509,8 @@ API. It includes bindings for Python, Ruby, and other languages.")
(delete-file-recursively "src/images/fonts") #t))))
(build-system python-build-system)
(inputs
- (list ffmpeg
+ (list bash-minimal
+ ffmpeg
font-dejavu
libopenshot
python
@@ -5550,14 +5539,12 @@ API. It includes bindings for Python, Ruby, and other languages.")
(substitute* "src/classes/app.py"
(("info.IMAGES_PATH") (string-append "\"" font "\""))
(("fonts") "share/fonts/truetype")
- (("[A-Za-z_-]+.ttf") "DejaVuSans.ttf")))
- #t))
+ (("[A-Za-z_-]+.ttf") "DejaVuSans.ttf")))))
(add-before 'install 'set-tmp-home
(lambda _
;; src/classes/info.py "needs" to create several
;; directories in $HOME when loaded during build
- (setenv "HOME" "/tmp")
- #t))
+ (setenv "HOME" "/tmp")))
(add-after 'install 'wrap-program
(lambda* (#:key outputs inputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out"))
@@ -5712,7 +5699,8 @@ video from a Wayland session.")
(native-inputs
(list gettext-minimal pkg-config))
(inputs
- (list python-pygobject
+ (list bash-minimal
+ python-pygobject
gtk+
python-pycairo ; Required or else clicking on a subtitle line fails.
python-chardet ; Optional: Character encoding detection.
@@ -6167,7 +6155,10 @@ brightness, contrast, and frame rate.")
`("PERL5LIB" ":"
prefix (,(string-append perllib ":" (getenv "PERL5LIB")))))))))))
(inputs
- (list perl-mojolicious perl-lwp-protocol-https perl-xml-libxml))
+ (list bash-minimal
+ perl-mojolicious
+ perl-lwp-protocol-https
+ perl-xml-libxml))
(home-page "https://github.com/get-iplayer/get_iplayer")
(synopsis "Download or stream available BBC iPlayer TV and radio programmes")
(description "@code{get_iplayer} lists, searches and records BBC iPlayer