summaryrefslogtreecommitdiff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm56
1 files changed, 39 insertions, 17 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 2ad0565db3..ed090107b3 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -589,14 +589,14 @@ standards (MPEG-2, MPEG-4 ASP/H.263, MPEG-4 AVC/H.264, and VC-1/VMW3).")
(define-public ffmpeg
(package
(name "ffmpeg")
- (version "3.4")
+ (version "3.4.1")
(source (origin
(method url-fetch)
(uri (string-append "https://ffmpeg.org/releases/ffmpeg-"
version ".tar.xz"))
(sha256
(base32
- "1vzvpx8ixy8m44f8qwp833hv253hpghybgzbc4n8b3div3j0dvmf"))))
+ "1h4iz7q10wj04awr2wvmp60n7b09pfwrgwbbw9sgl7klcf52fxss"))))
(build-system gnu-build-system)
(inputs
`(("fontconfig" ,fontconfig)
@@ -762,19 +762,6 @@ convert and stream audio and video. It includes the libavcodec
audio/video codec library.")
(license license:gpl2+)))
-;; XXX: Remove this when gst-libav and qtox supports 3.4.
-(define-public ffmpeg-3.3
- (package
- (inherit ffmpeg)
- (version "3.3.5")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://ffmpeg.org/releases/ffmpeg-"
- version ".tar.xz"))
- (sha256
- (base32
- "00nq8ng2p16yb48acargaz1hlp9kq24vfwvkqjlslz4a7864k4x8"))))))
-
(define-public ffmpeg-2.8
(package
(inherit ffmpeg)
@@ -1142,7 +1129,7 @@ access to mpv's powerful playback capabilities.")
(define-public youtube-dl
(package
(name "youtube-dl")
- (version "2017.12.02")
+ (version "2017.12.14")
(source (origin
(method url-fetch)
(uri (string-append "https://yt-dl.org/downloads/"
@@ -1150,7 +1137,7 @@ access to mpv's powerful playback capabilities.")
version ".tar.gz"))
(sha256
(base32
- "1qf5gz00cnxzab3cwh9kxzhs08mddm0nwvb7j5z5xxzhi6wkslha"))))
+ "01hvsch7ybff0amivl86m6klz156bm3hfh66zz5q8ha2af5j44hj"))))
(build-system python-build-system)
(arguments
;; The problem here is that the directory for the man page and completion
@@ -1877,6 +1864,41 @@ present in modern GPUs.")
implementation.")
(license (license:x11-style "file://COPYING"))))
+(define-public libvdpau-va-gl
+ (package
+ (name "libvdpau-va-gl")
+ (version "0.4.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/i-rinat/libvdpau-va-gl/"
+ "releases/download/v" version "/libvdpau-va-gl-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1x2ag1f2fwa4yh1g5spv99w9x1m33hbxlqwyhm205ssq0ra234bx"))
+ (patches (search-patches "libvdpau-va-gl-unbundle.patch"))
+ (modules '((guix build utils)))
+ (snippet '(delete-file-recursively "3rdparty"))))
+ (build-system cmake-build-system)
+ (arguments
+ '(#:tests? #f)) ; Tests require a running X11 server, with VA-API support.
+ (native-inputs
+ `(("libvdpau" ,libvdpau)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("libva" ,libva)
+ ("mesa" ,mesa)))
+ (home-page "https://github.com/i-rinat/libvdpau-va-gl")
+ (synopsis "VDPAU driver with VA-API/OpenGL backend")
+ (description
+ "Many applications can use VDPAU to accelerate portions of the video
+decoding process and video post-processing to the GPU video hardware. Since
+there is no VDPAU available on Intel chips, they fall back to different drawing
+techniques. This driver uses OpenGL under the hood to accelerate drawing and
+scaling and VA-API (if available) to accelerate video decoding.")
+ (license license:expat)))
+
(define-public recordmydesktop
(package
(name "recordmydesktop")