summaryrefslogtreecommitdiff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm74
1 files changed, 65 insertions, 9 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index b45e96d1e9..bf5999177e 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -53,6 +53,7 @@
#:use-module (guix build-system gnu)
#:use-module (guix build-system glib-or-gtk)
#:use-module (guix build-system meson)
+ #:use-module (guix build-system perl)
#:use-module (guix build-system python)
#:use-module (guix build-system waf)
#:use-module (gnu packages)
@@ -1089,7 +1090,7 @@ projects while introducing many more.")
(define-public gnome-mpv
(package
(name "gnome-mpv")
- (version "0.13")
+ (version "0.14")
(source
(origin
(method url-fetch)
@@ -1098,7 +1099,7 @@ projects while introducing many more.")
".tar.xz"))
(sha256
(base32
- "1w944ymyssgfcjiczrq4saig90crw9b9hhdsnchfbjsw173qi8n5"))))
+ "03kjwd5jq0i5ajnvhjwf5019bjjaa16xkdrhdkiz1k58ipjvvj93"))))
(native-inputs
`(("intltool" ,intltool)
("pkg-config" ,pkg-config)))
@@ -1156,7 +1157,7 @@ access to mpv's powerful playback capabilities.")
(define-public youtube-dl
(package
(name "youtube-dl")
- (version "2018.02.11")
+ (version "2018.03.10")
(source (origin
(method url-fetch)
(uri (string-append "https://yt-dl.org/downloads/"
@@ -1164,7 +1165,7 @@ access to mpv's powerful playback capabilities.")
version ".tar.gz"))
(sha256
(base32
- "0zg34spkfiwjq55jrk417ifdcyvrj80gdbc338rdpfw2s6ibggv8"))))
+ "1ibmz91anli1vzkgw2i3h4wf1i8arzd74730ylwcwyg3375xryjb"))))
(build-system python-build-system)
(arguments
;; The problem here is that the directory for the man page and completion
@@ -1310,6 +1311,61 @@ audio, images) from the Web. It can use either mpv or vlc for playback.")
(home-page "https://you-get.org/")
(license license:expat)))
+(define-public youtube-viewer
+ (package
+ (name "youtube-viewer")
+ (version "3.3.3")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/trizen/youtube-viewer/archive/"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1j572his6qmazlmyrbnfq62s9bqml875ay7wy26byy9hfc7m0vgk"))))
+ (build-system perl-build-system)
+ (native-inputs
+ `(("perl-module-build" ,perl-module-build)))
+ ;; FIXME: Add optional dependencies once available:
+ ;; perl-lwp-useragent-cached and perl-term-readline-gnu
+ (inputs
+ `(("perl-data-dump" ,perl-data-dump)
+ ("perl-file-sharedir" ,perl-file-sharedir)
+ ("perl-gtk2" ,perl-gtk2)
+ ("perl-json" ,perl-json)
+ ("perl-libwww" ,perl-libwww)
+ ("perl-lwp-protocol-https" ,perl-lwp-protocol-https)
+ ("perl-mozilla-ca" ,perl-mozilla-ca)
+ ("perl-unicode-linebreak" ,perl-unicode-linebreak)))
+ (arguments
+ `(#:modules ((guix build perl-build-system)
+ (guix build utils)
+ (srfi srfi-26))
+ #:module-build-flags '("--gtk")
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'wrap-program
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (bin-dir (string-append out "/bin/"))
+ (site-dir (string-append out "/lib/perl5/site_perl/"))
+ (lib-path (getenv "PERL5LIB")))
+ (for-each (cut wrap-program <>
+ `("PERL5LIB" ":" prefix (,lib-path ,site-dir)))
+ (find-files bin-dir))
+ #t))))))
+ (synopsis
+ "Lightweight application for searching and streaming videos from YouTube")
+ (description
+ "Youtube-viewer searches and plays YouTube videos in a native player.
+It comes with various search options; it can search for videos, playlists
+and/or channels. The videos are streamed directly in a selected video player
+at the best resolution (customizable) and with closed-captions (if available).
+Both command-line and GTK2 interface are available.")
+ (home-page "https://github.com/trizen/youtube-viewer")
+ (license license:perl-license)))
+
(define-public libbluray
(package
(name "libbluray")
@@ -1981,7 +2037,7 @@ making @dfn{screencasts}.")
(define-public simplescreenrecorder
(package
(name "simplescreenrecorder")
- (version "0.3.9")
+ (version "0.3.10")
(source
(origin
(method url-fetch)
@@ -1990,7 +2046,7 @@ making @dfn{screencasts}.")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "1gnf9wbiq2fcbqcn1a5nfmp8r0nxrrlgh2wly2mfkkwymynhx0pk"))))
+ "02rl9yyx3hlz9fqvgzv7ipmvx2qahj7ws5wx2m7zs3lssq3qag3g"))))
(build-system cmake-build-system)
;; Although libx11, libxfixes, libxext are listed as build dependencies in
;; README.md, the program builds and functions properly without them.
@@ -2474,7 +2530,7 @@ RTSP or SIP clients and servers.")
(define-public libdvbpsi
(package
(name "libdvbpsi")
- (version "1.3.1")
+ (version "1.3.2")
(source (origin
(method url-fetch)
(uri (string-append
@@ -2482,7 +2538,7 @@ RTSP or SIP clients and servers.")
version "/libdvbpsi-" version ".tar.bz2"))
(sha256
(base32
- "0824r08kaspbrrg2dd5d46s475zb7j59brqkm2y6x3mdsnpng0yn"))))
+ "1zn5hfv4qbahmydbwh59a3b480s3m5ss27r6ml35gqdip7r3jkmc"))))
(build-system gnu-build-system)
(home-page "https://www.videolan.org/developers/libdvbpsi.html")
(synopsis "Library for decoding and generation of MPEG TS and DVB PSI
@@ -2704,7 +2760,7 @@ It counts more than 100 plugins.")
(file-name (string-append name "-" version ".tar.gz"))))
(build-system gnu-build-system)
(native-inputs
- `(("autoconf" ,(autoconf-wrapper))
+ `(("autoconf" ,autoconf-wrapper)
("automake" ,automake)
("pkg-config" ,pkg-config)))
(inputs