summaryrefslogtreecommitdiff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm9
1 files changed, 4 insertions, 5 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 8ded42ce96..661ef91386 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -320,8 +320,7 @@ standards (MPEG-2, MPEG-4 ASP/H.263, MPEG-4 AVC/H.264, and VC-1/VMW3).")
(guix build utils)
(guix build rpath)
(srfi srfi-26))
- #:imported-modules ((guix build gnu-build-system)
- (guix build utils)
+ #:imported-modules (,@%gnu-build-system-modules
(guix build rpath))
#:phases
(alist-replace
@@ -775,12 +774,12 @@ several areas.")
'(#:phases
(modify-phases %standard-phases
(add-before
- configure setup-waf
+ 'configure 'setup-waf
(lambda* (#:key inputs #:allow-other-keys)
(copy-file (assoc-ref inputs "waf") "waf")
(setenv "CC" "gcc")))
(add-before
- configure patch-wscript
+ 'configure 'patch-wscript
(lambda* (#:key inputs #:allow-other-keys)
(substitute* "wscript"
;; XXX Remove this when our Samba package provides a .pc file.
@@ -1256,7 +1255,7 @@ capabilities.")
'(#:phases
(modify-phases %standard-phases
(add-after
- unpack autogen
+ 'unpack 'autogen
(lambda _
(zero? (system* "sh" "autogen.sh")))))))
(home-page "http://www.vapoursynth.com/")