summaryrefslogtreecommitdiff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm57
1 files changed, 30 insertions, 27 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index f7f82df072..94e1729403 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -206,8 +206,7 @@ old-fashioned output methods with powerful ascii-art renderer.")
(modify-phases %standard-phases
;; XXX We need to run ./bootstrap because of the build
;; system fixes above.
- (add-after
- 'unpack 'bootstrap
+ (replace 'bootstrap
(lambda _ (zero? (system* "sh" "bootstrap")))))))
(home-page "http://liba52.sourceforge.net/")
(synopsis "ATSC A/52 stream decoder")
@@ -304,15 +303,15 @@ H.264 (MPEG-4 AVC) video streams.")
(base32
"0hknnnnx9661igm1r73dc7aqxnnrl5a8yvyvr1nhd9ymn2klwpl5"))
(modules '((guix build utils)))
- (snippet
- '(begin
- ;; Delete bundled libraries.
- (for-each delete-file-recursively
- '("lib/libebml"
- "lib/libmatroska"
- "lib/nlohmann-json"
- "lib/pugixml"
- "lib/utf8-cpp"))))))
+ (snippet '(begin
+ ;; Delete bundled libraries.
+ (for-each delete-file-recursively
+ '("lib/libebml"
+ "lib/libmatroska"
+ "lib/nlohmann-json"
+ "lib/pugixml"
+ "lib/utf8-cpp"))
+ #t))))
(build-system gnu-build-system)
(inputs
`(("boost" ,boost)
@@ -388,8 +387,9 @@ and creating Matroska files from other media files (@code{mkvmerge}).")
(base32
"1gyd94jkwdii9308m07nymsbxrmrcl81c0j8i10zhslr2mj07w0v"))
(modules '((guix build utils)))
- (snippet
- '(delete-file-recursively "source/compat/getopt"))))
+ (snippet '(begin
+ (delete-file-recursively "source/compat/getopt")
+ #t))))
(build-system cmake-build-system)
(arguments
`(#:tests? #f ; tests are skipped if cpu-optimized code isn't built
@@ -1795,10 +1795,11 @@ from sites like Twitch.tv and pipes them into a video player of choice.")
(base32
"10m3ry0b2pvqx3bk34qh5dq337nn8pkc2gzfyhsj4nv9abskln47"))
(modules '((guix build utils)))
- (snippet
- ;; As of glibc 2.26, <xlocale.h> no longer is.
- '(substitute* "src/framework/mlt_property.h"
- (("xlocale\\.h") "locale.h")))))
+ (snippet '(begin
+ ;; As of glibc 2.26, <xlocale.h> no longer is.
+ (substitute* "src/framework/mlt_property.h"
+ (("xlocale\\.h") "locale.h"))
+ #t))))
(build-system gnu-build-system)
(arguments
`(#:tests? #f ; no tests
@@ -1935,9 +1936,9 @@ and JACK.")
(native-inputs
`(("pkg-config" ,pkg-config)))
(inputs
- `(("dri2proto" ,dri2proto)
- ("libx11" ,libx11 "out")
- ("libxext" ,libxext)))
+ `(("libx11" ,libx11 "out")
+ ("libxext" ,libxext)
+ ("xorgproto" ,xorgproto)))
(home-page "https://wiki.freedesktop.org/www/Software/VDPAU/")
(synopsis "Video Decode and Presentation API")
(description "VDPAU is the Video Decode and Presentation API for UNIX. It
@@ -1984,7 +1985,8 @@ implementation.")
"1x2ag1f2fwa4yh1g5spv99w9x1m33hbxlqwyhm205ssq0ra234bx"))
(patches (search-patches "libvdpau-va-gl-unbundle.patch"))
(modules '((guix build utils)))
- (snippet '(delete-file-recursively "3rdparty"))))
+ (snippet '(begin (delete-file-recursively "3rdparty")
+ #t))))
(build-system cmake-build-system)
(arguments
'(#:tests? #f)) ; Tests require a running X11 server, with VA-API support.
@@ -2251,7 +2253,7 @@ supported players in addition to this package.")
`(#:tests? #f ;tests require Ruby and claim to be unsupported
#:phases
(modify-phases %standard-phases
- (add-before 'patch-source-shebangs 'bootstrap-gtk
+ (replace 'bootstrap
;; Run bootstrap ahead of time so that shebangs get patched.
(lambda _
(setenv "CONFIG_SHELL" (which "sh"))
@@ -2496,10 +2498,11 @@ many codecs and formats supported by libmediainfo.")
(base32
"0f5kxpayqn3yhabqrd2cqlc74i6x2xr01jfkank1lcilxnfyrsnq"))
(modules '((guix build utils)))
- (snippet
- ;; As of glibc 2.26, <xlocale.h> no longer is.
- '(substitute* "liveMedia/include/Locale.hh"
- (("xlocale\\.h") "locale.h")))))
+ (snippet '(begin
+ ;; As of glibc 2.26, <xlocale.h> no longer is.
+ (substitute* "liveMedia/include/Locale.hh"
+ (("xlocale\\.h") "locale.h"))
+ #t))))
(build-system gnu-build-system)
(arguments
'(#:tests? #f ; no tests
@@ -2770,7 +2773,7 @@ It counts more than 100 plugins.")
("sqlite" ,sqlite)))
(arguments
'(#:phases (modify-phases %standard-phases
- (add-after 'unpack 'bootstrap
+ (replace 'bootstrap
(lambda _
(patch-shebang "version.sh")
(invoke "autoreconf" "-vfi"))))