summaryrefslogtreecommitdiff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm15
1 files changed, 14 insertions, 1 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index de9fb42904..b3e6e5ef7b 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -904,6 +904,8 @@ shared library and encoder and decoder command-line executables.")
(build-system gnu-build-system)
(native-inputs
(list pkg-config nasm))
+ (inputs
+ (list config))
;; TODO: Add gpac input
(arguments
`(#:tests? #f ;no check target
@@ -914,6 +916,7 @@ shared library and encoder and decoder command-line executables.")
;; program depends on ffmpeg and ffmpeg depends on
;; libx264).
"--disable-cli"
+ "--enable-pic"
;; On MIPS, we must pass "--disable-asm" or else
;; configure fails after printing: "You specified a
@@ -924,7 +927,17 @@ shared library and encoder and decoder command-line executables.")
(or (%current-target-system)
(%current-system)))
'("--disable-asm")
- '()))))
+ '()))
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'update-config-scripts
+ (lambda* (#:key native-inputs inputs #:allow-other-keys)
+ (for-each (lambda (file)
+ (install-file
+ (search-input-file
+ (or native-inputs inputs)
+ (string-append "/bin/" file)) "."))
+ '("config.guess" "config.sub")))))))
(home-page "https://www.videolan.org/developers/x264.html")
(synopsis "H.264 video coding library")
(description "libx264 is an advanced encoding library for creating