summaryrefslogtreecommitdiff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm108
1 files changed, 53 insertions, 55 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 8f4019b9c0..3a7b7dc29d 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -315,6 +315,8 @@ a shared library and encoder and decoder command-line executables.")
;; because the SourceForge project is misconfigured.
(uri (string-append "http://libmpeg2.sourceforge.net/files/"
name "-" version ".tar.gz"))
+ (patches (search-patches "libmpeg2-arm-private-symbols.patch"
+ "libmpeg2-global-symbol-test.patch"))
(sha256
(base32
"1m3i322n2fwgrvbs1yck7g5md1dbg22bhq5xdqmjpz5m7j4jxqny"))))
@@ -506,7 +508,7 @@ H.264 (MPEG-4 AVC) video streams.")
(define-public x265
(package
(name "x265")
- (version "3.1.2")
+ (version "3.2.1")
(outputs '("out" "static"))
(source
(origin
@@ -516,8 +518,7 @@ H.264 (MPEG-4 AVC) video streams.")
(string-append "https://download.videolan.org/videolan/x265/"
"x265_" version ".tar.gz")))
(sha256
- (base32
- "1ajr59gjj47gnczfb2qhmzclj746pdiq9a1d81b0mq22k8f5yy3g"))
+ (base32 "1k5vijsy6cgcghw69f5275xfmbjjx7js0nlbgxbd6krnjb7sv6zv"))
(patches (search-patches "x265-arm-flags.patch"))
(modules '((guix build utils)))
(snippet '(begin
@@ -686,8 +687,8 @@ streams.")
(source (origin
(method url-fetch)
(uri (string-append
- "mirror://sourceforge/" name "/" name "/"
- version "/" name "-" version ".tar.gz"))
+ "mirror://sourceforge/libdv/libdv/"
+ version "/libdv-" version ".tar.gz"))
(sha256
(base32
"1fl96f2xh2slkv1i1ix7kqk576a0ak1d33cylm0mbhm96d0761d3"))))
@@ -1087,20 +1088,26 @@ videoformats depend on the configuration flags of ffmpeg.")
(name "vlc")
(version "3.0.8")
(source (origin
- (method url-fetch)
- (uri (string-append
- "https://download.videolan.org/pub/videolan/vlc/"
- (car (string-split version #\-))
- "/vlc-" version ".tar.xz"))
- (sha256
- (base32
- "1xmxjpyzdhabchwncz6lvx3kzvl7fz9c42bkv3nbj68albs9w570"))))
+ (method url-fetch)
+ (uri (string-append
+ "https://download.videolan.org/pub/videolan/vlc/"
+ (car (string-split version #\-))
+ "/vlc-" version ".tar.xz"))
+ (sha256
+ (base32
+ "1xmxjpyzdhabchwncz6lvx3kzvl7fz9c42bkv3nbj68albs9w570"))
+ (patches
+ (search-patches
+ ;; TODO: The test "libvlc_slaves" fails. Applied upstream as
+ ;; <https://git.videolan.org/?p=vlc.git;a=commit;h=4186c94104ee528abd6860611b49515f3e6ec644>.
+ ;; Try removing it in 3.0.9.
+ "vlc-fix-test_libvlc_slaves.patch"))))
(build-system gnu-build-system)
(native-inputs
`(("flex" ,flex)
("bison" ,bison)
("gettext" ,gettext-minimal)
- ("git" ,git) ; needed for a test
+ ("git" ,git) ; needed for a test
("pkg-config" ,pkg-config)))
;; FIXME: Add optional inputs once available.
(inputs
@@ -1178,11 +1185,10 @@ videoformats depend on the configuration flags of ffmpeg.")
("xcb-util-keysyms" ,xcb-util-keysyms)))
(arguments
`(#:configure-flags
- `("CXXFLAGS=-std=gnu++11"
- "BUILDCC=gcc"
+ `("BUILDCC=gcc"
,(string-append "LDFLAGS=-Wl,-rpath -Wl,"
(assoc-ref %build-inputs "ffmpeg")
- "/lib")) ;needed for the tests
+ "/lib")) ;needed for the tests
#:phases
(modify-phases %standard-phases
@@ -1233,11 +1239,11 @@ videoformats depend on the configuration flags of ffmpeg.")
(invoke cachegen plugindir))))
(add-after 'install 'wrap-executable
(lambda* (#:key outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out"))
- (plugin-path (getenv "QT_PLUGIN_PATH")))
- (wrap-program (string-append out "/bin/vlc")
- `("QT_PLUGIN_PATH" ":" prefix (,plugin-path))))
- #t)))))
+ (let ((out (assoc-ref outputs "out"))
+ (plugin-path (getenv "QT_PLUGIN_PATH")))
+ (wrap-program (string-append out "/bin/vlc")
+ `("QT_PLUGIN_PATH" ":" prefix (,plugin-path))))
+ #t)))))
(home-page "https://www.videolan.org/")
(synopsis "Audio and video framework")
(description "VLC is a cross-platform multimedia player and framework
@@ -1341,7 +1347,7 @@ SVCD, DVD, 3ivx, DivX 3/4/5, WMV and H.264 movies.")
(define-public mpv
(package
(name "mpv")
- (version "0.29.1")
+ (version "0.30.0")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -1350,7 +1356,7 @@ SVCD, DVD, 3ivx, DivX 3/4/5, WMV and H.264 movies.")
(file-name (git-file-name name version))
(sha256
(base32
- "138921kx8g6qprim558xin09xximjhsj9ss8b71ifg2m6kclym8m"))))
+ "17mxjgcfljlv6h0ik3332xsqbs0ybvk6dkwflyl0cjh15vl1iv6f"))))
(build-system waf-build-system)
(native-inputs
`(("perl" ,perl) ; for zsh completion file
@@ -1416,9 +1422,7 @@ SVCD, DVD, 3ivx, DivX 3/4/5, WMV and H.264 movies.")
#t)))
#:configure-flags (list "--enable-libmpv-shared"
"--enable-cdda"
- "--enable-dvdread"
"--enable-dvdnav"
- "--enable-zsh-comp"
"--disable-build-date")
;; No check function defined.
#:tests? #f))
@@ -1493,7 +1497,7 @@ projects while introducing many more.")
(define-public youtube-dl
(package
(name "youtube-dl")
- (version "2019.09.28")
+ (version "2019.11.05")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/ytdl-org/youtube-dl/"
@@ -1501,7 +1505,7 @@ projects while introducing many more.")
version ".tar.gz"))
(sha256
(base32
- "0nrk0bk6lksnmng8lwhcpkc57iibzjjamlqz8rxjpsw6dnzxz82h"))))
+ "129461i4103slqj3nq69djnlmgjj3lfgmazn41avc5g967w29b85"))))
(build-system python-build-system)
(arguments
;; The problem here is that the directory for the man page and completion
@@ -1798,7 +1802,7 @@ players, like VLC or MPlayer.")
(define-public libdvdread
(package
(name "libdvdread")
- (version "6.0.1")
+ (version "6.0.2")
(source (origin
(method url-fetch)
(uri (string-append "https://download.videolan.org/videolan/"
@@ -1806,7 +1810,7 @@ players, like VLC or MPlayer.")
"libdvdread-" version ".tar.bz2"))
(sha256
(base32
- "1gfmh8ii3s2fw1c8vn57piwxc0smd3va4h7xgp9s8g48cc04zki8"))))
+ "1c7yqqn67m3y3n7nfrgrnzz034zjaw5caijbwbfrq89v46ph257r"))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags '("--with-libdvdcss=yes")))
@@ -1854,15 +1858,15 @@ MPEG-2 stream containing VOB packets.")
(define-public libdvdnav
(package
(name "libdvdnav")
- (version "6.0.0")
+ (version "6.0.1")
(source (origin
(method url-fetch)
(uri (string-append "https://download.videolan.org/videolan/"
- name "/" version "/"
- name "-" version ".tar.bz2"))
+ "libdvdnav/" version "/"
+ "libdvdnav-" version ".tar.bz2"))
(sha256
(base32
- "062njcksmpgw9yv3737qkf93r2pzhaxi9szqjabpa8d010dp38ph"))))
+ "0cv7j8irsv1n2dadlnhr6i1b8pann2ah6xpxic41f04my6ba6rp5"))))
(build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)))
@@ -1927,7 +1931,7 @@ for use with HTML5 video.")
(define-public avidemux
(package
(name "avidemux")
- (version "2.7.3")
+ (version "2.7.4")
(source (origin
(method url-fetch)
(uri (string-append
@@ -1935,7 +1939,7 @@ for use with HTML5 video.")
"avidemux_" version ".tar.gz"))
(sha256
(base32
- "17x2mnnr5h8pp764p55l1xcn2ljnzhbj8cykajlllvk4rc4qwxld"))
+ "1acdb3m37vdzzbm8mwyibcn8msi7birb5v30qfi7jli5r00src3x"))
(patches (search-patches "avidemux-install-to-lib.patch"))))
(build-system cmake-build-system)
(native-inputs
@@ -1968,7 +1972,7 @@ for use with HTML5 video.")
#:phases
;; Make sure files inside the included ffmpeg tarball are
;; patch-shebanged.
- (let ((ffmpeg "ffmpeg-4.1.1"))
+ (let ((ffmpeg "ffmpeg-4.1.4"))
(modify-phases %standard-phases
(add-before 'patch-source-shebangs 'unpack-ffmpeg
(lambda _
@@ -2050,7 +2054,7 @@ capabilities.")
(define-public vapoursynth
(package
(name "vapoursynth")
- (version "37")
+ (version "48")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -2059,7 +2063,7 @@ capabilities.")
(file-name (git-file-name name version))
(sha256
(base32
- "1ma2s7dxk6y6l04qj1jvgwia4xj7999ny3a1yx2vbk5l83giam2p"))))
+ "1i6163bidlp0p9zcnxpsphr44ayfzd51fig4ri7vbrbl9lw9jaih"))))
(build-system gnu-build-system)
(native-inputs
`(("autoconf" ,autoconf)
@@ -2204,7 +2208,7 @@ from sites like Twitch.tv and pipes them into a video player of choice.")
(define-public mlt
(package
(name "mlt")
- (version "6.16.0")
+ (version "6.18.0")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -2213,11 +2217,11 @@ from sites like Twitch.tv and pipes them into a video player of choice.")
(file-name (git-file-name name version))
(sha256
(base32
- "1362fv63p34kza9v4b71b6wakgvsa2vdx9y0g28x3yh4cp4k97kx"))))
+ "0iiqym15n8kbnjzj0asmm86gs23yykz0va5b475cc4v2vv5admgx"))))
(build-system gnu-build-system)
(arguments
`(#:tests? #f ; no tests
- #:make-flags '("CC=gcc" "CXX=g++ -std=gnu++11")
+ #:make-flags '("CC=gcc" "CXX=g++")
#:configure-flags
(list "--enable-gpl3"
"--enable-gpl")
@@ -2276,8 +2280,7 @@ tools, XML authoring components, and an extensible plug-in based API.")
'(#:configure-flags
(list (string-append "--with-udevdir="
(assoc-ref %outputs "out")
- "/lib/udev")
- "CXXFLAGS=-std=gnu++11")))
+ "/lib/udev"))))
(native-inputs
`(("perl" ,perl)
("pkg-config" ,pkg-config)))
@@ -2298,7 +2301,7 @@ be used for realtime video capture via Linux-specific APIs.")
(define-public obs
(package
(name "obs")
- (version "24.0.1")
+ (version "24.0.3")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -2307,7 +2310,7 @@ be used for realtime video capture via Linux-specific APIs.")
(file-name (git-file-name name version))
(sha256
(base32
- "056s0hs1ds3c57sc0gy39dxaxvwlakl3w25jxgawh0fs99211ar5"))))
+ "0g8nzs696f3myz4hvygav85b0jgjmn6dicy50axmapdv8miff9xa"))))
(build-system cmake-build-system)
(arguments
`(#:tests? #f)) ; no tests
@@ -3544,20 +3547,15 @@ transitions, and effects and then export your film to many common formats.")
(define-public dav1d
(package
(name "dav1d")
- (version "0.4.0")
+ (version "0.5.1")
(source
(origin
(method url-fetch)
- (uri (list ;; The canonical download site.
- (string-append "https://downloads.videolan.org/pub/videolan/"
- "dav1d/" version "/dav1d-" version ".tar.xz")
-
- ;; Auto-generated tarballs from the Git repo?
- (string-append "https://code.videolan.org/videolan/dav1d/-/"
- "archive/" version "/dav1d-" version ".tar.bz2")))
+ (uri (string-append "https://downloads.videolan.org/pub/videolan"
+ "/dav1d/" version "/dav1d-" version ".tar.xz"))
(sha256
(base32
- "08yqml01lbcpflrshdpvn88jv3xd8gm559qikiwyrh41a3kb4lr5"))))
+ "03cf6f9if45prq97qp7llzi1p71dyw9ymc87hc225iy89kmzjsdd"))))
(build-system meson-build-system)
(native-inputs `(("nasm" ,nasm)))
(home-page "https://code.videolan.org/videolan/dav1d")