summaryrefslogtreecommitdiff
path: root/gnu/packages/vim.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/vim.scm')
-rw-r--r--gnu/packages/vim.scm20
1 files changed, 13 insertions, 7 deletions
diff --git a/gnu/packages/vim.scm b/gnu/packages/vim.scm
index 372d470e09..9a3547bbc9 100644
--- a/gnu/packages/vim.scm
+++ b/gnu/packages/vim.scm
@@ -4,11 +4,12 @@
;;; Copyright © 2016, 2017 Nikita <nikita@n0.is>
;;; Copyright © 2017 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2017 Marius Bakke <mbakke@fastmail.com>
-;;; Copyright © 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2018–2021 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2019 HiPhish <hiphish@posteo.de>
;;; Copyright © 2019 Julien Lepiller <julien@lepiller.eu>
;;; Copyright © 2019, 2020 Jakub Kądziołka <kuba@kadziolka.net>
;;; Copyright © 2020 Jack Hill <jackhill@jackhill.us>
+;;; Copyright © 2021 Simon Tournier <zimon.toutoune@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -70,7 +71,7 @@
(define-public vim
(package
(name "vim")
- (version "8.2.2067")
+ (version "8.2.2632")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -79,7 +80,7 @@
(file-name (git-file-name name version))
(sha256
(base32
- "02cd953h69k9klrcwi756namwg39ka7if9ccc399ihb1l5f3kr66"))))
+ "0f80im1swja58n99696zslyzapsx8pyf545pmpzvy173ymnvm6nq"))))
(build-system gnu-build-system)
(arguments
`(#:test-target "test"
@@ -131,6 +132,8 @@
((".*Test_open_term_from_cmd.*" line)
(string-append line "return\n"))
((".*Test_terminal_postponed_scrollback.*" line)
+ (string-append line "return\n"))
+ ((".*Test_combining_double_width.*" line)
(string-append line "return\n")))
(substitute* "src/testdir/test_popupwin.vim"
((".*Test_popup_drag_termwin.*" line)
@@ -216,11 +219,14 @@ with the editor vim.")))
"--enable-xim"
"--disable-selinux"
"--enable-gui")
- ;; This flag fixes the following error:
- ;; .../libpython3.7m.a(pyexpat.o): undefined reference to symbol 'XML_FreeContentModel'
- ;; .../libexpat.so.1: error adding symbols: DSO missing from command line
- #:make-flags '("LDFLAGS=-lexpat")
,@(substitute-keyword-arguments (package-arguments vim)
+ ;; This flag fixes the following error:
+ ;; .../libpython3.7m.a(pyexpat.o): undefined reference to symbol 'XML_FreeContentModel'
+ ;; .../libexpat.so.1: error adding symbols: DSO missing from command line
+ ((#:make-flags flags)
+ `(append
+ (list "LDFLAGS=-lexpat")
+ (delete "CFLAGS=-D_REENTRANT" ,flags)))
((#:phases phases)
`(modify-phases ,phases
(add-before 'check 'start-xserver