summaryrefslogtreecommitdiff
path: root/gnu/packages/vpn.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/vpn.scm')
-rw-r--r--gnu/packages/vpn.scm12
1 files changed, 7 insertions, 5 deletions
diff --git a/gnu/packages/vpn.scm b/gnu/packages/vpn.scm
index 2378e4ff2e..c704106221 100644
--- a/gnu/packages/vpn.scm
+++ b/gnu/packages/vpn.scm
@@ -53,6 +53,7 @@
#:use-module (gnu packages guile)
#:use-module (gnu packages libevent)
#:use-module (gnu packages linux)
+ #:use-module (gnu packages ncurses)
#:use-module (gnu packages nss)
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
@@ -321,7 +322,7 @@ traversing network address translators (@dfn{NAT}s) and firewalls.")
(define-public protonvpn-cli
(package
(name "protonvpn-cli")
- (version "2.2.2")
+ (version "2.2.4")
(source
(origin
;; PyPI has a ".whl" file but not a proper source release.
@@ -333,7 +334,7 @@ traversing network address translators (@dfn{NAT}s) and firewalls.")
(file-name (git-file-name name version))
(sha256
(base32
- "0ixjb02kj4z79whm1izd8mrn2h0rp9cmw4im1qvp93rahqxdd4n8"))))
+ "08yca0a0prrnrc7ir7ajd56yxvxpcs4m1k8f5kf273f5whgr7wzw"))))
(build-system python-build-system)
(arguments '(#:tests? #f)) ; no tests in repo
(native-inputs
@@ -342,7 +343,8 @@ traversing network address translators (@dfn{NAT}s) and firewalls.")
`(("pythondialog" ,python-pythondialog)
("requests" ,python-requests)))
(propagated-inputs
- `(("openvpn" ,openvpn)))
+ `(("openvpn" ,openvpn)
+ ("dialog" ,dialog)))
(synopsis "Command-line client for ProtonVPN")
(description
"This is the official command-line interface for ProtonVPN, a secure
@@ -556,7 +558,7 @@ WireGuard was added to Linux 5.6.")
(define-public wireguard-tools
(package
(name "wireguard-tools")
- (version "1.0.20200820")
+ (version "1.0.20200827")
(source
(origin
(method git-fetch)
@@ -565,7 +567,7 @@ WireGuard was added to Linux 5.6.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1n8gxms0hmialm5zgh51bhbrl4fndxfc9vfwj20grp9fr7r6vzc4"))))
+ (base32 "1h351hn531z6z85sx9ya27xjz1jszgn1pkwibacjj49mds15f7gn"))))
(build-system gnu-build-system)
(arguments
`(#:make-flags