summaryrefslogtreecommitdiff
path: root/gnu/packages/vulkan.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/vulkan.scm')
-rw-r--r--gnu/packages/vulkan.scm32
1 files changed, 20 insertions, 12 deletions
diff --git a/gnu/packages/vulkan.scm b/gnu/packages/vulkan.scm
index 23d0c72ee3..25542c1e06 100644
--- a/gnu/packages/vulkan.scm
+++ b/gnu/packages/vulkan.scm
@@ -155,7 +155,7 @@ SPIR-V, aiming to emit GLSL or MSL that looks like human-written code.")
(define-public spirv-llvm-translator
(package
(name "spirv-llvm-translator")
- (version "15.0.0")
+ (version "18.1.0")
(source
(origin
(method git-fetch)
@@ -164,19 +164,27 @@ SPIR-V, aiming to emit GLSL or MSL that looks like human-written code.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "0lix3bpli7i9csz26bq0d9g1v7c0gim498m5bm2gp8kifj2yih1s"))))
+ (base32 "0yfz02mlnf4ffn67g2ms0w8f7jgdsn438w2dbxd5mvcf5dk2x27b"))))
(build-system cmake-build-system)
(arguments
- `(#:configure-flags
- (list (string-append "-DLLVM_EXTERNAL_SPIRV_HEADERS_SOURCE_DIR="
- (assoc-ref %build-inputs "spirv-headers")
- "/include/spirv")
- (string-append "-DLLVM_EXTERNAL_LIT="
- (assoc-ref %build-inputs "python-lit")
- "/bin/lit")
- "-DLLVM_SPIRV_INCLUDE_TESTS=ON")))
- (inputs (list llvm-15))
- (native-inputs (list clang-15 llvm-15 python-lit spirv-headers))
+ ;; The test suite is known to fail on several architectures:
+ ;; https://github.com/llvm/llvm-project/issues/59637
+ (list
+ #:tests? (and (not (%current-target-system))
+ (target-x86-64?))
+ #:configure-flags
+ #~(list (string-append "-DLLVM_EXTERNAL_SPIRV_HEADERS_SOURCE_DIR="
+ #$(this-package-native-input "spirv-headers")
+ "/include/spirv")
+ (string-append "-DLLVM_EXTERNAL_LIT="
+ #$(this-package-native-input "python-lit")
+ "/bin/lit")
+ (string-append "-DCMAKE_EXE_LINKER_FLAGS=-Wl,-rpath="
+ #$output "/lib")
+ "-DBUILD_SHARED_LIBS=ON"
+ "-DLLVM_SPIRV_INCLUDE_TESTS=ON")))
+ (inputs (list llvm-18))
+ (native-inputs (list clang-18 llvm-18 python-lit spirv-headers))
(home-page "https://github.com/KhronosGroup/SPIRV-LLVM-Translator")
(synopsis "Bi-directional translation between SPIR-V and LLVM IR")
(description