summaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm73
1 files changed, 68 insertions, 5 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 0c67e7d6e4..d729e9bdbf 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -144,7 +144,9 @@
#:use-module (gnu packages gnupg)
#:use-module (gnu packages golang)
#:use-module (gnu packages golang-build)
+ #:use-module (gnu packages golang-check)
#:use-module (gnu packages golang-web)
+ #:use-module (gnu packages golang-xyz)
#:use-module (gnu packages gperf)
#:use-module (gnu packages graphviz)
#:use-module (gnu packages gtk)
@@ -5199,6 +5201,69 @@ little effort, and the program to do so is often shorter and simpler than
you'd expect.")
(license (list license:expat license:cc-by3.0))))
+(define-public go-github-com-mikefarah-yq-v4
+ (package
+ (name "go-github-com-mikefarah-yq-v4")
+ (version "4.34.2")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mikefarah/yq")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0y5i0p4fiq0kad9xqihhyclhd9d3l2r5yligdkvsdc90hlqjmql3"))))
+ (build-system go-build-system)
+ (arguments
+ (list #:import-path "github.com/mikefarah/yq/v4"
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'install 'remove-binary
+ (lambda _
+ (delete-file-recursively
+ (string-append #$output "/bin")))))))
+ (propagated-inputs
+ (list go-github-com-a8m-envsubst
+ go-github-com-alecthomas-participle-v2
+ go-github-com-dimchansky-utfbom
+ go-github-com-elliotchance-orderedmap
+ go-github-com-fatih-color
+ go-github-com-goccy-go-json
+ go-github-com-goccy-yaml
+ go-github-com-jinzhu-copier
+ go-github-com-magiconair-properties
+ go-github-com-pelletier-go-toml-v2
+ go-github-com-spf13-cobra
+ go-golang-org-x-net
+ go-golang-org-x-text
+ go-gopkg-in-op-go-logging-v1
+ go-gopkg-in-yaml-v3))
+ (home-page "https://mikefarah.gitbook.io/yq/")
+ (synopsis
+ "Command-line YAML, JSON, XML, CSV, TOML and properties processor")
+ (description
+ "This package provides @code{yq}, a command-line YAML, JSON and XML
+processor. It uses @code{jq}-like syntax but works with YAML files as well as
+JSON, XML, properties, CSV and TSV.")
+ (license license:expat)))
+
+(define-public yq
+ (package
+ (inherit go-github-com-mikefarah-yq-v4)
+ (name "yq")
+ (arguments
+ (list #:install-source? #f
+ #:import-path "github.com/mikefarah/yq/v4"
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'install 'rename-binary
+ (lambda _
+ (rename-file (string-append #$output "/bin/v4")
+ (string-append #$output "/bin/yq")))))))
+ (propagated-inputs '())
+ (inputs (package-propagated-inputs go-github-com-mikefarah-yq-v4))))
+
(define-public go-github-com-itchyny-timefmt-go
(package
(name "go-github-com-itchyny-timefmt-go")
@@ -8166,7 +8231,7 @@ compressed JSON header blocks.
(define-public nghttp3
(package
(name "nghttp3")
- (version "1.1.0")
+ (version "1.2.0")
(source
(origin
(method url-fetch)
@@ -8175,12 +8240,10 @@ compressed JSON header blocks.
"nghttp3-" version ".tar.gz"))
(sha256
(base32
- "1fzvadnwb03jlm180313gg5m4fg09qdcc67fwcfrv9zs22anaa55"))))
+ "0xfa3nbpv3d514ssjpxvizqmss8z330w9p0bp045w4qsyr1vkj8c"))))
(build-system gnu-build-system)
(native-inputs
- (list pkg-config
- ;; Required by tests.
- cunit))
+ (list pkg-config))
(arguments
(list
#:configure-flags