summaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm43
1 files changed, 28 insertions, 15 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 781f76a132..2b1585c8e3 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -42,6 +42,7 @@
;;; Copyright © 2020 Alexandros Theodotou <alex@zrythm.org>
;;; Copyright © 2020 Pierre Neidhardt <mail@ambrevar.xyz>
;;; Copyright © 2020 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
+;;; Copyright © 2018, 2019, 2020 Björn Höfling <bjoern.hoefling@bjoernhoefling.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -4385,8 +4386,8 @@ CDF, Atom 0.3, and Atom 1.0 feeds.")
(package-with-python2 python-feedparser))
(define-public guix-data-service
- (let ((commit "18eb9dfdcb3174bfd4bab5b9089acffa13aa1214")
- (revision "18"))
+ (let ((commit "d1c243f7fd8902f359ff06fb78dce663cf4297ce")
+ (revision "19"))
(package
(name "guix-data-service")
(version (string-append "0.0.1-" revision "." (string-take commit 7)))
@@ -4398,11 +4399,13 @@ CDF, Atom 0.3, and Atom 1.0 feeds.")
(file-name (git-file-name name version))
(sha256
(base32
- "0lb78cqzqaz0r4sspg272w2a3yhzhqah30j0kxf0z182b0qpmp37"))))
+ "1ji8d4vwmv7j9h7z96hvzi3zvik594yngjrdal37w13fbxy2v6sw"))))
(build-system gnu-build-system)
(arguments
'(#:modules ((guix build utils)
(guix build gnu-build-system)
+ (ice-9 ftw)
+ (ice-9 match)
(ice-9 rdelim)
(ice-9 popen))
#:test-target "check-with-tmp-database"
@@ -4430,20 +4433,28 @@ CDF, Atom 0.3, and Atom 1.0 feeds.")
"/site-ccache")))
(for-each
(lambda (file)
+ (simple-format (current-error-port)
+ "wrapping: ~A\n"
+ (string-append bin "/" file))
(wrap-program (string-append bin "/" file)
`("PATH" ":" prefix
- (,bin))
+ ,(cons*
+ bin
+ (map (lambda (input)
+ (string-append
+ (assoc-ref inputs input)
+ "/bin"))
+ '("ephemeralpg"
+ "util-linux"
+ "postgresql"))))
`("GUILE_LOAD_PATH" ":" prefix
(,scm ,(getenv "GUILE_LOAD_PATH")))
`("GUILE_LOAD_COMPILED_PATH" ":" prefix
(,go ,(getenv "GUILE_LOAD_COMPILED_PATH")))))
- '("guix-data-service"
- "guix-data-service-process-branch-updated-email"
- "guix-data-service-process-branch-updated-mbox"
- "guix-data-service-process-job"
- "guix-data-service-process-jobs"
- "guix-data-service-manage-build-servers"
- "guix-data-service-query-build-servers"))
+ (scandir bin
+ (match-lambda
+ ((or "." "..") #f)
+ (_ #t))))
#t)))
(delete 'strip)))) ; As the .go files aren't compatible
(inputs
@@ -4452,13 +4463,14 @@ CDF, Atom 0.3, and Atom 1.0 feeds.")
("guile-json" ,guile3.0-json)
("guile-email" ,guile3.0-email)
("guile-squee" ,guile3.0-squee)
- ("postgresql" ,postgresql)
+ ("ephemeralpg" ,ephemeralpg)
+ ("util-linux" ,util-linux)
+ ("postgresql" ,postgresql-11)
("sqitch" ,sqitch)))
(native-inputs
`(("guile" ,guile-3.0)
("autoconf" ,autoconf)
("automake" ,automake)
- ("ephemeralpg" ,ephemeralpg)
("emacs-minimal" ,emacs-minimal)
("emacs-htmlize" ,emacs-htmlize)
("pkg-config" ,pkg-config)))
@@ -6125,14 +6137,14 @@ encoder/decoder based on the draft-12 specification for UBJSON.")
(define-public java-tomcat
(package
(name "java-tomcat")
- (version "8.5.46")
+ (version "8.5.53")
(source (origin
(method url-fetch)
(uri (string-append "mirror://apache/tomcat/tomcat-8/v"
version "/src/apache-tomcat-" version "-src.tar.gz"))
(sha256
(base32
- "0fb49gsqa3r6jrwc54yynvsakq9qbzr2pbxr7a29c2zvja2v65iq"))
+ "15lwq3clf21hzk7mma70sffpxjqn8ww5mjq6zhmwcp4m17m22z26"))
(modules '((guix build utils)))
;; Delete bundled jars.
(snippet
@@ -6210,6 +6222,7 @@ encoder/decoder based on the draft-12 specification for UBJSON.")
(let ((out (assoc-ref outputs "out")))
(copy-recursively "output/build" out))
#t)))))
+ (properties '((cpe-name . "tomcat")))
(home-page "https://tomcat.apache.org")
(synopsis "Java Servlet, JavaServer Pages, Java Expression Language and Java
WebSocket")