summaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm23
1 files changed, 12 insertions, 11 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 6c24b6253a..28bd2c7c68 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -272,7 +272,13 @@ parse JSON formatted strings back into the C representation of JSON objects.")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "0rl6s0vg5y1dhh9vfl1lqay3sxf69sxjh0czxrjmasn7ng91wwf3"))))
+ "0rl6s0vg5y1dhh9vfl1lqay3sxf69sxjh0czxrjmasn7ng91wwf3"))
+ (modules '((guix build utils)))
+ (snippet
+ ;; Building with GCC 4.8 with -Werror was fine, but 4.9.3
+ ;; complains in new ways, so turn of -Werror.
+ '(substitute* (find-files "." "^CMakeLists\\.txt$")
+ (("-Werror") "")))))
(build-system cmake-build-system)
(home-page "https://github.com/miloyip/rapidjson")
(synopsis "JSON parser/generator for C++ with both SAX/DOM style API")
@@ -320,20 +326,14 @@ for efficient socket-like bidirectional reliable communication channels.")
(define-public libpsl
(package
(name "libpsl")
- (version "0.6.0")
+ (version "0.7.1")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/rockdaboot/libpsl/"
- "archive/" version ".tar.gz"))
+ "archive/libpsl-" version ".tar.gz"))
(sha256
(base32
- "10s7xxxx6pp4ydp3san69sa6q379ih3pv92fyi565ggmlw8igv7a"))
- (file-name (string-append name "-" version ".tar.gz"))
- (modules '((guix build utils)))
- (snippet
- ;; Believe it or not, the .pc is invalid. Fix it.
- '(substitute* "libpsl.pc.in"
- (("-llibpsl") "-lpsl")))))
+ "1k0klj668c9v0r4993vfs3kq773mzdz61vsigqw6v1mjcwnf1si3"))))
(build-system gnu-build-system)
(inputs `(("icu4c" ,icu4c)))
;; The release tarball lacks the generated files.
@@ -341,7 +341,8 @@ for efficient socket-like bidirectional reliable communication channels.")
("automake" ,automake)
("gettext" ,gnu-gettext)
("which" ,which)
- ("libtool" ,libtool)))
+ ("libtool" ,libtool)
+ ("pkg-config" ,pkg-config)))
(arguments
`(#:phases (alist-cons-after
'unpack 'bootstrap