summaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm108
1 files changed, 106 insertions, 2 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 61e1d1f1bc..c1e9e943c0 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -189,6 +189,7 @@
#:use-module (gnu packages video)
#:use-module (gnu packages vim)
#:use-module (gnu packages wget)
+ #:use-module (gnu packages xdisorg)
#:use-module (gnu packages xml)
#:use-module ((srfi srfi-1) #:select (delete-duplicates)))
@@ -4896,6 +4897,69 @@ little effort, and the program to do so is often shorter and simpler than
you'd expect.")
(license (list license:expat license:cc-by3.0))))
+(define-public go-github-com-itchyny-timefmt-go
+ (package
+ (name "go-github-com-itchyny-timefmt-go")
+ (version "0.1.4")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/itchyny/timefmt-go")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0z5z8hy5lbjqdxp544mf238i77n7pf7bv3psgr5gffh0630dsyag"))))
+ (build-system go-build-system)
+ (arguments
+ (list #:import-path "github.com/itchyny/timefmt-go"))
+ (home-page "https://github.com/itchyny/timefmt-go")
+ (synopsis "Efficient time formatting library (strftime, strptime) for Golang")
+ (description
+ "@code{timefmt-go} is a Go language package for formatting and parsing date
+time strings.")
+ (license license:expat)))
+
+(define-public go-github-com-itchyny-gojq
+ (package
+ (name "go-github-com-itchyny-gojq")
+ (version "0.12.9")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/itchyny/gojq")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1m4zchhhi2428r1v0qz08drac4s63mag1pwcqzsf6n495yc3g0h0"))))
+ (build-system go-build-system)
+ (inputs
+ (list go-github-com-google-go-cmp-cmp
+ go-github-com-itchyny-timefmt-go
+ go-github-com-mattn-go-isatty
+ go-github-com-mattn-go-runewidth
+ go-gopkg-in-yaml-v3))
+ (arguments
+ (list
+ #:import-path "github.com/itchyny/gojq/cmd/gojq"
+ #:unpack-path "github.com/itchyny/gojq"))
+ (home-page "https://github.com/itchyny/gojq")
+ (synopsis "Pure Go implementation of jq")
+ (description
+ "@command{gojq} is an Go implementation and library of the jq JSON
+processor.")
+ (license license:expat)))
+
+(define-public gojq
+ (package
+ (inherit go-github-com-itchyny-gojq)
+ (name "gojq")
+ (arguments
+ (ensure-keyword-arguments
+ (package-arguments go-github-com-itchyny-gojq)
+ (list #:install-source? #f)))))
+
(define-public pup
(let ((revision "1")
(commit "681d7bb639334bf485476f5872c5bdab10931f9a"))
@@ -7701,6 +7765,46 @@ bookmarks directly. It can also present them in a web interface with
@command{bukuserver}.")
(license license:gpl3+)))
+(define-public buku-run
+ (package
+ (name "buku-run")
+ (version "0.1.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/carnager/buku_run")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1zyjjf3b8g3dnymcrg683rbnc6qrvx8ravfm833n7kjrqky3bczn"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list #:tests? #f ;no tests
+ #:make-flags
+ #~(list (string-append "DESTDIR=" #$output)
+ "PREFIX=")
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'configure)
+ (add-after 'unpack 'fixpath
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "buku_run"
+ ((" \\<(rofi)\\>" all cmd)
+ (string-append " " (search-input-file inputs "/bin/rofi")))
+ (("\\<(buku)\\> " all cmd)
+ (string-append (search-input-file inputs "/bin/buku") " "))
+ (("\\<(awk|gawk)\\>" cmd)
+ (search-input-file inputs "/bin/awk"))
+ (("/etc/buku_run.config" path)
+ (string-append #$output path))))))))
+ (inputs (list buku rofi))
+ (home-page "https://github.com/carnager/buku_run")
+ (synopsis "rofi frontend for buku bookmarks manager")
+ (description
+ "This package provides a rofi frontend for the buku bookmark manager.")
+ (license license:gpl3+)))
+
(define-public anonip
(package
(name "anonip")
@@ -7849,7 +7953,7 @@ solution for any project's interface needs:
(define-public gmid
(package
(name "gmid")
- (version "1.8.5")
+ (version "1.8.6")
(source (origin
(method url-fetch)
(uri (string-append
@@ -7857,7 +7961,7 @@ solution for any project's interface needs:
version "/gmid-" version ".tar.gz"))
(sha256
(base32
- "0p3wr3ic4c50wxi7sr1hi8m8izmmjnazcmyqvxaf56yx58b3gpxv"))))
+ "1j0bgnixffz2lv5xgp5c88hl146c1vyk1988gyd70mhgyl9700jy"))))
(build-system gnu-build-system)
(arguments
(list #:test-target "regress"