summaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm70
1 files changed, 41 insertions, 29 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 4fc7181f34..2144c4fe8f 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -44,6 +44,7 @@
;;; Copyright © 2020 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
;;; Copyright © 2018, 2019, 2020 Björn Höfling <bjoern.hoefling@bjoernhoefling.de>
;;; Copyright © 2020 Paul Garlick <pgarlick@tourbillion-technology.com>
+;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -136,6 +137,7 @@
#:use-module (gnu packages perl)
#:use-module (gnu packages perl-check)
#:use-module (gnu packages python)
+ #:use-module (gnu packages python-crypto)
#:use-module (gnu packages python-web)
#:use-module (gnu packages python-xyz)
#:use-module (gnu packages pcre)
@@ -156,14 +158,14 @@
(define-public httpd
(package
(name "httpd")
- (version "2.4.43")
+ (version "2.4.46")
(source (origin
(method url-fetch)
(uri (string-append "mirror://apache/httpd/httpd-"
version ".tar.bz2"))
(sha256
(base32
- "0hqgw47r3p3521ygkkqs8s30s5crm683081avj6330gwncm6b5x4"))))
+ "1sj1rwgbcjgkzac3ybjy7j68c9b3dv3ap71m48mrjhf6w7vds3kl"))))
(build-system gnu-build-system)
(native-inputs `(("pcre" ,pcre "bin"))) ;for 'pcre-config'
(inputs `(("apr" ,apr)
@@ -229,14 +231,14 @@ Interface} specification.")
;; ’stable’ and recommends that “in general you deploy the NGINX mainline
;; branch at all times” (https://www.nginx.com/blog/nginx-1-6-1-7-released/)
;; Consider updating the nginx-documentation package together with this one.
- (version "1.19.1")
+ (version "1.19.2")
(source (origin
(method url-fetch)
(uri (string-append "https://nginx.org/download/nginx-"
version ".tar.gz"))
(sha256
(base32
- "14jlcn8gywa4r9brmm41ddg2dczskslnn4dnr5xmqg7dcin7f150"))))
+ "0wr4ss4gld7x717m4j3a6l6f7ijblrrd55y563lkwhvr7sqpn7vw"))))
(build-system gnu-build-system)
(inputs `(("openssl" ,openssl)
("pcre" ,pcre)
@@ -360,9 +362,9 @@ documentation.")
(define-public nginx-documentation
;; This documentation should be relevant for the current nginx package.
- (let ((version "1.19.0")
- (revision 2549)
- (changeset "c13a55aae487"))
+ (let ((version "1.19.2")
+ (revision 2581)
+ (changeset "324ca14c3003"))
(package
(name "nginx-documentation")
(version (simple-format #f "~A-~A-~A" version revision changeset))
@@ -374,7 +376,7 @@ documentation.")
(file-name (string-append name "-" version))
(sha256
(base32
- "0vwwvk6wf8f6c6n6yffmya9a287s6dbx1p739hdl3hwxfyh2ygc5"))))
+ "15bdbi6cjqhx8lqsyr3hnwagq2r80bsyh2im80ajmbfv7y47djqi"))))
(build-system gnu-build-system)
(arguments
'(#:tests? #f ; no test suite
@@ -768,6 +770,7 @@ data.")
(define-public json-c
(package
+ (replacement json-c/fixed)
(name "json-c")
(version "0.14")
(source (origin
@@ -788,6 +791,15 @@ parse JSON-formatted strings back into the C representation of JSON objects.
It aims to conform to RFC 7159.")
(license license:x11)))
+(define json-c/fixed
+ (package
+ (inherit json-c)
+ (name "json-c")
+ (version "0.14")
+ (source (origin
+ (inherit (package-source json-c))
+ (patches (search-patches "json-c-CVE-2020-12762.patch"))))))
+
;; TODO: Remove these old versions when all dependents have been updated.
(define-public json-c-0.13
(package
@@ -800,6 +812,7 @@ It aims to conform to RFC 7159.")
version ".tar.gz"))
(sha256
(base32 "0ws8dz9nk8q2c0gbf66kg2r6mrkl7kamd3gpdv9zsyrz9n6n0zmq"))
+ (patches (search-patches "json-c-0.13-CVE-2020-12762.patch"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -822,6 +835,7 @@ It aims to conform to RFC 7159.")
version ".tar.gz"))
(sha256
(base32 "08qibrq29a5v7g23wi5icy6l4fbfw90h9ccps6vq0bcklx8n84ra"))
+ (patches (search-patches "json-c-0.12-CVE-2020-12762.patch"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -1951,14 +1965,14 @@ instance of a component on each request.")
(define-public perl-catalyst-devel
(package
(name "perl-catalyst-devel")
- (version "1.40")
+ (version "1.41")
(source
(origin
(method url-fetch)
- (uri (string-append "mirror://cpan/authors/id/J/JJ/JJNAPIORK/"
+ (uri (string-append "mirror://cpan/authors/id/H/HA/HAARG/"
"Catalyst-Devel-" version ".tar.gz"))
(sha256
- (base32 "1fqnw6cizpxnfr87rpid8w1wpi1p1lxg6imfjpixqn7s055hcpwc"))))
+ (base32 "1r8arq7sw37d0mjyfzkc3pg1a9plgydqbscryc8qpvba4swpljls"))))
(build-system perl-build-system)
(native-inputs
`(("perl-test-fatal" ,perl-test-fatal)))
@@ -2183,16 +2197,15 @@ Catalyst.")
(define-public perl-catalyst-plugin-configloader
(package
(name "perl-catalyst-plugin-configloader")
- (version "0.34")
+ (version "0.35")
(source
(origin
(method url-fetch)
- (uri (string-append "mirror://cpan/authors/id/B/BO/BOBTFISH/"
+ (uri (string-append "mirror://cpan/authors/id/H/HA/HAARG/"
"Catalyst-Plugin-ConfigLoader-"
version ".tar.gz"))
(sha256
- (base32
- "19j7p4v7mbx6wrmpvmrnd974apx7hdl2s095ga3b9zcbdrl77h5q"))))
+ (base32 "0w8r3bbxqnlykvra6sx3sh3wh8ylkj914xg5ql6nw11ddy56jaly"))))
(build-system perl-build-system)
(native-inputs
`(("perl-path-class" ,perl-path-class)
@@ -2509,15 +2522,14 @@ stash data in JSON format.")
(define-public perl-catalyst-view-tt
(package
(name "perl-catalyst-view-tt")
- (version "0.44")
+ (version "0.45")
(source
(origin
(method url-fetch)
- (uri (string-append "mirror://cpan/authors/id/E/ET/ETHER/"
+ (uri (string-append "mirror://cpan/authors/id/H/HA/HAARG/"
"Catalyst-View-TT-" version ".tar.gz"))
(sha256
- (base32
- "06d1zg4nbb6kcyjbnyxrkf8z4zlscxr8650d94f7187jygfl8rvh"))))
+ (base32 "0jzgpkgq5pwq82zlb0nykdyk40dfpsyn9ilz91d0wpixgi9i5pr8"))))
(build-system perl-build-system)
(propagated-inputs
`(("perl-catalyst-runtime" ,perl-catalyst-runtime)
@@ -4446,8 +4458,8 @@ CDF, Atom 0.3, and Atom 1.0 feeds.")
(package-with-python2 python-feedparser))
(define-public guix-data-service
- (let ((commit "d1c243f7fd8902f359ff06fb78dce663cf4297ce")
- (revision "19"))
+ (let ((commit "ab68b0fdb3efe68f1962b7b9698ffc225abfeabb")
+ (revision "20"))
(package
(name "guix-data-service")
(version (string-append "0.0.1-" revision "." (string-take commit 7)))
@@ -4459,7 +4471,7 @@ CDF, Atom 0.3, and Atom 1.0 feeds.")
(file-name (git-file-name name version))
(sha256
(base32
- "1ji8d4vwmv7j9h7z96hvzi3zvik594yngjrdal37w13fbxy2v6sw"))))
+ "0imbkrm46ykjip81cbf14gc6hqlgi79fnwvsjxbhkd2wq3c1nrjg"))))
(build-system gnu-build-system)
(arguments
'(#:modules ((guix build utils)
@@ -4473,7 +4485,7 @@ CDF, Atom 0.3, and Atom 1.0 feeds.")
(modify-phases %standard-phases
(add-before 'build 'set-GUILE_AUTO_COMPILE
(lambda _
- ;; To avoid errors relating to guild
+ ;; To avoid warnings relating to 'guild'.
(setenv "GUILE_AUTO_COMPILE" "0")
#t))
(add-after 'install 'wrap-executable
@@ -4528,7 +4540,7 @@ CDF, Atom 0.3, and Atom 1.0 feeds.")
("postgresql" ,postgresql-11)
("sqitch" ,sqitch)))
(native-inputs
- `(("guile" ,guile-3.0)
+ `(("guile" ,@(assoc-ref (package-native-inputs guix) "guile"))
("autoconf" ,autoconf)
("automake" ,automake)
("emacs-minimal" ,emacs-minimal)
@@ -4684,14 +4696,14 @@ you'd expect.")
(define-public uhttpmock
(package
(name "uhttpmock")
- (version "0.5.2")
+ (version "0.5.3")
(source
(origin
(method url-fetch)
- (uri (string-append "http://tecnocode.co.uk/downloads/uhttpmock/"
+ (uri (string-append "https://tecnocode.co.uk/downloads/uhttpmock/"
"uhttpmock-" version ".tar.xz"))
(sha256
- (base32 "0glyx07kxc3s3cx5vp30kfgscl9q6bghcq1zysfyxm24r0h6j58p"))))
+ (base32 "0bqizz69hxk8rn4z57asz1d45vizl1rj6i5k3rzxn2x3qcik514h"))))
(build-system glib-or-gtk-build-system)
(native-inputs
`(("gobject-introspection" ,gobject-introspection)
@@ -5774,7 +5786,7 @@ used to start services with both privileged and non-privileged port numbers.")
(define-public tidy-html
(package
(name "tidy-html")
- (version "5.6.0")
+ (version "5.7.28")
(source
(origin
(method git-fetch)
@@ -5784,7 +5796,7 @@ used to start services with both privileged and non-privileged port numbers.")
(file-name (git-file-name name version))
(sha256
(base32
- "0w175c5d1babq0w1zzdzw9gl6iqbgyq58v8587s7srp05y3hwy9k"))))
+ "01k5sqwgcsr26i8031v1yr2r8qcy9a5w7sj800660haszgfbjz2f"))))
(build-system cmake-build-system)
(outputs '("out"
"static")) ; 1.3MiB of .a files