summaryrefslogtreecommitdiff
path: root/gnu/packages/webkit.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/webkit.scm')
-rw-r--r--gnu/packages/webkit.scm41
1 files changed, 27 insertions, 14 deletions
diff --git a/gnu/packages/webkit.scm b/gnu/packages/webkit.scm
index 6a101331bd..f79d6bd4f6 100644
--- a/gnu/packages/webkit.scm
+++ b/gnu/packages/webkit.scm
@@ -30,6 +30,7 @@
#:use-module (guix utils)
#:use-module (guix build utils)
#:use-module (guix build-system cmake)
+ #:use-module (guix build-system meson)
#:use-module (guix build-system gnu)
#:use-module (gnu packages)
#:use-module (gnu packages base)
@@ -70,7 +71,7 @@
(define-public libwpe
(package
(name "libwpe")
- (version "1.6.0")
+ (version "1.12.0")
(source
(origin
(method url-fetch)
@@ -78,8 +79,8 @@
(string-append "https://wpewebkit.org/releases/libwpe-"
version ".tar.xz"))
(sha256
- (base32 "141w35b488jjhanl3nrm0awrbcy6hb579fk8n9vbpx07m2wcd1rm"))))
- (build-system cmake-build-system)
+ (base32 "13618imck69w7fbmljlh62j4gnlspb9zfqzv9hlkck3bi8icmvp8"))))
+ (build-system meson-build-system)
(arguments
`(#:tests? #f)) ;no tests
(native-inputs
@@ -98,21 +99,21 @@ the WPE-flavored port of WebKit.")
(define-public wpebackend-fdo
(package
(name "wpebackend-fdo")
- (version "1.6.1")
+ (version "1.12.0")
(source (origin
(method url-fetch)
(uri (string-append "https://wpewebkit.org/releases/"
"wpebackend-fdo-" version ".tar.xz"))
(sha256
(base32
- "1jdi43gciqjgvhnqxs160f3hmp1hkqhrllb0hhmldyxc4wryw3kl"))))
- (build-system cmake-build-system)
+ "1b3l02dns1yxw3rq18cv00qan4hp95mxw5b3ssc0fh93ap0wjfb2"))))
+ (build-system meson-build-system)
(arguments
`(#:tests? #f)) ;no tests
(native-inputs
(list pkg-config))
(inputs
- (list glib libwpe mesa wayland))
+ (list glib libepoxy libwpe mesa wayland))
(home-page "https://wpewebkit.org/")
(synopsis "Wayland WPE backend")
(description
@@ -123,7 +124,7 @@ engine that uses Wayland for graphics output.")
(define-public wpewebkit
(package
(name "wpewebkit")
- (version "2.30.5")
+ (version "2.34.3")
(source
(origin
(method url-fetch)
@@ -131,7 +132,7 @@ engine that uses Wayland for graphics output.")
(string-append "https://wpewebkit.org/releases/"
name "-" version ".tar.xz"))
(sha256
- (base32 "16imr0kmzhs7dz6jva9750xbsdz9v50playnagabajy30x7pymsb"))))
+ (base32 "1z20bza01ld4jvi0qx8xsl5y4czaniwpi8hxdjyirj1mrszy8pf3"))))
(build-system cmake-build-system)
(outputs '("out" "doc"))
(arguments
@@ -161,6 +162,15 @@ engine that uses Wayland for graphics output.")
"/xml/dtd/docbook/docbookx.dtd"))))
(find-files "Source" "\\.sgml$"))
#t))
+ (add-after 'unpack 'patch-cmake
+ (lambda _
+ (substitute* "Source/PlatformWPE.cmake"
+ (("(Documentation/wpe(-webextensions)?-)\\$\\{WPE_API_VERSION\\}"
+ all prefix)
+ (string-append prefix "${WPE_API_DOC_VERSION}"))
+ (("(html/wpe(-webextensions)?-)\\$\\{WPE_API_VERSION\\}"
+ all prefix)
+ (string-append prefix "${WPE_API_DOC_VERSION}")))))
(add-after 'install 'move-doc-files
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
@@ -193,6 +203,7 @@ engine that uses Wayland for graphics output.")
("gst-plugins-base" ,gst-plugins-base)
("harfbuzz" ,harfbuzz)
("icu" ,icu4c)
+ ("lcms" ,lcms)
("libepoxy" ,libepoxy)
("libgcrypt" ,libgcrypt)
("libjpeg" ,libjpeg-turbo)
@@ -222,21 +233,23 @@ acceleration in mind, leveraging common 3D graphics APIs for best performance.")
;; Rendering and JavaScript Engines.
license:lgpl2.1+
;; Others
- license:bsd-2))))
+ license:bsd-2))
+ (properties '((cpe-name . "wpe_webkit")))))
(define-public webkitgtk
(package
(name "webkitgtk")
- (version "2.34.4")
+ (version "2.34.6")
(source (origin
(method url-fetch)
(uri (string-append "https://www.webkitgtk.org/releases/"
"webkitgtk-" version ".tar.xz"))
(sha256
(base32
- "01m4mfqxqkcx72kps46hpkir92x105ggfp43j68nk9wv34cm0pwp"))
- (patches (search-patches "webkitgtk-share-store.patch"
- "webkitgtk-bind-all-fonts.patch"))))
+ "1xn1hhd0qaxmjf6vy6664i4mmmjsw9zgrr4w8ni3415d981zvj3b"))
+ (patches (search-patches "webkitgtk-bind-all-fonts.patch"
+ "webkitgtk-adjust-bubblewrap-paths.patch"
+ "webkitgtk-canonicalize-paths.patch"))))
(build-system cmake-build-system)
(outputs '("out" "doc" "debug"))
(arguments