summaryrefslogtreecommitdiff
path: root/gnu/packages/wget.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/wget.scm')
-rw-r--r--gnu/packages/wget.scm20
1 files changed, 13 insertions, 7 deletions
diff --git a/gnu/packages/wget.scm b/gnu/packages/wget.scm
index 17459344c0..6c6f7d3382 100644
--- a/gnu/packages/wget.scm
+++ b/gnu/packages/wget.scm
@@ -1,7 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2012 Nikita Karetnikov <nikita@karetnikov.org>
;;; Copyright © 2014, 2015, 2017, 2018 Ludovic Courtès <ludo@gnu.org>
-;;; Copyright © 2016, 2017, 2019-2022 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016, 2017, 2019-2023 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2017 Rutger Helling <rhelling@mykolab.com>
;;; Copyright © 2018–2021 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2020 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
@@ -135,13 +135,13 @@ online pastebin services.")
(define-public wget2
(package
(name "wget2")
- (version "2.0.1")
+ (version "2.1.0")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/wget/wget2-" version ".tar.gz"))
(sha256
(base32
- "1caxhkwk08z3npzw8x2qhkmjc224cfw1aphvbv8bidbvd41zmdqb"))))
+ "1rz294dld9zmd5fmsrjgfyj7nlpmg1x7gckdzl9r7bbb3hcwapd0"))))
(build-system gnu-build-system)
(arguments
`(#:phases (modify-phases %standard-phases
@@ -152,16 +152,22 @@ online pastebin services.")
(("test-gpg-valid\\$\\(EXEEXT)") "")
(("test-gpg-styles\\$\\(EXEEXT)") "")))))
#:configure-flags
- '("--enable-static=no")))
- (inputs (list bzip2
+ '("--enable-static=no"
+ "--with-bzip2=yes"
+ "--with-lzma=yes")))
+ (inputs (list brotli
+ bzip2
gnutls/dane
gpgme
libidn2
libmicrohttpd
libpsl
+ `(,nghttp2 "lib")
pcre2
- zlib))
- ;; TODO: Add libbrotlidec, libnghttp2.
+ xz
+ zlib
+ `(,zstd "lib")))
+ ;; TODO: Add libhsts.
(native-inputs (list pkg-config))
(home-page "https://gitlab.com/gnuwget/wget2")
(synopsis "Successor of GNU Wget")