summaryrefslogtreecommitdiff
path: root/gnu/packages/wm.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/wm.scm')
-rw-r--r--gnu/packages/wm.scm49
1 files changed, 40 insertions, 9 deletions
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 4d1b6b3fd4..a29a7d9764 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -9,7 +9,7 @@
;;; Copyright © 2016 Al McElrath <hello@yrns.org>
;;; Copyright © 2016 Carlo Zancanaro <carlo@zancanaro.id.au>
;;; Copyright © 2016, 2017, 2018, 2019 Ludovic Courtès <ludo@gnu.org>
-;;; Copyright © 2016, 2017, 2018 ng0 <ng0@n0.is>
+;;; Copyright © 2016, 2017, 2018 Nikita <nikita@n0.is>
;;; Copyright © 2016 doncatnip <gnopap@gmail.com>
;;; Copyright © 2016 Ivan Vilata i Balaguer <ivan@selidor.net>
;;; Copyright © 2017 Mekeor Melire <mekeor.melire@gmail.com>
@@ -34,6 +34,7 @@
;;; Copyright © 2020 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2020 Brice Waegeneire <brice@waegenei.re>
;;; Copyright © 2020 Boris A. Dekshteyn <harlequin78@gmail.com>
+;;; Copyright © 2020 Marcin Karpezo <sirmacik@wioo.waw.pl>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -150,7 +151,7 @@ the leaves of a full binary tree.")
(define-public herbstluftwm
(package
(name "herbstluftwm")
- (version "0.8.1")
+ (version "0.8.2")
(source
(origin
(method url-fetch)
@@ -158,7 +159,7 @@ the leaves of a full binary tree.")
version ".tar.gz"))
(sha256
(base32
- "0c1lf82z6a56g8asin91cmqhzk3anw0xwc44b31bpjixadmns57y"))
+ "0wbl1s1gwdc61ll6qmkwb56swjxv99by1dhi080bdqn0w8p75804"))
(file-name (string-append "herbstluftwm-" version ".tar.gz"))))
(build-system cmake-build-system)
(inputs
@@ -270,14 +271,14 @@ commands would.")
(define-public i3-wm
(package
(name "i3-wm")
- (version "4.18")
+ (version "4.18.1")
(source (origin
(method url-fetch)
(uri (string-append "https://i3wm.org/downloads/i3-"
version ".tar.bz2"))
(sha256
(base32
- "0dv5g8ycfmijxfjyw8hzsxaf80v09lb73zh7x2vszy78h3amifqz"))))
+ "0z709cianlzw0x0qwq4361347354xd9ckj1v7vjvhb1zh3x91gws"))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags
@@ -1312,7 +1313,7 @@ functionality to display information about the most commonly used services.")
(define-public wlroots
(package
(name "wlroots")
- (version "0.7.0")
+ (version "0.10.1")
(source
(origin
(method git-fetch)
@@ -1321,7 +1322,7 @@ functionality to display information about the most commonly used services.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "0jzxa6psbc7ddxli7rbfqxmv1svxnis51l1vch4hb9fdixqm284a"))))
+ (base32 "0j2lh9vc92zhn44rjbia5aw3y1rpgfng1x1h17lcvj5m4i6vj0pc"))))
(build-system meson-build-system)
(arguments
`(#:configure-flags '("-Dlogind-provider=elogind")
@@ -1357,7 +1358,7 @@ modules for building a Wayland compositor.")
(define-public sway
(package
(name "sway")
- (version "1.2")
+ (version "1.4")
(source
(origin
(method git-fetch)
@@ -1366,7 +1367,7 @@ modules for building a Wayland compositor.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "0vch2zm5afc76ia78p3vg71zr2fyda67l9hd2h0x1jq3mnvfbxnd"))))
+ (base32 "11qf89y3q92g696a6f4d23qb44gqixg6qxq740vwv2jw59ms34ja"))))
(build-system meson-build-system)
(arguments
`(#:phases
@@ -1730,6 +1731,36 @@ productive, customizable lisp based systems.")
rendering.")
(license (list license:gpl2+ license:gpl3+ license:bsd-2)))))
+(define-public sbcl-stumpwm-pass
+ (let ((commit "dd5b037923ec7d3cc27c55806bcec5a1b8cf4e91")
+ (revision "1"))
+ (package
+ (name "sbcl-pass")
+ (version (git-version "0.0.1" revision commit)) ;no upstream release
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/stumpwm/stumpwm-contrib.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0ahxdj9f884afpzxczx6mx7l4nwg4kw6afqaq7lwhf7lxcwylldn"))))
+ (inputs
+ `(("stumpwm" ,stumpwm "lib")))
+ (build-system asdf-build-system/sbcl)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'chdir
+ (lambda _
+ (chdir "util/pass"))))))
+ (home-page "https://github.com/stumpwm/stumpwm-contrib")
+ (synopsis "Integrate @code{pass} wih StumpWM")
+ (description "This package provides an interface which integrates
+password-store into StumpWM.")
+ (license (list license:gpl2+ license:gpl3+ license:bsd-2)))))
+
(define-public sbcl-stumpwm-globalwindows
(let ((commit "dd5b037923ec7d3cc27c55806bcec5a1b8cf4e91")
(revision "1"))