summaryrefslogtreecommitdiff
path: root/gnu/packages/wm.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/wm.scm')
-rw-r--r--gnu/packages/wm.scm96
1 files changed, 92 insertions, 4 deletions
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 3d85392394..90896c2b89 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -44,6 +44,7 @@
;;; Copyright © 2021 Zheng Junjie <873216071@qq.com>
;;; Copyright © 2021 Sharlatan Hellseher <sharlatanus@gmail.com>
;;; Copyright © 2021 qblade <qblade@protonmail.com>
+;;; Copyright © 2021 lasnesne <lasnesne@lagunposprasihopre.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1569,7 +1570,7 @@ modules for building a Wayland compositor.")
(define-public waybar
(package
(name "waybar")
- (version "0.9.4")
+ (version "0.9.5")
(source
(origin
(method git-fetch)
@@ -1578,10 +1579,10 @@ modules for building a Wayland compositor.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "038vnma7y7z81caywp45yr364bc1aq8d01j5vycyiyfv33nm76fy"))))
+ (base32 "1kzrgqaclfk6gcwhknxn28xl74gm5swipgn8kk8avacb4nsw1l9q"))))
(build-system meson-build-system)
(inputs `(("date" ,date)
- ("fmt" ,fmt-6)
+ ("fmt" ,fmt)
("gtk-layer-shell" ,gtk-layer-shell)
("gtkmm" ,gtkmm)
("jsoncpp" ,jsoncpp)
@@ -1590,7 +1591,7 @@ modules for building a Wayland compositor.")
("libmpdclent" ,libmpdclient)
("libnl" ,libnl)
("pulseaudio" ,pulseaudio)
- ("spdlog" ,spdlog-1.7)
+ ("spdlog" ,spdlog)
("wayland" ,wayland)))
(native-inputs
`(("gcc" ,gcc-8) ; for #include <filesystem>
@@ -2400,3 +2401,90 @@ for wayland conceptually based on the X11 window manager
(description "libucl implements a configuration language that is easy to
read and write, and compatible with JSON.")
(license license:bsd-2)))
+
+(define-public hikari
+ (package
+ (name "hikari")
+ (version "2.2.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hikari.acmelabs.space/releases/"
+ "hikari-" version ".tar.gz"))
+ (sha256
+ (base32 "1d023cphzi15k434n60l1rp5awxmdijvsxfrm59fmsvd5rjxh9q7"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("bmake" ,bmake)
+ ("pkg-config" ,pkg-config)
+ ("wayland-protocols" ,wayland-protocols)))
+ (inputs
+ `(("cairo" ,cairo)
+ ("libinput" ,libinput)
+ ("libucl" ,libucl)
+ ("libxkbcommon" ,libxkbcommon)
+ ("pam" ,linux-pam)
+ ("pango" ,pango)
+ ("wayland" ,wayland)
+ ("wlroots" ,wlroots)))
+ (arguments
+ `(#:tests? #f ; no tests
+ #:make-flags
+ (list
+ (string-append "PREFIX=" (assoc-ref %outputs "out"))
+ (string-append "CC=" ,(cc-for-target))
+ "WITH_XWAYLAND=YES"
+ "WITH_SCREENCOPY=YES"
+ "WITH_LAYERSHELL=YES"
+ "WITH_VIRTUAL_INPUT=YES")
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (replace 'build
+ (lambda* (#:key inputs outputs make-flags #:allow-other-keys)
+ (apply invoke "bmake" make-flags)))
+ (replace 'install
+ (lambda* (#:key inputs outputs make-flags #:allow-other-keys)
+ (apply invoke "bmake" "install" make-flags))))))
+ (home-page "https://hikari.acmelabs.space/")
+ (synopsis "Stacking Wayland compositor with tiling capabilities")
+ (description
+ "Hikari is a stacking Wayland compositor with additional tiling
+capabilities. It is heavily inspired by the Calm Window manager(cwm).")
+ (license license:bsd-2)))
+
+(define-public wlogout
+ (package
+ (name "wlogout")
+ (version "1.1.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ArtsyMacaw/wlogout")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1swhzkqkzli59c89pvrakfvicd00x7ga860c3x2pbb4y3xziqfvi"))))
+ (build-system meson-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("scdoc" ,scdoc)))
+ (inputs
+ `(("gtk-layer-shell" ,gtk-layer-shell)
+ ("gtk+" ,gtk+)))
+ (arguments
+ '(#:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-source-paths
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (substitute* "main.c"
+ (("/usr/share") (string-append out "/share"))
+ (("/etc") (string-append out "/etc"))))
+ #t)))))
+ (home-page "https://github.com/ArtsyMacaw/wlogout")
+ (synopsis "Logout menu for Wayland")
+ (description "wlogout is a logout menu for Wayland environments.")
+ (license license:expat)))