summaryrefslogtreecommitdiff
path: root/gnu/packages/wm.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/wm.scm')
-rw-r--r--gnu/packages/wm.scm55
1 files changed, 30 insertions, 25 deletions
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 7ea6840689..ebbd1a06bd 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -45,7 +45,7 @@
;;; Copyright © 2021 Sharlatan Hellseher <sharlatanus@gmail.com>
;;; Copyright © 2021 qblade <qblade@protonmail.com>
;;; Copyright © 2021 lasnesne <lasnesne@lagunposprasihopre.org>
-;;; Copyright © 2021 Petr Hodina <phodina@protonmail.com>
+;;; Copyright © 2021, 2022 Petr Hodina <phodina@protonmail.com>
;;; Copyright © 2021 jgart <jgart@dismail.de>
;;; Copyright © 2021 Disseminate Dissent <disseminatedissent@protonmail.com>
;;; Copyright © 2022 John Kehayias <john.kehayias@protonmail.com>
@@ -1395,7 +1395,7 @@ project derived from the original Calm Window Manager.")
(define-public dwl
(package
(name "dwl")
- (version "0.2.1")
+ (version "0.3.1")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -1404,7 +1404,7 @@ project derived from the original Calm Window Manager.")
(file-name (git-file-name name version))
(sha256
(base32
- "0js8xjc2rx1ml6s58s90jrak5n7vh3kj5na2j4yy3qy0cb501xcm"))))
+ "0952kajc60ijy6qz14y6s5n7dyyf14ndzrhs4ynxj97k76742z2l"))))
(build-system gnu-build-system)
(arguments
`(#:tests? #f ; no tests
@@ -1524,16 +1524,16 @@ functionality to display information about the most commonly used services.")
(define-public wlroots
(package
(name "wlroots")
- (version "0.14.1")
+ (version "0.15.1")
(source
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/swaywm/wlroots")
+ (url "https://gitlab.freedesktop.org/wlroots/wlroots")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "1sshp3lvlkl1i670kxhwsb4xzxl8raz6769kqvgmxzcb63ns9ay1"))))
+ (base32 "00s73nhi3sc48l426jdlqwpclg41kx1hv0yk4yxhbzw19gqpfm1h"))))
(build-system meson-build-system)
(arguments
`(#:phases
@@ -1570,7 +1570,7 @@ modules for building a Wayland compositor.")
(define-public sway
(package
(name "sway")
- (version "1.6.1")
+ (version "1.7")
(source
(origin
(method git-fetch)
@@ -1579,7 +1579,7 @@ modules for building a Wayland compositor.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "0j4sdbsrlvky1agacc0pcz9bwmaxjmrapjnzscbd2i0cria2fc5j"))))
+ (base32 "0ss3l258blyf2d0lwd7pi7ga1fxfj8pxhag058k7cmjhs3y30y5l"))))
(build-system meson-build-system)
(arguments
`(;; elogind is propagated by wlroots -> libseat
@@ -2515,7 +2515,7 @@ shows a notification for the user on the screen.")
(define-public cagebreak
(package
(name "cagebreak")
- (version "1.8.0")
+ (version "1.8.3")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -2524,13 +2524,18 @@ shows a notification for the user on the screen.")
(file-name (git-file-name name version))
(sha256
(base32
- "0296mnzk7qd0zvnhw716jvpp7madjsar373ixx4qcff0m0jwfrxm"))))
+ "0vm97ak0589v39m3fljf1qhy92dqgiqcrrfp757gg7q58qwa6dkf"))))
(build-system meson-build-system)
- (arguments '(#:configure-flags '("-Dxwayland=true")))
- (native-inputs
- (list pandoc pkg-config))
- (inputs
- (list libevdev pango wlroots))
+ (arguments
+ `(#:configure-flags '("-Dxwayland=true")
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-data-dir
+ (lambda* (#:key outputs #:allow-other-keys)
+ (substitute* "meson.build"
+ (("/etc/") (string-append (assoc-ref outputs "out") "/etc"))))))))
+ (native-inputs (list pandoc pkg-config))
+ (inputs (list libevdev pango wlroots))
(home-page "https://github.com/project-repo/cagebreak")
(synopsis "Tiling wayland compositor inspired by ratpoison")
(description
@@ -2567,26 +2572,26 @@ read and write, and compatible with JSON.")
(define-public hikari
(package
(name "hikari")
- (version "2.3.2")
+ (version "2.3.3")
(source
(origin
(method url-fetch)
(uri (string-append "https://hikari.acmelabs.space/releases/"
"hikari-" version ".tar.gz"))
(sha256
- (base32 "1jvy21irh6s7czff2hk63spswqibjcjhrpsgmrki5bii9ddi73wy"))))
+ (base32 "1qjd9dhpmv75idf6jjzwff8wgliad4d0af8pih9526p14vrnyws0"))))
(build-system gnu-build-system)
(native-inputs
(list bmake pkg-config wayland-protocols))
(inputs
- `(("cairo" ,cairo)
- ("libinput" ,libinput-minimal)
- ("libucl" ,libucl)
- ("libxkbcommon" ,libxkbcommon)
- ("pam" ,linux-pam)
- ("pango" ,pango)
- ("wayland" ,wayland)
- ("wlroots" ,wlroots)))
+ (list cairo
+ libinput-minimal
+ libucl
+ libxkbcommon
+ linux-pam
+ pango
+ wayland
+ wlroots))
(arguments
`(#:tests? #f ; no tests
#:make-flags