summaryrefslogtreecommitdiff
path: root/gnu/packages/xdisorg.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/xdisorg.scm')
-rw-r--r--gnu/packages/xdisorg.scm16
1 files changed, 9 insertions, 7 deletions
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index 5afc495ad7..783bce0d56 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -142,14 +142,14 @@ avoiding password prompts when X11 forwarding has already been setup.")
(define-public libxkbcommon
(package
(name "libxkbcommon")
- (version "0.6.1")
+ (version "0.7.1")
(source (origin
(method url-fetch)
- (uri (string-append "http://xkbcommon.org/download/" name "-"
+ (uri (string-append "https://xkbcommon.org/download/" name "-"
version ".tar.xz"))
(sha256
(base32
- "0q47xa1szlxwgvwmhv4b7xwawnykz1hnc431d84nj8dlh2q8f22v"))))
+ "12z6hih3n1r0asp2hzp9qsiwdfkfz46jwp06x8kprr0r5rfk0nds"))))
(build-system gnu-build-system)
(inputs
`(("libx11" ,libx11)
@@ -166,7 +166,7 @@ avoiding password prompts when X11 forwarding has already been setup.")
(string-append "--with-x-locale-root="
(assoc-ref %build-inputs "libx11")
"/share/X11/locale"))))
- (home-page "http://xkbcommon.org/")
+ (home-page "https://xkbcommon.org/")
(synopsis "Library to handle keyboard descriptions")
(description "Xkbcommon is a library to handle keyboard descriptions,
including loading them from disk, parsing them and handling their
@@ -277,7 +277,7 @@ rasterisation.")
(define-public libdrm
(package
(name "libdrm")
- (version "2.4.68")
+ (version "2.4.75")
(source
(origin
(method url-fetch)
@@ -287,7 +287,7 @@ rasterisation.")
".tar.bz2"))
(sha256
(base32
- "1px91j6imaaq2fy8ksvgldmv0cdz3w379jqiciqvqa99jajxjjsv"))
+ "0kq5hmck0gq7b29fr8jp94njc7jpkpbyws12s63w4b21xw750nid"))
(patches (search-patches "libdrm-symbol-check.patch"))))
(build-system gnu-build-system)
(inputs
@@ -830,7 +830,9 @@ Wacom tablet applet.")
name "-" version ".tar.bz2"))
(sha256
(base32
- "0idhkigl0pnyp08sqm6bqfb4h20v6rjrb71z1gdv59gk7d7qwpgi"))))
+ "0idhkigl0pnyp08sqm6bqfb4h20v6rjrb71z1gdv59gk7d7qwpgi"))
+ (patches
+ (search-patches "xf86-input-wacom-xorg-abi-25.patch"))))
(arguments
`(#:configure-flags
(list (string-append "--with-sdkdir="