summaryrefslogtreecommitdiff
path: root/gnu/packages/xiph.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/xiph.scm')
-rw-r--r--gnu/packages/xiph.scm16
1 files changed, 7 insertions, 9 deletions
diff --git a/gnu/packages/xiph.scm b/gnu/packages/xiph.scm
index 03cf0e49d2..8259be3f7d 100644
--- a/gnu/packages/xiph.scm
+++ b/gnu/packages/xiph.scm
@@ -49,14 +49,14 @@
(define libogg
(package
(name "libogg")
- (version "1.3.0")
+ (version "1.3.2")
(source (origin
(method url-fetch)
(uri (string-append "http://downloads.xiph.org/releases/ogg/libogg-"
version ".tar.xz"))
(sha256
(base32
- "0jy79ffkl34vycnwfsj4svqsdg1lwy2l1rr49y8r4d44kh12a5r3"))))
+ "16z74q422jmprhyvy7c9x909li8cqzmvzyr8cgbm52xcsp6pqs1z"))))
(build-system gnu-build-system)
(synopsis "libogg, a library for manipulating the ogg multimedia format")
(description
@@ -72,14 +72,14 @@ periodic timestamps for seeking.")
(define libvorbis
(package
(name "libvorbis")
- (version "1.3.3")
+ (version "1.3.4")
(source (origin
(method url-fetch)
(uri (string-append "http://downloads.xiph.org/releases/vorbis/libvorbis-"
version ".tar.xz"))
(sha256
(base32
- "1gby6hapz9njx4l9g0pndyk4q83z5fgrgc30mfwfgx7bllspsk43"))))
+ "0wpk87jnhngcl3nc5i39flkycx1sjzilx8jjx4zc4p8r55ylj19g"))))
(build-system gnu-build-system)
(propagated-inputs `(("libogg" ,libogg)))
(arguments `(#:configure-flags '("LDFLAGS=-lm")
@@ -192,16 +192,14 @@ OpenBSD's sndio.")
(define flac
(package
(name "flac")
- (version "1.2.1")
+ (version "1.3.0")
(source (origin
(method url-fetch)
(uri (string-append "http://downloads.xiph.org/releases/flac/flac-"
- version ".tar.gz"))
+ version ".tar.xz"))
(sha256
(base32
- "1pry5lgzfg57pga1zbazzdd55fkgk3v5qy4axvrbny5lrr5s8dcn"))
- (patches
- (list (search-patch "flac-fix-memcmp-not-declared.patch")))))
+ "1p0hh190kqvpkbk1bbajd81jfbmkyl4fn2i7pggk2zppq6m68bgs"))))
(build-system gnu-build-system)
(arguments
`(#:parallel-tests? #f