summaryrefslogtreecommitdiff
path: root/gnu/packages/xorg.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/xorg.scm')
-rw-r--r--gnu/packages/xorg.scm77
1 files changed, 31 insertions, 46 deletions
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index c3e38314ce..00782ce8b2 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -11,7 +11,7 @@
;;; Copyright © 2016 Alex Kost <alezost@gmail.com>
;;; Copyright © 2016 David Craven <david@craven.ch>
;;; Copyright © 2016, 2017 John Darrington <jmd@gnu.org>
-;;; Copyright © 2017, 2018, 2019, 2020, 2021 Marius Bakke <marius@gnu.org>
+;;; Copyright © 2017-2022 Marius Bakke <marius@gnu.org>
;;; Copyright © 2017, 2018, 2019 Rutger Helling <rhelling@mykolab.com>
;;; Copyright © 2017, 2020 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2018–2022 Tobias Geerinckx-Rice <me@tobias.gr>
@@ -241,14 +241,14 @@ which can be read by any architecture.")
(define-public xorgproto
(package
(name "xorgproto")
- (version "2021.5")
+ (version "2022.1")
(source (origin
(method url-fetch)
- (uri (string-append "ftp://ftp.freedesktop.org/pub/xorg//individual/proto/"
- "xorgproto-" version ".tar.bz2"))
+ (uri (string-append "mirror://xorg/individual/proto"
+ "/xorgproto-" version ".tar.bz2"))
(sha256
(base32
- "05d0kib351qmnlfimaznaw0220fr0ym7fx2gn9h2jqxxilxncbxa"))))
+ "19n2ig296x89yhyjc2mcrm4m2wp8sfh9i38z3qn4s8rzjrkcqb8x"))))
(build-system gnu-build-system)
(propagated-inputs
;; To get util-macros in (almost?) all package inputs.
@@ -1291,7 +1291,7 @@ with the Cygwin XWin server when running X11 in a rootless mode.")
(define-public libxft
(package
(name "libxft")
- (version "2.3.3")
+ (version "2.3.4")
(source
(origin
(method url-fetch)
@@ -1301,15 +1301,15 @@ with the Cygwin XWin server when running X11 in a rootless mode.")
".tar.bz2"))
(sha256
(base32
- "05lja9s54090xwh31r0bqms4v3pimng5xr09g2rdnafx2vk6hp12"))))
+ "1pdbr6gzfvixc791pjf42i9gg8wvfq6cpq6sdca04h4i42mxmpjp"))))
(build-system gnu-build-system)
(arguments
'(#:configure-flags '("--disable-static")))
(propagated-inputs
;; xft.pc refers to all these.
- `(("libxrender" ,libxrender)
- ("freetype" ,freetype)
- ("fontconfig" ,fontconfig)))
+ (list libxrender
+ freetype
+ fontconfig))
(inputs
(list libx11 xorgproto))
(native-inputs
@@ -2046,7 +2046,7 @@ emulate a TI-30 or an HP-10C.")
(define-public xcb-proto
(package
(name "xcb-proto")
- (version "1.14")
+ (version "1.15.2")
(source
(origin
(method url-fetch)
@@ -2055,17 +2055,10 @@ emulate a TI-30 or an HP-10C.")
version ".tar.xz"))
(sha256
(base32
- "01d62r286yfc3rpz714nqdgkl0wk9j0wqkd4ylas1d7r4vmkqshq"))
- (modules '((guix build utils)))
- (snippet
- '(begin
- ;; fractions.gcd has been deprecated since python-3.5.
- (substitute* "xcbgen/align.py"
- (("from fractions import gcd") "from math import gcd"))
- #t))))
+ "1vak6q53abwxnkfn6by7j24m48kd2iy7jnskkqzzx8l0ysqvwwkh"))))
(build-system gnu-build-system)
(native-inputs
- `(("pkg-config" ,pkg-config) ("python" ,python-minimal-wrapper)))
+ (list pkg-config python-minimal-wrapper))
(home-page "https://xcb.freedesktop.org/")
(synopsis "XML-XCB protocol descriptions")
(description
@@ -3898,10 +3891,7 @@ extension to the X11 protocol. It includes:
(inputs
(list libx11 xkbcomp-intermediate))
(native-inputs
- `(("gettext" ,gettext-minimal)
- ("perl" ,perl)
- ("pkg-config" ,pkg-config)
- ("python" ,python)))
+ (list gettext-minimal libxslt perl pkg-config python))
(home-page "https://www.x.org/wiki/")
(synopsis "Xorg XKB configuration files")
(description
@@ -5005,17 +4995,15 @@ new API's in libXft, or the legacy API's in libX11.")
(define-public libxvmc
(package
(name "libxvmc")
- (version "1.0.12")
+ (version "1.0.13")
(source
- (origin
- (method url-fetch)
- (uri (string-append
- "mirror://xorg/individual/lib/libXvMC-"
- version
- ".tar.bz2"))
- (sha256
- (base32
- "1kbdjsvkm5l7axv7g477qj18sab2wnqhliy6197syzizgfbsfgbb"))))
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://xorg/individual/lib/libXvMC-"
+ version ".tar.xz"))
+ (sha256
+ (base32
+ "0z35xqna3dnrfxgn9aa1y6jx7mrwsn8vi8dcwm3sg23qx9nvx7ha"))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags '(,@(malloc0-flags) "--disable-static")))
@@ -5065,7 +5053,7 @@ protocol.")
(define-public libxcb
(package
(name "libxcb")
- (version "1.14")
+ (version "1.15")
(source
(origin
(method url-fetch)
@@ -5073,7 +5061,7 @@ protocol.")
"libxcb-" version ".tar.xz"))
(sha256
(base32
- "0d2chjgyn5lr9sfhacfvqgnj9l9faz11vn322a06jd6lk3dxcpm5"))))
+ "0nd035rf83xf531cnjzsf9ykb5w9rdzz6bbyhi683xkwh57p8f6c"))))
(build-system gnu-build-system)
(outputs '("out" "doc")) ;5.5 MiB of man pages
(propagated-inputs
@@ -5081,8 +5069,7 @@ protocol.")
(inputs
(list xcb-proto libxslt))
(native-inputs
- `(("pkg-config" ,pkg-config)
- ("python" ,python-minimal-wrapper)))
+ (list pkg-config python-minimal-wrapper))
(arguments
`(#:configure-flags (list "--enable-xkb"
"--disable-static"
@@ -5427,7 +5414,7 @@ Wayland.")
(define-public libx11
(package
(name "libx11")
- (version "1.7.3.1")
+ (version "1.8.1")
(source
(origin
(method url-fetch)
@@ -5435,7 +5422,7 @@ Wayland.")
"/individual/lib/libX11-" version ".tar.xz"))
(sha256
(base32
- "1289nvs52q9fnp7zl30bdpbvqggnjjb39vy0zll511zvcrr43z9g"))))
+ "1xyry8i7zqmlkvpbyyqwi18rrdw6ycczlvfp63rh2570pfhimi0v"))))
(build-system gnu-build-system)
(outputs '("out"
"doc")) ;8 MiB of man pages + XML
@@ -5462,17 +5449,15 @@ Wayland.")
(define-public libxcursor
(package
(name "libxcursor")
- (version "1.2.0")
+ (version "1.2.1")
(source
(origin
(method url-fetch)
- (uri (string-append
- "mirror://xorg/individual/lib/libXcursor-"
- version
- ".tar.bz2"))
+ (uri (string-append "mirror://xorg/individual/lib/libXcursor-"
+ version ".tar.xz"))
(sha256
(base32
- "10l7c9fm0jmpkm9ab9dz8r6m1pr87vvgqjnbx1psz50h4pwfklrs"))))
+ "011195an3w4xld3x0dr534kar1xjf52q96hmf0hgvfhh2rrl7ha6"))))
(build-system gnu-build-system)
(arguments
'(#:configure-flags '("--disable-static")))