summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/firmware.scm12
1 files changed, 4 insertions, 8 deletions
diff --git a/gnu/packages/firmware.scm b/gnu/packages/firmware.scm
index 58253b93a7..06abfcec71 100644
--- a/gnu/packages/firmware.scm
+++ b/gnu/packages/firmware.scm
@@ -1344,9 +1344,7 @@ corresponding layout." layout))
`("PATH" prefix
,(map (compose dirname
(cut search-input-file inputs <>))
- '("bin/avr-ar"
- "bin/avr-gcc"
- "bin/avrdude"
+ '("bin/avrdude"
"bin/awk"
"bin/cmp"
"bin/dfu-programmer"
@@ -1359,16 +1357,13 @@ corresponding layout." layout))
;; TODO: Remove after git is wrapped with these.
"bin/basename"
"bin/sed"
- "bin/uname")))
- `("CROSS_C_INCLUDE_PATH" = (,(getenv "CROSS_C_INCLUDE_PATH")))
- `("CROSS_LIBRARY_PATH" = (,(getenv "CROSS_LIBRARY_PATH")))))))))
+ "bin/uname")))))))))
;; The inputs are not propagated since qmk is to be used strictly as a
;; command.
(inputs
;; The 'qmk setup' command advises to use GCC at version 8, and there are
;; compilation errors in some firmware otherwise.
- (list (make-avr-toolchain #:xgcc gcc-8)
- avrdude
+ (list avrdude
bash-minimal
dfu-programmer
dfu-util
@@ -1441,6 +1436,7 @@ provided."
(ice-9 ftw)
(ice-9 match)
(srfi srfi-26))
+ #:target "avr"
;; XXX: Running a test target like "test:$keyboard" doesn't seem to run
;; anything and causes the .hex file to be regenerated; leave the tests
;; out for now.