summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/base.scm11
-rw-r--r--gnu/packages/cross-base.scm12
2 files changed, 18 insertions, 5 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index 4fe6651a73..1270184f12 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -1025,11 +1025,18 @@ the store.")
,@(if (target-hurd?)
'((add-after 'install 'augment-libc.so
(lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out")))
+ (let ((out (assoc-ref outputs "out")))
(substitute* (string-append out "/lib/libc.so")
(("/[^ ]+/lib/libc.so.0.3")
(string-append out "/lib/libc.so.0.3"
- " libmachuser.so libhurduser.so")))))))
+ " libmachuser.so libhurduser.so"))))))
+ (add-after 'install 'create-machine-symlink
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out"))
+ (cpu "i386"))
+ (symlink cpu
+ (string-append out
+ "/include/mach/machine"))))))
'()))))
(inputs `(("static-bash" ,static-bash)))
diff --git a/gnu/packages/cross-base.scm b/gnu/packages/cross-base.scm
index 7fa9772cb9..b1c34db7d2 100644
--- a/gnu/packages/cross-base.scm
+++ b/gnu/packages/cross-base.scm
@@ -725,12 +725,18 @@ returned."
,@(if (target-hurd? target)
'((add-after 'install 'augment-libc.so
(lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out")))
+ (let ((out (assoc-ref outputs "out")))
(substitute* (string-append out "/lib/libc.so")
(("/[^ ]+/lib/libc.so.0.3")
(string-append out "/lib/libc.so.0.3"
- " libmachuser.so libhurduser.so"))))
- #t)))
+ " libmachuser.so libhurduser.so"))))))
+ (add-after 'install 'create-machine-symlink
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out"))
+ (cpu "i386"))
+ (symlink cpu
+ (string-append out
+ "/include/mach/machine"))))))
'())))))
;; Shadow the native "kernel-headers" because glibc's recipe expects the