summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/vulkan.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/vulkan.scm b/gnu/packages/vulkan.scm
index b0d968938b..1d2e58f1d4 100644
--- a/gnu/packages/vulkan.scm
+++ b/gnu/packages/vulkan.scm
@@ -228,8 +228,10 @@ interpretation of the specifications for these languages.")
(build-system cmake-build-system)
(arguments
(list
- #:tests? (not (or (%current-target-system)
- (target-riscv64?)))
+ ;; As many as 23 tests are expected to fail per architecture.
+ ;; Limit the tests to those architectures tested upstream.
+ #:tests? (and (%current-system)
+ (target-x86?))
#:configure-flags
#~(list (string-append "-DVULKAN_HEADERS_INSTALL_DIR="
(dirname (dirname