summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/vim.scm23
1 files changed, 8 insertions, 15 deletions
diff --git a/gnu/packages/vim.scm b/gnu/packages/vim.scm
index bed9783281..b468347380 100644
--- a/gnu/packages/vim.scm
+++ b/gnu/packages/vim.scm
@@ -834,22 +834,15 @@ through its msgpack-rpc API.")
(sha256
(base32
"1f8h8m96fqh3f9hy87spgh9kdqzyxl11n9s3rywvyq5xhn489bnk"))))
- (build-system gnu-build-system)
+ (build-system copy-build-system)
(arguments
- '(#:tests? #f
- #:phases
- (modify-phases %standard-phases
- (delete 'configure)
- (delete 'build)
- (replace 'install
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (vimfiles (string-append out "/share/vim/vimfiles")))
- (for-each
- (lambda (dir)
- (copy-recursively dir (string-append vimfiles "/" dir)))
- '("compiler" "doc" "indent" "ftdetect" "ftplugin" "syntax"))
- #t))))))
+ '(#:install-plan
+ '(("compiler" "share/vim/vimfiles/")
+ ("doc" "share/vim/vimfiles/")
+ ("indent" "share/vim/vimfiles/")
+ ("ftdetect" "share/vim/vimfiles/")
+ ("ftplugin" "share/vim/vimfiles/")
+ ("syntax" "share/vim/vimfiles/"))))
(home-page "https://gitlab.com/Efraim/guix.vim")
(synopsis "Guix integration in Vim")
(description "This package provides support for GNU Guix in Vim.")